Can't Create New Foundation Project-Duplicate Pages Found on Your Server-BUG? - SOLVED


(Jody Joy) #1

Please provide a few details in the following format so we can help you as quickly as possible!

RW 7.0.2
Foundation 1.7.2
Mac OS 10.11.5

Suddenly I can’t create a new project using Foundation. When I add a Site Styles stack, then Header Pro and move from Edit to Preview I get the following error

. I have upgraded to latest Stacks-3.1.0 I have used Transmit to search for the indicated files, but it doesn’t show up with any results. I only have 1 Foundation project so far, and I can Preview that without the error message. It is only happening when I create a new project. How can I troubleshoot?


(Jody Joy) #3

Just to update, this occurs when adding a Site Styles stack to the project. No files exist on the server, no folder on the server has been created no info other than default in General Settings… Only when adding a Stacks page and then a Site Styles stack is this occurring. I have a post about this on the Foundation forum and Joe is aware. I just want to post here for RW devs as well.

OK, this was solved. The error occurs when a Foundation stack is put in a new project PRIOR to the Foundation theme being selected.


(Jeffrey Shaw) #4

That’s not a solution for me, but I am using Foundation as a page-specific theme in an otherwise non-Foundation project. I add a Stacks page, select Foundation as the page-specific theme, add the Foundation Site Styles stack and boom, there’s the duplicate pages error.


(Iain Sloan) #5

Tried selecting the Foundation Theme first but still get the error


(Brian LaPan) #6

Send a query to the good folks at joeworkman.net and I’m sure they’ll sort you out.


(Jon Balke) #7

Hi I started using Foundation now and building a test site for practice. I am stuck now with this duplicate pages message blocking all my previews, with none of the buttons functioning,like Shoormal and Powder keg. Was this solved, somehow?How do i get rid of that?


(Doug Bennett) #8

Are you getting the same message above? Duplicate PHP and HTML? You will need to delete one of them. More than likely you added a stack to the page that requires PHP, you can check the page inspector for the page in question and see if it ends with PHP extension, if so delete the HTML file.


(Jon Balke) #9

i am getting the same message yes. But neither button does anything, and “the server” is not specified and I haven’t set the publishing details yet, so I don´t understand what pages this is referring to, so I can’t delete them if these buttons dont work.
uh…?


(Jon Balke) #10

and when clicking on the link to the php file i get the message that this page does not exist. So why the message, then? All the stacks i used were Foundation (site styles, top Bar and 1 column), so this must somehow be rooted there


(Robert Ziebol 🖖🏼) #11

Be sure you have chosen the Foundation theme in the theme drawer.


(Jon Balke) #12

OK. Thanks. I had selected it, but somehow that selection slipped.Don´t know why, but…That solved it.


(Matthew Hirte) #13

Hi Jody or anyone who might be able to help out.

I’m having the same problem except there is no selection for “Foundation” in the “themes list”. How do I import “Foundation” into the “Themes” list ? :sunglasses:


(Robert Ziebol 🖖🏼) #14

Get the Foundation theme here:
https://foundationstacks.com/theme/
Download it and install it by either double clicking the theme or dragging and dropping it onto the RapidWeaver icon. Restart RW (just to be sure) and try to select the theme from the themes list.


(Matthew Hirte) #15

Hey thanks Robert ! I will give this a try. Let you know how it goes. :relaxed:


(Jody Joy) #16

Hi Matthew, Foundation is a free theme from Joe Workman with basic stacks which you need to install as Robert suggests. You can purchase additional Foundation stacks but I suggest taking a look at all the absolutely fabulous stacks that are put out by Andrew Tavenor at Big White Duck: https://bigwhiteduck.com.


(Matthew Hirte) #17

Thanks Jody. You and Robert have been very helpful. cheers ! :sunglasses: