Can't get easycms to work


(Chris Noome) #1

Desperate for help…

I can’t even get the easycms demo file to work.

I load the demo into rw, and then publish. The result: the pages load up, click on ‘admin’, change a text and click save - the green ticks appear. Then return to the ‘content’ page and get nothing but ‘Unable to load cms file with the id …’ for all the content.

Have contacted jw support but no solutions found yet.

site: http://learningopportunities.co.za (please try for yourself - site contains nothing but easycms demo)

Ubuntu 15.10, php 5.6.11, apache 2.4.12

On jw support recommendation have changed the total_cms folder to permission 777 (which I do NOT want to have to do) but still no functionality.

PLEASE can someone help…

Chris


(Jon C. Munson II) #2

Do you need to set up the domain with Joe?


(Chris Noome) #3

shouldn’t need to - it’s easycms not totalcms…


(Robert Ziebol 🖖🏼) #4

OK, found your issues, we have a nice tool that Joe created to help in situations like this, and here is what it says:

TotalCMS Debug Info
You do not have the PHP gd extension enabled
curl extension is not enabled on this server.
Failed to create TotalCMS directory: /total-cms
PHP version: 5.6.11-1ubuntu3.1
HTTP_HOST: learningopportunities.co.za
SERVER_NAME: learningopportunities.co.za

So looks like you will need to contact your host and ask them to turn on the PHP gd extension and enable curl.


(Chris Noome) #5

hi

just installed curl & gd2

rebooted the machine

error persists

please debug again…


(Robert Ziebol 🖖🏼) #6

Still says failing to create the TotalCMS directory, forgot to add you need to be sure the permissions on the folder are set right so it can do that.


(Chris Noome) #7


(Robert Ziebol 🖖🏼) #8

I believe you need to have the place where the content is trying to be made, and that is not it. Since it is on your root, that is the folder you need to check


(Chris Noome) #9

where is that? as far as i understand the stack does not try to access anything that is not in the public web folder - your support guys told me to look at the folder (as shown in the path on the image). if you have another place, you need to tell me where it is.

NB: This is NOT a site i have created, it is your unmodified demo that is not working.


(Robert Ziebol 🖖🏼) #10

Since our support guys are me and Joe, and I know I did not tell you to check permissions on that folder, it must have been Joe, but I do not think he did either. Can you show me a screenshot of the root of your server? See mine as an example.


this is where it needs to create the cms-data folder, so the permissions on this folder is what need to be 755 at least.


(Chris Noome) #11

quote from e-mail:

Robert Ziebol, Dec 3, 22:26:
Hey Chris,
There are a couple of issues on your server that is causing this.

First, curl extension is not enabled on this server. You need to contact your host and ask them to turn that on.

Second, the TotalCMS lib directory is not writable. Please fix the permissions on the directory: /var/www/html/easycms/rw_common/plugins/stacks/total-cms
To fix this, read this FAQ


or ask your host for help.

Robb
The Support Jedi


(Chris Noome) #12

hi

you can ftp in as jw with password jwtemp


(Chris Noome) #13

all published to the root folder this time, so don’t need the easycms part of the path from your email.


(Chris Noome) #14

the permissions on the root web folder (i.e. /var/www/html/) are 755


(Robert Ziebol 🖖🏼) #15

Ah, well there it is! Guess I was wrong. OK, sent you a reply on your open ticket so the people of the forum do not need to see our back and forth.


(Chris Noome) #16

ok - cool - will wait for joe on e-mail but am getting a bit desperate…


(Joe Workman) #17

Try adding group write permissions to that folder. That would make it 775. If that does not work, try 777. The permissions vary based on your web server configuration. What is happening is that the web server does not have permission to create the /cms-data folder that the CMS needs to save all of the data.


(Chris Noome) #18

hi joe

please help me understand

is easycms going to create a cms-data subfolder in every folder that contains cms content or is there ONE folder for the whole site?

What i am trying to determine is which folders must have the dreaded and non-advisable 777 permission for easycms to work? I can’t use this system if it means my whole web root has to have 777 permissions (which i have just set and finally managed to get easycms to work)…

knowing how easycms manages folders and data files will certainly help to make working with it clearer.

best
c


(Joe Workman) #20

/cms-data is a centralized folder that is created at the root of your website.

I agree that 777 is not ideal. If 775 or 755 does not work, then you will need to modify your web server setup so that Apache runs as your user or as a user that is apart of a group that has permissions that create files/folders. This is not an uncommon thing to have web servers have access to create files.

You may like this video on CMS Behind the Scenes…


(Brad Halstead) #21

@joeworkman, can he manually create the folders on the server and set them to 755? Video is very helpful!

Brad