Unable to get Total CMS working... looking for suggestions [SOLVED]


(Peter) #1

Hi there.

This is my first venture into the CMS world and am struggling a bit. Hoping someone here may have some insight as to what I’m doing incorrectly.

I followed Joe Workman’s videos (which I think are well done) and thought I did everything as he did - but apparently not…

When I access the admin page on the website (this works well) and save the text - it does not appear on the page. As soon as I click the “Save button” the page automatically goes to the top (not sure if it’s supposed to do this or if this is a sign of something not right).

Here’s what I have so far:

Using the “Neat Theme”

Admin Page:

  1. Protect Stack
  2. Admin Core
    • License is activated
    • “No, I am not using Foundation :-(“ selected
  3. Site Styles stack
  4. 2 Column Foundation
    1. Tabs Stack - (Foundation Dynamic Layout)
      1. Text Stack (Total CMS Admin)
      2. CMS ID: home_content
    2. Save Button Stack (Total CMS Admin)
  5. CMS Core Stack

Home Page:

  1. Site Styles Stack
  2. Text Stack (Total CMS Content)
    • CMS ID: home_content
  3. CMS Core Stack
    1. License is activated
    2. “No I am not using Foundation :-(“ selected

Hoping someone will recognize what is wrong/missing.

Thanks for your time.

Sparky


(Robert Ziebol 🖖🏼) #2

Not sure if this will fix your issue, but why are you using Foundation stacks inside another theme?!?


(Joe Workman) #3

Do you have an URL that we can look at?


(Peter) #4

Good question.

I thought I could use stacks interchangeably… perhaps not?

Are you suggesting because I am not using the 'Foundation" theme - I should not use “Foundation” stacks?

This may explain my problem if that is true…

Sparky


(Robert Ziebol 🖖🏼) #5

Yes, the Foundation stacks only work with the Foundation theme. Other stacks will work with the Foundation theme too, but not the reverse.


(Peter) #6

www.riksart.com

I currently have the “admin” page in the header - so it’s easy for me to find and test… :slight_smile:

Thanks joeworkman


(Robert Ziebol 🖖🏼) #7

This is the big reason why it does not work

There is a debug stack you can always add to your page and remove that will give you this information.


(Peter) #8

Ah - as I indicated - I followed Joe’s video - but perhaps a little too closely (or not closely enough) - not recognizing he was teaching us how to use the CMS stack from within the 'Foundation" theme…

Thanks zeebe - that may be the issue…
Sparky


(Robert Ziebol 🖖🏼) #9

See my reply right before yours, there is another reason as well


(Peter) #10

Wow - how cool is that investigative work!

Not sure how you figured this out - but way to go!

So, where does the version of PHP come from? Is it from the server side or from somewhere else?

And how do I make sure I have the latest version?

Thanks,

Sparky


(Robert Ziebol 🖖🏼) #11

This is something your host has on there server. You might have an option to control it in a CPanel if your host offers one. If not, you will have to contact them and get them to change it. Investigation is easy, since I work for Joe I see this a lot and know what to look for if a URL is given.

Good luck on your site!!


(Peter) #12

Thank you so much!

My buddy the artist asked for a CMS site - my band site is non CMS and I really like how it works.

Oh well - always good to learn something new.

So - just to be clear - I should remove “Foundation” stacks from my non-“Foundation” themed site?

Thanks,

Sparky


(Peter) #13

Me again… jumping into unfamiliar territory - but moving forward none-the-less.

Just looked on my server settings & can change the PHP from 5.4 to:

  1. 5.6
  2. 7.0
  3. 7.1

Which would you recommend?

Thanks zeebe,

Sparky


(Robert Ziebol 🖖🏼) #14

Yes, some of the more basic ones like Paragraph and Header might work, but it would be best to remove them and use the standard stacks ones.

I would go 7.1, lots of good things in that and more and more stacks will be taking advantage of those new goodies.


(Peter) #15

Don’t think I can thank you enough…

Thanks

Sparky


(Robert Ziebol 🖖🏼) #16

Glad I can be of help!


(Peter) #17

It appears I’m not quite there…

I removed all traces of “Foundation” stacks - then completely deleted all files from server - then re-published all files.

I upgraded my php on the server to 7.1 - no luck

Tried php 5.6 - no luck

Switched back to 7.1

Still no success on getting text to print when hitting “Save”

The “Logout” button does work on the admin page…

Once again - open to suggestions…

Thanks,

Sparky


(scott williams) #18

Put the debug stack on your page and preview in RW.
The child stack will also show you the cms log file.

That should give you an idea what’s going on


(Peter) #19

Thanks for the suggestion swilliam.

I placed the debug stack on the admin page and it gives me the following information:

Mon, 07 Mar 2016 06:40:49 -0800 : Saving new content to /text/title1.cms
Mon, 07 Mar 2016 16:33:09 -0800 : Saving new content to /toggle/toggle.cms
Mon, 07 Mar 2016 17:27:01 -0800 : ERROR:PHP ERROR [2] Invalid argument supplied for foreach() (/home/joeworkman/websites/sandbox.joeworkman.net/total-cms/blog/post/index.php line:227)
Tue, 08 Mar 2016 13:55:09 -0800 Domain registered
Tue, 08 Mar 2016 13:55:09 -0800 Passport check succeeded
Thu, 10 Mar 2016 16:51:12 -0800 : Saving new content to /text/content1.cms
Thu, 10 Mar 2016 16:51:26 -0800 : Deleting cms data for feed/totalcms/totalcms-1449610398.cms
Thu, 10 Mar 2016 16:51:26 -0800 : Deleting cms data for gallery/feed-totalcms/feed-totalcms-1449610398.jpg
Thu, 10 Mar 2016 16:51:26 -0800 : Deleting cms data for gallery/feed-totalcms/feed-totalcms-1449610398.cms
Thu, 10 Mar 2016 16:51:26 -0800 : Deleting cms data for gallery/feed-totalcms/feed-totalcms-1449610398-th.jpg
Thu, 10 Mar 2016 16:51:26 -0800 : Deleting cms data for gallery/feed-totalcms/feed-totalcms-1449610398-sq.jpg

All with the incorrect date mind you…

Did I do this correctly?

Thanks,

Sparky


(Peter) #20

And now this nugget of information just appeared on the bottom of the admin web page:

Warning: file_get_contents(http:www.riksart.comcms-data/cms.log): failed to op

Sparky…