Can't Get Twitter Embed To Work


(Michael Thibault) #1

I copied the HTML code from the Twitter publish.twitter.com/# page and pasted it into and HTML stack and all I get is a hyperlink. I tried a text stack as well and got the same result. Am I doing something wrong? Shouldn’t I be getting the timeline?

I’m on Rapidweaver 6.4


(NeilUK) #2

Link?

No link = can’t help you.


(Michael Thibault) #3

Doh! Here’s what I get from Twitter publish:

Tweets by AngryWHStaffer

Should I just be able to paste that right into an HTML stack? Or am I missing code?


(Michael Thibault) #4
<a class="twitter-timeline" href="https://twitter.com/AngryWHStaffer">Tweets by AngryWHStaffer</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>`Preformatted text`

(NeilUK) #5

I just tested the code on my test site and it works. You shouldn’t include the “Preformatted text” part, but that didn’t stop it from displaying.

I just inserted the code into an HTML stack.


(Michael Thibault) #6

That’s weird. Here’s what it looks like when I paste it into an HTML stack:

http://imgur.com/tRbbWHe

And here’s what I get:

http://imgur.com/bmcdE2s

Maybe it’s a bug in Rapidweaver 6.4 (15176)?


(Jason Bostick) #7

That link - is that what it looks like published? In Preview?

I get that link in Edit view (after clicking out of the HTML stack) but it Previews and publishes as a timeline. Here is mine (with a few added styling tweaks):
Here’s the HTML stack:

Here’s Edit mode:

And Preview mode:

(I am in RW 7.3.1)


(Michael Thibault) #8

I manually entered your code:

Tweets by GoLidz_ Preformatted text

And all I got was:

Tweets by GoLidz_

And it wasn’t even a link. I really have no idea what’s going on. Either RW 6.4 has a bug or the Tesla theme I’m using does.


(Michael Thibault) #9
indent preformatted text by 4 spaces   Tweets by GoLidz_ <script async src=“//platform.twitter.com/widgets.js” charset=“utf-8”></script>

(David) #10

Are you using “paste as plain text” or “clear formatting”? If not give “paste as plain text” a try. Looks like you may have “curly quotes” turned on.


(Michael Thibault) #11

I just tried that but it didn’t do anything different in either an HTML stacker a text stack.


(Michael Thibault) #12

Yes, that’s what it looks like when I preview or preview in a browser.