Can't publish : exception while exporting site


(bart vosters) #1

I can’t publish my site. I get this message :

exception while exporting site : -[NSAlert runModal] may only be invoked from the main thread. Behavior on other threads is undefined.

What can be wrong ?


(bart vosters) #3

nope. The same message.


(Jan Fuellemann) #5

Are you using plugins that may be outdated? Like an old PlusKit?


(bart vosters) #6

all my plugins are updated. The problem occurred after updating tot the latest RW version.


(NeilUK) #7

I had problems publishing with 7.4. Single pages, no problem. Whole project, no way.

Reverting to 7.3.3 took all the pain away.


(bart vosters) #8

How do I go back to 7.3. ?


(NeilUK) #9

You can download it here. I normally just install the old version over the top of the existing one.


(bart vosters) #10

thanks. installed 7.3.3 but still the same error :confounded:


(NeilUK) #11

I’m not sure what the problem could be then. Maybe time to email support?

Good luck


(bart vosters) #12

already send them a mail. Just waiting now for their answer.


(Simon Maddox) #13

Hi @Bartje,

Is there any chance you could zip up your project and email it to support@realmacsoftware.com? Let them know I sent you, and they’ll pass it on to me.

Either RapidWeaver or one of the plugins you’re using is being naughty. If you send us your project file, we can identify where this issue happens and hopefully fix it ourselves or prod the right person :slight_smile:

Cheers,

Simon


(bart vosters) #14

thanks @simon. I’ve sent you the file with Wetransfer.


(Dan) #15

Hi @Bartje,

Hmm, I can’t seem to find your email in our support system, can you re-send it to me - dan@realmacsoftware.com along with a reference to this thread.

Thanks
Dan