Publish, unable. RW 7.2.2


(Bernt-Viggo Valeur) #1

One of my RW sites does not publish. It just quits. The stuff I entered or edited and saved was still there but no publishing.
Any ideas


(Isaiah Carew) #2

Without any specific info about the problem we can probably only offer general tips and wild guesses. With a bit more info we can probably provide more concrete advice:

  1. When you say “just quits” you probably mean crash. There is usually a crash report. Sharing that would be helpful.
  2. Are there any error messages?
  3. What version of macOS are you using?
  4. Are you using any plugins? If so which and what versions?

Some general tips for understanding the problem:

  1. Try a default file. With no extra plugins or themes – just the defaults. This will help you know if it’s specific to one of your plugin pages or themes.
  2. Try export the site (instead of ftp). This will let you know if it’s related to FTP.
  3. Make a copy of the file and delete everything but the homepage. Publish/Export that. If this works you know it’s specific to one page and it’s not the homepage.

If you can get to a place that works, you can slowly add things back to track down what’s really causing the problem.

If none of this helps I’d recommend contacting support folks and send them a copy of your file. If you’re using only RapidWeaver then you should contact Realmac. If you’re using Stacks you should contact http://yourhead.com/support


(Andrea Vitali) #3

I had this problem as well… then switched from ftp to sftp or ftps and worked… flawlessly even on providers where it was always a pain in the a*s!!


(Bernt-Viggo Valeur) #4

Attn Isiah Carew

  1. When I say “quits” I mean “quits”. On pushing “Publish” RW totally quits and I have to reload it again via the RW App.
  2. See enclosure below
  3. OS X El Capitan, v. 10.11.6. (RW v 7.2.2)
  4. See enclosure below

Regards,

Bernt-Viggo Valeur
Thomas Heftyesgate 52
0267 Oslo, Norway
+47 901 61 110
bvvaleur@online.no


(Isaiah Carew) #5

i understand now. This sort of unexpected quit – where it shows the “something went wrong” is what developers call a crash. But whatever you call it, it’s definitely a bummer. :wink:

That shouldn’t be happening. It’s a bug.

One thing I notice from your screenshot: There are three resources in the sidebar that show the warning icon. This usually means that RW can’t find those file/images any more. You should probably correct that as soon as you can.

But I think we’re probably at the end of the road about what I can tell you on the forum. I’d recommend sending the file over to http://yourhead.com/support.

To send it you should zip up your file and you entire addons folder (yes, I know it might be big). Share a link to that file with our support folks with your favorite sharing service (we like Dropbox).

With the file and addons in hand, we should hopefully be able to see the crash happen and give you more precise info.


(Andrea Vitali) #6

Hi @bamse6540, i had a similar problem some days ago. Then I’ve started publishing just pages with subpages to find out which page actually was the cause of the problem. Once found the criminal page, the problem was solved in a breeze…

It was a corrupted plug-in that stopped working, I’ve rebuilt that page with stacks and improved it.
This is the new page: http://www.blumenhofer-acoustics.com/Support/FAQ/FAQ.php