Catalina Release Version and RW Plugins Problems


(Frank Marten) #1

I have tested the release version of MacOS 10.15 and have found that, like previously reported under the beta versions, a number of plugins do not work as they are being blocked due to “not from an identified developer”.

I noted some terse responses previously and assurances that these issues would be addressed but I guess not.

In my case, the offending plugins are:

Rapidweaver Plugins not Working

Collage2: Couldn’t obtain plugin principal class — Yourhead

EasyTubeGallery: Couldn’t obtain plugin principal class — Cosculture

FormLoom: Couldn’t obtain plugin principal class — Yadab

Lockdown: Couldn’t obtain plugin principal class — Yourhead

Mobilize: Couldn’t obtain plugin principal class

PlusKit: Couldn’t obtain plugin principal class — Yourhead

RapidSearch Pro: Couldn’t obtain plugin principal class - Nimblehost (Will Woodgate)

SiteMap: Couldn’t obtain plugin principal class — Yourhead

Waterfall: Couldn’t obtain plugin principal class — Nimblehost

WP-Blog: Couldn’t obtain plugin principal class

Hopefully these can be addressed. In the meantime, I will have to stay on Mojave.


(Alex) #2

Just upgraded to Catalina too.
This is what I get when I run RW.
Am running the latest releases of the latest versions of PlusKit & FormLoom.
Almost all my sites use either one or both of them. This is bad. Real bad.
Now Googling how to roll back to Mojave…


(Joe Workman) #3

(Frank Marten) #4

I only installed it on my MacBook and still have the Mojave installation on the iMac. However, I am in the process of setting up the RW installation and all plugins and stacks in a VM.
Hopefully you had a backup before you commenced the update and only need to roll back to that. I always create a complete backup with SuperDuper as well as Time Machine.


(Frank Marten) #5

Good to hear “on a furious plugin releasing bent”.
In the meantime, safest to not update to Catalina or do what I said, have a VM installation.


(Joe Workman) #6

Uninstall MetaMate. The plugin is dead.


(Alex) #7

It has reminded me how much old stuff I’ve never got rid of. Now’s a good time to clean, including MetaMate. But some of the others are across most of my sites.
I checked these forums before upgrading & all seemed well. Its just a bit… disappointing.
Rollback time.


(Tom Bradley) #8

Hey all,

Apple have just released macOS 10.15 Catalina without any warning so it’s come at a complete surprise to us.

Gatekeeper in macOS 10.15 now requires plugins to be signed by the plugin developer otherwise the system will reject them. Please be careful when upgrading to Catalina if you rely on old plugins. Some plugins are no longer developed and as such will never be compatible with macOS Catalina.

:frowning:


(Alex) #9

By ‘complete surprise’, do you mean gatekeeper has just started doing this & didn’t do so in all the Betas released since June?
Its reminded me nicely never to be an early adopter, especially when there is false reassurance that everything is fine. I hope the solutions are easy to implement for developers.


(Tom Bradley) #10

Sorry, I didn’t mean to cause any confusion. We were unaware that Apple had released a GM of Catalina and were planning to go live with it.

There was a time when Apple OS updates would ‘just work’ but in recent years every update has been problematic. They’ll get fixed in time but I can’t recommend that anyone updates the day a new OS is released. Wait until the .1 or .2 release and you’ll have a much smoother experience.

This plugin load problem was identified during the Catalina beta period. 3rd party developers should be correctly codesigning their plugins and ensuring they continue to work in macOS Catalina.


(Doug Bennett) #11

Catalina is going to be a very bumpy upgrade for many users. I would definitely wait it out for a while, give software developers time to make adjustments and updates.

Keep in mind in addition to the gatekeeper issues no 32bit apps will work. So if any other apps that you use are still 32bit they will stop working.

iTunes has gone away. Replaced by other apps, any apps that run against your music library like de-dup and AppleScripts probably won’t work.

So I’d definitely recommend waiting on this upgrade.


(Dave) #12

Well I am stunned! Rapidweaver on my MacBook Pro (just updated to Catalina) is unuseable! If I select some text and right click on it to add a hyperlink it crashes and closes. If I try to add a Page Title the text field loses focus after every character and I have to reselect the field before adding the next character. Often I select the preview view and all I get is a blank white page! This is after 20 minutes of testing, what else will I find?


(Mathew Mitchell) #13

See @teefers comment above. I really have no idea why anybody is upgrading to Catalina at this point. I’m waiting at least 6 months. Rapidweaver is unlikely to be the only app you have problems with. Apple really hasn’t helped developers when how they rolled this out.


(Will Woodgate) #14

This free app can scan your computer and tell you what 32-bit apps are still installed and need upgrades or swapping for something newer:
https://www.stclairsoft.com/Go64/index.html

It found 18 on my computer that are Catalina incompatible. Some are little utilities like colour pickers, icon generators, screen rulers and file converters. Others are bigger apps, like the software I use for my weather station and some of the highly specialist Python / science environments I use. Some are really important things like the Logitech control centre for my mouse and keyboard!

So I’m not going to install Catalina for a while yet. My advice is the same for anyone else who does not want to take on the role of becoming a beta tester.

And to be brutally honest, the feature list I saw earlier on Twitter did not excite me enough to make me think I had to get Catalina on my computer today.

Most average consumers would be better waiting for the .1 or .2 updates first. And give indie developers the time they need to research and properly fix any potential problems. Apple seems to have just dumped this OS update on users with little quality control or forward planning IMO.


(Dave) #15

Well the beta versions have been around for ages and all other apps I have tried so far have been updated to work with Catalina, May I wasn’t paying attention but was there a warning to rapidweaver users not to upgrade? In the meantime I will install a Mojave VM and run from there.


(Mathew Mitchell) #16

The betas have not been around for ages, but they have been around a few months. And they have had historic problems for many people: not just the RW community. These problems have been widely reported. So yes, I would say you weren’t paying sufficient attention.

To be fair, this is a major problematic upgrade. This has not been typical behavior in the past with OS updates. Typically I might wait a month before upgrading to a completely new version. But with this one: it’s going to be several months to a year. I know what I have to lose. I’m not seeing anything I really gain from upgrading. Lose lose all around for me.


(Dave) #17

Anyhow, I don’t want to bleat on about it but there was no explicit notification from rapidweaver that users should not upgrade to Catalina, surely someone tried it on the Catalina betas and saw the problems? Reverting OS is not a trivial issue so a Mojave VM is my only recourse for the time being.


(Doug Bennett) #18

RealMac has a beta 8.4 that should work with Catilina,


(Andrew Tavernor) #19

@jwDave Both RW7.5 and RW 8.3 are working fine for me with 10.15 Catalina on my 2017 MacBook Pro (which is not my main machine).

I know of several other people who are also running it without issue so it certainly does not seem to me as though there should have been an explicit notification to not upgrade.

I would however agree with @willwood regarding installing it on anything other that a spare machine just now.


(Will Woodgate) #20

You should not have that still installed. Please delete it now. I should add that the plugin was previous developed by Jonathan Head and has not been updated in about 5 years. No surprise that it does not work for you any more. I’ve never had ownership of the plugin. Only the RapidSearch Pro stack, which is now retired in favour of the RapidSearch Live stack.