Changes only on preview

Hi everybody,

I am using RW8 with Foundation.

I have made some changes on my about page and I have hit the published button. The changes didn’t show, so I published many times and I have tried Re-publish all files. But again nothing.

The interesting part is that on preview the changes are correctly showed.

Inside RW

Live website

It is those two small logos at the bottom of the right column that don’t seem to like being live on the my site.

Any ideas?

Looks like you are on CloudFlare did you Purge the Cache?

1 Like

I haven’t.

In fact, another strange fact is that after I re-published all, in the “About” page I got a old banner coming back (I used to use this before yesterday when I made the changes) instead of the actual simple banner I have created and that I published yesterday.

Inside RW (new banner)

Live website

So, I guess your point is accurate: I need to cache from CloudFlare.

And then I guess I need to re-publish page, isn’t it?

Thanks for your support

Chances are if you have published everything it may not need to be republished.
When you use CloudFlare and make changes to a site, you need to log on to your CloudFlare account and select Cache and then Push. the “Purge Everything” button. If you don’t then all or part of the site will get servered to the user from CloudFlare’s Cache. When you select “Purge Everything” CloudFlare will go out to your server and refresh what it has cached.

IF you are making a bunch of changes then farther down the CloudFlare Caching Page there’s a switch called Development mode. This temporarily “turns off” CloudFlare Caching and goes to your server for every request. This is useful if you need to see changes immediately. Once enabled, Development Mode lasts for three hours and then automatically turns off.

1 Like

I clicked the “Purge Everything” button inside CloudFlare and a thin green window at the bottom of the page confirmed the action, but my Development Mode settings was ON.

So, I waited the suggested 30 seconds to make any changes and I then went inside RW and published the single page “About”.

No changes happened unfortunately. May it be because my dev. mode was ON when I Purged Everything inside CloudFlare?

And by the way, thank you for the info!!. While I knew that I need to turn ON Development mode, I had no idea that is best to Purge Everything as well inside CloudFlare.

If you have Deveopment mode on then you shouldn’t have to purge everything.

If you are sure you are logged into the proper site on cloudflare and are in development mode, then I would look next at your web server and make sure the files did get published correctly to the proper location. You can use the hosting company file manager or a stand alone FTP application like Transmit or FileZilla.

1 Like

I am logged into the proper site with CloudFlare, but now that I think about it… short after I log in into CloudFlare I always get an email from CloudFlare saying:
“Hi, Your security is very important to us. This email address was used to access the Cloudflare dashboard from a new IP address”.

Can this be the cause of this issue?

Hello Doug,

I went to File Manager - Public_html - About - and I have found the two logo I am trying to upload, as well as the background image (the green vegetables image) that I used to have as the background of the green shaded banner in the right folder (at least it seems to me, as it is within the About folder).

So, it does seems that RW upload the file in the right place.

What could be then the issue causing me not to see the changes?

Also, I tried to make a small change in the homepage and published the changes no problem. The issue seems to affect only that page.

Have you tried republishing all files?

I’m looking at the about page and CSS for the stacks page hasn’t been changed since May 20th. However the home page was changed today at 17:52 GMT. The also have differnet Cache busting link values (part after ?rwcache).

So it appears that the page didn’t republish at least not completely.

1 Like

I tried republishing all files yesterday, but it didn’t make any changes in the About page. Actually, by doing so, somehow the old green banner that I used to have since few days ago, popped up from nowhere in replacement that the new plain green one. lol

I am trying and trying again publishing the page, but nothing… It doesn’t seem to respond.

I wonder if by copying and pasting the page in a new page in the RW project, while deleting this About page both in RW and File Manager could resolve the problem…

Or there is some strategies that we can try ?.

Thanks for your support.


Sound like browser cache problem. Try viewing your newly published page with browser in ingocnito/private browsing mode.

Are sure you are not using Cloud sync for local back up? It can sync your project file in real time and give a headache.

If you made major changes on page you need to use FTP client or login via hosting provider to remove same page and then just upload that page again. RR publish does not ’remove’ content.

Hope this helps.

Edit: oops you already had better help.

1 Like

I would probably try and publish the site to a local folder as a next step. I’m not at my Mac right now but if I remember the page in question uses PHP so unfortunately to view the locally published site you would need to use MAMP. The free version would work for what you need.

Anyway that would be my next step, that way you can mess around a bit without messing up the entire live site. If you get it working okay on a localhost like MAMP then you can use a stand-alone FTP app like transmit or FileZilla to try and publish the site. I would probably at that point delete the old stuff on the server(at least for the directory for the page in question) and then publish with the ftp client.

Make sure you have a backed up of the files on the server prior to deleting anything.

I can’t look at the directory structure on the server but another thing I would look at is the folder names in RapidWeaver. This is where publishing locally might give you a clue. Even without MAMP running you should be able to look at the directory list (folders) on the locally published site and compare to what’s on the server.

1 Like

I tried this, but the changes are not showing anyway.

I don’t know what that is, so I guess I am not using it. lol

I am forward with this method!.

Thank you Doug.

I decided to execute actions directly on RW, but I will keep in mind and is a valuable thing to know about.

What I have done so far is:

  • copied the page in another “Test” project and deleted the page from the OG (original) project
  • I then deleted via File Manager the page from the public_html folder
  • I published. When I went to click on the page a message 404 appeared abviously
  • I then created a new page in RW and pasted all the stacks from the “Test Project”
  • I finally published, but now I click to the link of the page from the menu I get this message:

How can I get this solved ?

Edit: allright guys. I got it !!!. Simply the URL linked in the menu bar wasn’t the same of the page set-up in the page-inspector. The page is now showing very well. I need to thank you all @teefers & @TapioMichael for your help and information. Cheers :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.