Solved / Rapidweaver publishes website – but not all changes are visible

Hi everybody,
Recently I have come across a new problem: Sometimes, after publishing, some changes aren’t published, no matter what I do. Although RW says “Publishing complete” and everything occurs to work perfectly normal. It has happened twice now (perhaps more often, but I haven’t checked everything on my large website) and what I find strangest about it is that the problem occurs absolutely randomly. On one occasion a new banner image, which shows correctly on my project file and is installed just exactly as all my other banner images have ever been, will just not show up online after publishing. Now, I just found out that a new date that I have been adding as a label item in a dropdown menu in FormSnap won’t show up after publishing. It’s all there in the project file – but not online. And again, RW tells me “Publishing complete”.
I have recently (stupidly) updated to Big Sur. Ever since RW has been crashing more often than it used to but otherwise it works OK and I haven’t made any major changes to the architecture of my website. Recently, however, for some hours RW failed to publish anything to my server – but then at least it told me that it was unable to publish. What is going wrong here???
Help is much appreciated! Thanks a lot in advance!


It sounds like you are experiencing two different problems.

The first is where changes get published - the” Publishing Complete” message, but the changes don’t appear when you view the live website. I guess that the changes are probably published, but you’re viewing the older content from the browser’s cache. So try viewing the site from a different computer, a different browser, and try clearing the browser’s cache. How you clear the cache varies from browser to browser. You can search for what browser/device that you are using.

If the browser cache is the issue there are browser extensions available for Chromium browsers and Firefox that make clearing cache simple.

If that’s not the issue then post back here with a URL and maybe some screenshots of what you changed and what you see.

The second problem, not being able to publish will require you to give us some more details for folks to help.

  • Name of hosting company
  • screenshots of the publishing settings, and the error message
1 Like

Hi Doug,
Thanks for your very fast help!
Well, this is what I first thought of too, although usually this never happens when I publish something in RW, normally I can view changes in Safari right away. So I had hit the reload button again and again but nothing changed.
Now, actually a client of mine reported the issue with the date that obviously hadn’t been published. I first checked because I thought it was probably my mistake and I had forgotten to change the date in my RW project. But there I found it had been renewed already! And since I had done that I have actually done numerous uploads onto my server. I tried again immediately, but same result: it won’t change online. And as it was a client who found it, this means it can’t be my cache…
I will go ahead now and do the screenshots you’ve asked for!


My RW file (uploaded “successfully” many times):


Reloading doesn’t clear the browsers cache on any browser.
Have a look here:

Not saying that the issue, but it’s a common misconception that reloading clears cache.

If the problem still occurs, then post back here.

Clients have cache also. There are ways to set up expiry dates so clients cache will expire.

Not sure why on the screenshot you blocked out the URL and path. That’s common areas of errors. Without a URL the second screenshot doesn’t help much.

And the name of the hosting company is?

OK, thank you! Sorry for blackening out the URL – I just thought it feels bit weird to publish all my website’s publishing data? But of course, nothing to hide – I was just a bit concerned as I am really not too knowledgeable about these things. So here’s the full screenshot:

– deleted –

Just cleared the cache, following your instruction. Nothing changed.

Can you click browse and check if the path is correct? In my opinion it should not have a .ch at the end… /www/ might be sufficient. You might publish in another folder than you wanted to…

And here’s the other thing that just won’t show up online…
Picture 1: On my RW file (all normal, as dozens of other pages’ banners)
– deleted –
Picture 2: Online. The old version. Whatever I do – the new picture won’t show. This was the first time I had realized this problem (perhaps a week ago):
– deleted –

Seems like… at least it opens the folders on the server, when I do!

If RapidWeaver is showing that the changes were published okay, and you have cleared the cache and the changes don’t appear, then my best guess would be that they are being published to the wrong place.

If RW can’t publish, it should give you an error message. FTP protocol has no way to know if the destination path is the same directory that the domain is pointing at.

Since you haven’t said who the hosting company is or provided a URL to the page(sj that the changes are not showing up on, it’s hard for me to help.

If your hosting company has a file manager then you manually check to see if the files are updated. You can also check with them about the path.

My goodness – I just realized: I had marked exactly these two pages as “draft”!!! For whatever reason!
Of course, this way it didn’t publish…
I think I owe you guys something! Sorry and thank you so much! I’ve looked at everything a hundred times before seeing this small thing being checked!

1 Like

So before closing this thread I want to use this opportunity and say THANK YOU VERY MUCH to all you out there who keep helping people like me who somehow have managed to build their websites but actually are complete dummies when it comes to all the stuff that’s behind it and who probably will never be able to contribute to this forum anything else than questions… :wink:
I really appreciate that! Cheers!!!


Maybe add the word - SOLVED - to the headline?

OK, didn’t know… Thanks!

1 Like

Leaving the URL is fine for helping with support calls but I personally would black out the username as a hacker now only has to find the password to wreak havoc on your site.

Thank you very much Nick,
I have now deleted the screenshots altogether.

I had a similar problem. After updating a PDF file that was placed in the Resources for use in a stacks button, I always got the early PDF version and not the updated one. I finally figured it out. I ran Clean My Mac which cleaned out all old caches. It then ran the updated PDF version perfectly. This was on a Macbook Pro Catalina.
David Comings

I would be very hesitant to use “clean my Mac” or like products. It will break a lot more things it fixes or “cleans”. Clearing your browser’s cache is simple. Don’t use it! Get it off your machine.

Thank you, But how do I clean out cache on Safari and Mac? I hear it is easy with Firefox.