Publishing changes not displaying live


(Brooke) #1

I’m publishing my changes to the site-- but even though rapid weaver is saying the publishing is complete the changes are not showing up on the website live. I’m trying to remove some broken links. here’s the screenshot of the rapid weaver preview- i removed the link to the “contact me” page because that page no longer exists- but when i go to the live site the link is still there… so now i have all these broken links on my site because the changes aren’t publishing. www.thesantamonicatherapist.com, bottom of the page. any insight?


(scott williams) #2

Try right clicking the page and select publish this page, see if that does it.
Assuming you are not using a cdn like cloud flair and that you only have one type of page published, either .html or .pho but not both in same folder.


(Brooke) #3

i tried publishing the single page already. i also tried “publish all files.” neither worked. i don’t know what a cdn is or if my php files are in the same folder as my html files… i’m very tech illiterate :((


(Brooke) #4

also tried “mark all changes as changed” and the updates still didn’t show live when i published it again


(scott williams) #5

Do you have an FTP client or Cpanel file manager access on your host.
If so, check to be sure that you don’t have both php and HTML file in the folder

Most times host will serve .html file by default so if you had one and now have a .php it will serve the old .html file and you won’t see changes.

Some stacks and page types need php. But RW cannot delete files from your host. So if you had a pin html page then added something requiring php, or changed the page type to php in the hud you have to manually delete the old html file.


(Brooke) #6

i have an FTP client… I had no problem publishing yesterday so php and index is not likely the issue… i published a new test page and it didn’t upload to the hosting/FTP… so i don’t think that the file type is the problem


(Rob Beattie) #7

@bls - I’ve just taken a look with Chrome and all the links at the bottom of that page appear to work fine. I wonder if it’s a browser cache issue? Try clearing the cache and taking another look. Or getting a friend to take a look. I think you’ll find everything’s actually working OK.

Rob


(Greg Schneck) #8

Caching will really mess around with your live proofing/preview. It might help to disable browser caching altogether when working on and checking your site. Find a browser extension to turn on/off caching or use dev tools.


(scott williams) #9

My understanding is links were removed but they are still showing up
if it is a publishing issue and not a php-vs-html issue (your new page didn’t upload either) then you can only check your publishing settings.

use your ftp software to look on the server and see if your file published to a different directory.

export to a local folder and move the files with your ftp program, Does that work? Did they copy to the host?

What if any plug in’s are you using? Pluskit? Stacks? is everything up to date?


(Sylwia) #10

Hi Guys,
Im not a developer, and know not much about building sites etc. but ive managed to create something. Now trying to publish it and its all wrong, can someone help pls?
I have hosting with goDaddy and using Rapid weaver 6 and page looks like this http://happypolka.eu
its a Streamline theme

ive published with diferent domain and its the same

i suspecting I need a new software or stacks any other ideas, please??
Many thanks

Sylwia


(scott williams) #11

It appears that the CSS for your site is not loading, go to file menu and select republish all files. That should fix things.


(Sylwia) #12

ive been doing that…


(Sylwia) #13

ill try to get an updated version of the theme…many thanks S