Changing Addons location crashes RW - RW wont launch.... Help Please


(Greg Schneck) #1

So I decide to change the location of my addons… I go to RW > Preference > Addons and change the location of the Addons. Upon “Restart” RW crashes and becomes unresponsive. I force quit, restart, and RW won’t run… it just shows as unresponsive.

I use Time Machine to “go back” to as it was last night. Restored the RW7 app and also the entire RapidWeaver folder (Lib>Containers>…App Support>RapidWeaver)

RW still wont’ launch. I download and install new RW7 app. Still won’t launch. It just times out…

Suggestions?


(Scott Steven) #2

find the PLIST file in your Library folder for Rapid weaver and toss it in the trash. Then startup RW again and see if it works. Sometimes this file gets corrupted on a mac. The app will replace it with a clean one and things most of the time start working again.


(Greg Schneck) #3

Nope… Trashing the plist didn’t help… And it should have worked after going back to last nights versions from Time Machine so I don’t know what is happening…

Thanks for the reply though. Appreciate it.


(Greg Schneck) #4

OK… so I Trashed RW7… Pulled the Rapidweaver folder out of Library… Downloaded new RW7… Started and entered Registrations… App seems to to working now…

Now to add back all my pluging/addons.


(Rob D) #5

It’s getting better and faster with each new version of RW (at least, according to RMS), haven’t you heard?… :stuck_out_tongue_closed_eyes:


(Greg Schneck) #6

The install on my iMac is just weird… If I allow any RW or 3rd prarty ADD ONs to “install and restart” RW always crashes at the restart and I have to rebuild something. But if I manually drop in Add On’s everything always works fine. The install on my MBP doesn’t to this, it works great. What is weird is that I have done several complete clean installs but this particular problem persists. And yes, I’ve tried with minimal OS re-start and that doesn’t help either.