Content in partials randomly changing


(LJ) #1

I’m having some problems with stacks in partials randomly disappearing or appearing to ‘corrupt’.

Using Elixir’s Abstract theme, Stacks 3, RW 6.3.8, El Capitan 10.11.4 (although problem was evident under 10.11.3 as well). Fairly large site - 50MB c. 50 pages

Examples shown in screen grabs - common thread seems to be that:

  • it only happens to content in partials
  • it’s random
  • clicking edit and then preview again seems to sort the issue on any given page
  • I have only seen this in preview and not in live site

Despite the 4th point, as a busy live site, I’m nervous of publishing in case the glitches happen live.

Any assistance much appreciated. Never had this problem before and not experienced on any other sites.



(Rob D) #2

I have noticed that, too. And I also work around this issue by clicking back and forth between Edit and Preview modes. So far, this does not affect my published site. I think it’s the Stacks bug, but I may be wrong…


(LJ) #3

Hmm - have just published a large site test site and at least 2 pages have the problem ‘live’. This is not good. I can’t go checking 50 odd pages every time… Having said this, on these 2 pages it isn’t only content in partials that is affected.


(Christi Carew) #4

It might be most helpful for us if we could get a copy of your site to see what’s going on.
Make a copy of your site, cut out any extraneous pages, and zip it up and send it to us ( support@yourhead.com ). You may need to use a service such as DropBox if it is over 1MB.
The absolute quickest way to identifying a problem, though, starts with the simplest instance. So, if you can use a built in theme and as few third-party plug ins as possible, that would be extra good.

Christi Carew
YourHead Software
http://www.yourhead.com


(Rob D) #5

I thought you might want to know. I just uploaded my entire web site (update) and everything works as expected, even though while working in RW, I had some problems described above.

RW 6.3.8, Stacks 3.0.5, all stacks and the theme updated to last versions.


(Brad Halstead) #6

@manofdogz

It would be awesome to know the stacks you are using in your partials and their layout to assist troubleshooting as in 6.3.8 with Stacks 3.0.5 I do not encounter this issue, I did in 3.0.4 though… perhaps your Stacks plugin is out of date?

Brad


(LJ) #7

No Stacks is up to date. One thing I am doing is replacing a seriously overloaded Stacks page (supplier details in approx 360 JW Floaty Stacks in Doobox Hunter stack). The page was great when smaller but has virtually ground to a halt. I’m mindful of something Isaiah mentioned about Stacks pages getting overloaded. This will take about 5 hours but has to be done.

Once done I’ll see if problems persist on that page and others. Question is whether that one very overloaded page would impact on others - I guess it could.

The stacks I’m currently using in 7 different partials are:

Doobox Text X and Header X
Responsive show/hide
JW sweet buttons
JW newsletter sign up
Elixir Ivy 2
JW cycler
Built in 2 columns

Otherwise a fair amount of Font Awesome, a search box, some ticker text on home page, a postcode search widget, a lockdown dual-members area. That’s about it. Site size c.50MB

I’m currently reworking the site structure and this in-progress site is published at www.kikk.co.uk/gatesafe. Due to be published shortly at http://gate-safe.org

Cheers


(Isaiah Carew) #8

OK. Pulling together some of the info about this from various places:

It seems there are at least 3 different things here with a similar symptom – but that are actually quite distinct.

  1. Page complexity
    Some folks have put so much on their page that the web view cannot completely render. If he problem only exists on very complex pages, then it’s time to simplify things (the people who have to load these sites will be thank you!).

  2. 3rd party stacks
    Just like all software, 3rd party stacks can also suffer from bugs and incompatibilities. If the specific stack or stack-combination can be identified then the problem can usually be worked around.

  3. Bad HTML
    In at least two cases I’ve received the problem was simply due to adding HTML to the page that had typos/bugs/etc. Test your HTML by itself before adding it to your page. Use the Safari debugger to look for errors.

  4. Stacks Bug
    Some folks have said that they’ve seen this error on simple pages without HTML. I don’t have any strong evidence of this yet, but it is still a possibility.

Isaiah


(LJ) #9

I have gone through the entire site, tidying things up. Completely replaced the overloaded ‘Hunter’ page, removed some old instances of a now unnecessary Font Awesome enabling stack, tidied up the partials headers (some older headers were still not in partials).

Unfortunately the results - at least in preview - are not good. As I go through the pages in preview mode, things randomly disappear from some partials. As before, go into Edit and back to Preview and things are OK again - so far every time.

GOOD NEWS however - the published site is behaving perfectly. This issue seems to be limited to preview. I did have some problems with a published site but I now believe that was because some elements hadn’t published


(Isaiah Carew) #10

i would love to have a look at one of the pages in that file.

i’m looking for any concrete examples of this problem.

any example is appreciated. single page examples with as few 3rd party complications as possible are :thumbsup: :thumbsup: the best.

please share with us at support@yourhead.com
thx