SOLVED: Stacks Disappearing after Editing a Partial


(Gavin Dudeney) #1

Hi,

I’ve just started a new Foundation site.

I have a header partial containing Site Styles, Font Pro (Font Families and Font Styles), CMS Core and Top Bar and a footer partial containing Footer Zero and SocialPopup.

On the page currently I have one Impact stack partial functioning as a header image, then one one-column stack partial and one two-column stack partial - both with text in them.

Every time I double-click one of the one-column stack partial and edit it, when I return to the main page view the other stacks have disappeared and I can only view them again by sticking another stack on the page, which seems to cause some kind of redraw.

Any ideas? (the two images show what I see before editing the partial, and after editing it and returning)

Many thanks in advance.

Gavin


(Isaiah Carew) #2

It looks like you have a “One Column Page” and a “Two Column Page”

I’m no familiar with those stacks, but just taking a wild guess based on their name, I’d say that perhaps only one of these “page” kinds of stack is allowed per page?

That seems like the most likely scenario given what info I can see from the couple screenshots. If that’s the case, then I’d say you should probably direct your question to the developer of that stack so that you can get specific help on how to use it.

If that’s not the case, then I’d recommend, just for the sake of getting the most out of your question here, using some default stacks to demonstrate the issue – just so it isn’t complicated with unrelated custom bits.

And if that doesn’t help, send us your file and we’ll have a look: support@yourhead.com :slight_smile:

Isaiah


(Gavin Dudeney) #3

Isiah,

Sorry for the confusion - those are just names I’ve given to the partials. The actual partials are made up of one-column or two-column Foundation stacks which have Header Pro and Paragraph Pro stacks in them - nothing fancy at all.


(Isaiah Carew) #4

Then I’m afraid I probably can’t add too much insight. The devil is likely in the details. I think I’d have to have a peek at the actual project file to give you more concrete advice.


(Gavin Dudeney) #5

I can send it on to you tomorrow - where to?


(Robert Ziebol 🖖🏼) #6

As @isaiah mentions here


you can send it to support@yourhead.com


(Gavin Dudeney) #7

Folks,

I sent it on to you earlier this morning - stripped down as much as possible.

Many thanks in advance.

Gavin


(Isaiah Carew) #8

Update: It looks like this was isolated to one of the 3rd party stacks on the page. I’ve sent you complete details. And also filed a bug report with the developer. Seems like a minor bug so I suspect it’ll all be back to working after a little update.

Isaiah


(Gavin Dudeney) #9

Really appreciate it - thanks very much

Gavin


(RWtuts) #10

Hey Gavin,

@isaiah informed us about a minor bug in our Space 2 Stack. We’ve just fixed it and pushed out a quick update. We sent out an update notification to existing users, please check your E-Mail for further details on how to update the Stack.

I guess that your problem should be solved once you install the fix, if not please let us know by using our contact form.

–M


(Isaiah Carew) #11

Thanks @RWtuts for the quick work!!!


(Gavin Dudeney) #12

Thanks to all of you for such amazingly quick and professional service. I was just extolling your virtues over dinner.

Gavin


(Isaiah Carew) #13

:blush: well shucks. thanks.


(Gavin Dudeney) #14

The thing is, you don’t often find developers working together, and when you do, you don’t find them doing it in the space of a few hours, then pushing out an update. Really, really impressive.

Gavin


(Gavin Dudeney) #15

I’ve downloaded the update, but RW reports it to be the same version as the one I have installed…


(RWtuts) #16

In this case I suggest you to remove Space 2.0 inside RW using the Addon Manager. After removing, save your current project and close RW completely. Now open up the DMG of the updated Space 2.1 and double click to install it. However, it could be possible that you’ll need to drag’n’drop the Stack to the places again you’ve used it before.

If this shouldn’t help either, please drop me a line using our contact form.

–M