Conversion from 5.4.1 to version 7?


(Mark Mason) #1

I have a project in 5.4.1 that version 7 will not open. How do I make this conversion from the old to the new? I downloaded 7 demo to learn if it would open 5. It will not. Greyed out.

Also, I lost the Geographic Theme that I used to create the 5.4.1 project. How can I replace it?


(David Walsh) #2

Can you / have you tried v.6+ to open the 5.4.1 project?
The release notes for v.6.0.7 here

  • imply that there was a change in RW file formats.

So I would try installing perhaps the latest of the v6 series then opening your 5.4.1 file and then saving it into the v6 format as mentioned in the release notes. You should then be able to open the new project file in v7.
The earlier versions are available from the Realmac site via the links in the release note file.

If you are unable to install the earlier version then it may be that someone on here might be able to do the conversion for you.

If you are going to do the conversion yourself then I strongly advise reading the release notes to confirm that what I’m saying will work for you. Obviously keep backups of all project files so that you can revert back if needed.

Hope that helps a little.


(Don) #3

@fixmacs, here’s a link to a support document on upgrading project files.

https://help.realmacsoftware.com/support/solutions/articles/36000001229-upgrading-sites-to-rapidweaver-7


(Mark Mason) #4

Thank you. This is helpful. When I try to open under V. 6 or 7 it tells me that my Geographic Theme is missing. What can I do to restore the theme that I used to create the project?


(David Walsh) #5

You probably need to install the theme file into v6 so if you don’t have it will need to dig out your purchase history, redownload the file and then install it to v6 before attempting to open your project file. I seem to recall also having issues with certain stacks when I did this process a while back so be prepared for more ‘missing component’ issues.

It can be a bit frustrating but eventually you’ll get there. Good luck!


(Mark Mason) #6

Is there a code in the RapidWeaver file itself that notes the name and version of the theme? If i open the project does it have the theme code somewhere?


(David Walsh) #7

Not sure about that.

RW must contain some info about installed themes but not sure just now where to find it.

You might be able to see some theme- related info in the header if you view source of one of your published pages.

Hopefully someone else will be along to provide a fuller answer soon.


(Mark Mason) #8

The theme is labelled Geographic.


(Mark Mason) #9

OKAY, need help here. I found the theme and loaded it onto 5.4.1, then saved, following the instructions. I then followed the instructions NUMBER FOUR---- which said to open Version 7, which I did. The instructions then tell me to ADD ON the theme but Version 7 doesn’t ask me to do anything and when I try to open the existing project file I get this error message. ---- Theme Missing.


(Mark Mason) #10


(Mark Mason) #11

Launch RapidWeaver 7, and when asked whether you’d like to copy your add ons click Copy Add-ons. RapidWeaver will copy over your themes, stacks, theme styles and other add-ons. Recent projects will not be copied over, as RapidWeaver 7 is a new app, and OS X only tracks recent projects as they are opened with each different app.

RW7 never asks me to copy the add-on theme. What should I do now?


(William Buchanan) #12

Hello Don,
I’m working to resolve a similar problem, converting a RW 6 file set in hopes of opening it in RW 7. When I follow the link suggested I rx an error message explaining this file is no longer available. Would you please post a current link to this document? Thank you.


(Doug Bennett) #13

might try:


(William Buchanan) #14

Thanks, Mark. I started with RW 7, so my mac didn’t offer the right click option described (open in application); but no matter. The document was a big help, implying RW 7 would open the rw6 directory structure and convert to rw 7. I opened the dir structure inside RW 7, and worked great. Back in bussiness now! Most helpful and thanks again!