Disappearing pages? Help!


(Stu Farnham) #1

I recently tried to open the first site I developed with Rapidweaver to do some maintenance on it. The site comprises 4 pages. If I open the site in Rapidweaver edit mode, all I can see is the first page; however, if I open it in preview mode I can see all 4 pages.

I’ve tried every preference, menu item, and UI control that I can find, but can’t make all 4 pages visible in edit mode.

Another tidbit: when I open the file, the first page shows in edit mode. If I use File->Remove page, that page is removed and the second page is revealed; if I remove that page, the third shows up, and so on.

Since this is the first site I built in Rapidweaver it is entirely possible that I did something funky that I got away with in Rapidweaver 5 but which is biting me in RW6.

It’s also entriely possible that I am having a senior moment and overlooking something obvious.

Any thoughts, ideas, or suggestions?


Content disappeared from site built in older version of RapidWeaver
(scott williams) #2

Humm… Got any screen shots?


(Brian LaPan) #3

Were you sure to follow the upgrade instructions (v5>v6)?


(Stu Farnham) #4

Here are some screenshots. The BB software only allows me to add one photo per post, so there will be three separate replies.

The first is the home page, which is the only page I can see in edit mode:


(Stu Farnham) #5

Here’s the second screenshot, that same page (home page) in preview mode
.


(Stu Farnham) #6

And the third, the About page in preview mode … This is one of the pages that I can’t view in edit mode.


(Stu Farnham) #7

I upgraded back when V6 came out and, as far as I can remember, I followed the instructions. None of the other sites I have developed have this problem, FWIW.

What’s really odd is that I have not lost any data – I see it all in preview mode. I just cant get to it in edit mode.


(Christi Carew) #8

Hi,

Can you zip your file and send it to us at support@yourhead.com ? You may need to use a service such as Drop Box. But drop us an email and we can take a look at it.

Christi Carew
YourHead Software
http://www.yourhead.com


(Doug Bennett) #9

Looks like you don’t have your source list turned on from the screen shot.

In menu go to view => show source list
( or option+command L) and see if you get your page listing back.


(Stu Farnham) #10

Show source list was one of the first things I tried. Didn’t help. Thanks


(Stu Farnham) #12

Thanks, Christi, I will do that directly.


(Dennis L. Graf) #13

I am having exactly the same problem - no matter what I do I cannot see the sidebar on the left with pages and sources - in my case i get the “home” page in edit mode. The site is working fine. In preview I can see all the pages - just can’t navigate to any other page to do an edit. Very frustrating as I would like to be able to update my websites. any help will be much appreciated. I have never had any issues with Rapid Weaver before, and have recommended it to many friends and colleagues.

Thanks in advance for your help!
Dennis


(Dennis L. Graf) #14

Also - yes - followed all instructions when upgrading - I upgraded from the previous 6 version.


(Dennis L. Graf) #15

Keep forgetting something - I get this same behavior on the sample projects provided by Realmac.


(Christi Carew) #16

Sounds like it’s not specific to Stacks, then, correct? Have you tried using a different them? I’d recommend removing all your plugin and start from scratch. If you don’t have any third-party stuff installed, does it? If so, then I’d be one of those needs to be updated.

Christi Carew
YourHead Software
http://www.yourhead.com


(Christi Carew) #17

Hi,

If you cannot choose “Pages & Resources” from the View menu and have the list of pages appear, you need to contact RealMac Software, maybe directly as I’m not sure that they’ll see this thread. I think that RealMac is aware of this issue.

Christi Carew
YourHead Software
http://www.yourhead.com


(Dennis L. Graf) #18

I found the solution elsewhere on this site - involved entering a command in Terminal that changed the way the screen displays. So now I can see pages and resources! However - that led to a new problem and its a big one. When I make a change to my site the change appears in preview mode, but when I visit the site, the change has not been made! I have changes I need to make in several sites, and this is very frustrating.


(Oscar Schmid) #19

You have cleared the browser cache?


(Dennis L. Graf) #20

Thanks - that fixed it - Hallelujah!!!


(Dennis L. Graf) #21

by the way - in case it might help someone, here is the string I executed in terminal to get my pages and resources visible again:
defaults delete com.realmacsoftware.rapidweaver6 “NSSplitView Subview Frames Main Document SplitView”

just copy the statement above, start Terminal, paste at the prompt and hit return.