"Duplicate Pages Found on Your Server." Again

You know, I dread having to create a new RW project from scratch, because every time I do I encounter the damned “Duplicate Pages Found on Your Server” error message. This in spite of:

  • not having appended .html to the Filename,


  • having set the Default Setting as php, and


  • not* having even published the page to my server in the first place.


A colonoscopy would provide more benefit than the PITA dealing with this involves. As it is, I find myself copying earlier projects that [somehow] I’ve figured out how to resolve the problem by deleting pages, and building anew.

I humbly ask for someone to kindly provide a procedure that ends this foolishness. In return, I’ll supply the name of a purgative that truly takes the dread out of preparing for colorectal screening.

Thank you for your help!

John

PS: Someone really needs to fix this problem.

1 Like

Is it possible that your hosting company automatically creates a placeholder index.html file in the root directory?

@NavionDriver I’m not sure what is going on but it’s certainly unusual. I suppose what Rob wrote (just above) could be the case. It really is possible your hosting company does this HTML file for you when creating a new site.

At any rate, based on the screenshot you provide the “fix” seems super simple: press the “Remove HTML File” button. That would seem to take 1 second and is a lot smoother sailing than a colonoscopy!

I assume what you mean is this index.html file appears once at your site’s root. Or are you saying this occurs for every single page you create?

Looking at the publishing settings you are showing, you don’t have anything filled out.

No server name, username, password, or even a URL for the website address.

So if that’s the actual settings you have when you’re hitting the publish button, then it’s not going to work anyway. The error message might be erroneous, but there’s no way foundation could be checking what’s on the server with what the screenshots show.

Also, I couldn’t help but notice that the other advanced options are kind of strange, you are using index.php but have tidy links turned off? You aren’t using minified CSS or JavaScript, no search engine sitemap, etc, etc.

Just part of the reason EVERYONE needs a real FTP application.

Actually - if you look at all the posts here concerning provider/host/publishing - everyone who wants to have/publish a website should be aware what a server is, what it does and what is necessary to have a proper setup. The all-in-one-create-and-publish idea of Rapidweaver is theoretically nice - but there are tons of hickups and problems because a lot (the majority?) of RW users have no clue WHAT they publish and to WHAT destination (path/folders) they publish. I am using RW for nearly 10 years now, using FTP (switched recently from Cyberduck to Forklift) for 8 years. I always publish to a local folder (which then is a “local backup” of the website) and I sometimes load up only specific changed pages/files - sometimes only the css part of a page. Much better concept imho. But requests that you dig a little deeper into the concept of our beloved www …
I had a colonoscopy. I prefer ftp.

Moments ago I double-checked to see if there is an index.html placeholder in the root directory of my hosting company; there is no index.html file.

Thank you, Mathew, for your reply. In response:

  1. un-commanded addition of html file into root
    About my hosting company adding an html file when creating a new site, I’d like to know how they manage to do that, since at that time of creating the new project my computer was not connected to the Internet. Since mid-2017 when I returned to RW after a decade+ hiatus, I have not seen an html file in my host’s root directory. Years ago, before switching entirely over to php in all my RW 6+ projects, I did have html files in websites running Sandvox. (A few of those early holdouts remain live, albeit in separate subdirectories.)

  2. “Remove HTML File” button
    I failed to mention above in my rant discussion that I did press the “Remove HTML File” button, but to no effect: the error message remains. Indeed, this ‘remove html file’ feature has not worked on any previous RW project of mine. (This is the source of another pet peeve: buttons in RW with the functionality of a '56 Buick hood ornament.)

  3. index.html file appears at root? or every single new page?
    The “Duplicate Pages Found on Your Server” error message appears on every single new page I create in a new project. In this particular instance, the index.html file does not appear in the subdirectory of the new project because I have not yet created that subdirectory. To test this assertion, moments ago I created yet another new project with multiple new blank pages, unpublished, with the computer disconnected from the Internet. Again, the ‘duplicate pages…’ error message appeared on each new page.

Do you have a suggestion how to proceed?

Thanks again, Mathew.

John

Looking at the publishing settings you are showing, you don’t have anything filled out. No server name, username, password, or even a URL for the website address.

I should have mentioned in my note that the total lack of settings in Publish was to show that there was no means for RW to find an html file in the site’s [future] subdirectory…because Path and Website Address were blank, and unpublished.

The same applies for the Advanced settings; I had everything unchecked and turned off to eliminate the possibility of some errant code creating an html file somehow. Normally I have those settings turned on.

I appreciate your help!

@NavionDriver Okay … so you haven’t a live site. I have no idea why you are getting those buttons … but obviously if there’s nothing on a server then there’s nothing to delete!

What type of page are you adding? Stacks? Other?

At any rate, I’ve never seen that message before. You’d have to describe more details, but I think it’s fair to say everyone looking at your post assumed your had published to a hosted location and were having problems. So we need to go back to square one.

I only use stacks … so when I add a stack as a first page to a new project I don’t get that message. I have to assume you are using a different page type or something very weird is happening.

Okay,
The message you are showing, technically isn’t RapidWeaver. It’s a Foundation message(@joeworkman) . RW8 does do the same check but I don’t think it will give you the equivalent message with an empty publishing settings.

Are you using F1 or F6?

When do you get the message, I remember that message from F1 days, but I didn’t think you got it until you tried to publish. Of course you wouldn’t publish until you filled in the server settings.

Mathew inspired me to document each step I took to produce the error message. Once I was able to reliably recreate the problem, I found a solution.

steps to the error message

  1. Rapidweaver 8.7 -> File -> New Project
  2. Add -> select Stacks
  3. Untitled Page -> Library -> add Site Styles
  4. Untitled Page -> Preview: error message “Duplicate Pages Found on Your Server” appears
  5. Preview -> click on “Remove HTML File”. Error message remains “Duplicate Pages Found on Your Server”
  6. Advanced -> Default Extension: change html to php
  7. Untitled Page -> Preview: error message remains “Duplicate Pages Found on Your Server”

new steps taken

  1. Untitled Page -> Edit -> Page Styles -> unclick Use Master Style
  2. Untitled Page -> Page Styles -> Page-Specific Theme: select Foundation
  3. Untitled Page -> Preview: no error message

I discovered that by turning Page Styles -> Use Master Style back ON deselects Foundation, and thus causes the error message “Duplicate Pages Found on Your Server” to reappear. Honestly, I don’t understand the relationship between selecting Foundation and the appearance of the error message.

Q: If the default extension is html, why does the error message find php, since the new project (with no Publish details set) does not and cannot point to a subdirectory?

Some experimentation led to the following.

revised new-project procedure

  1. Rapidweaver 8 -> File -> New Project
  2. Add -> select Stacks
  3. Untitled Page -> Edit -> Page Styles -> unclick Use Master Style
  4. Untitled Page -> Page Styles -> Page-Specific Theme: select Foundation
  5. Advanced -> Default Extension: change html to php
  6. Untitled Page -> Library -> add Site Styles
  7. Untitled Page -> Preview: no error message

If there’s a better way to create a new project, please let me know.

I thought I’d offer the following feature request to the chaps in Brighton that might streamline new-project creation:

  • add a preference to allow new project extensions default to php
  • add a preference setting to allow new projects default to a particular theme

For Mathew’s suggestions, and everyone else’s input, I thank you!


About that purgative I mentioned.

Over time, I’ve been given various laxatives in advance of screening colonoscopies, leaving me to dread the prep. GoLYTELY tasted like bilge water, Moviprep was even worse.

Pico-Salax AKA Prepopik, a product of Canada, saved my butt. It tastes like slightly-off Kool-Aid, is easy to take, and importantly, produced results that pleased the doc. Find it online here and here.

Have you setup a website address in the project settings? What is it?

Yes. This feature is built into Foundation (and SEO Helper 2)

There is the possibilty to make all new pages with extension php. Just delete html and put php in the Advanced > Default extension setup
See screenshot. It only works when the project is new and you add pages.