Duplicating a stack page causes errors

RP v8.1.2
stacks v3

  • EDITED -

What happened:
Added a new page “stacks”. Designed it. Duplicated that page. Modified it.
All looks good in EDIT mode:

  • I could modify
  • I could use the duplicated stacks page to set a link to

All looks good once the duplicated page is placed on a higher menu level than the original page.
In my example, I duplicated a stacks page on menu-level 4 (Home - submenu1 - submenu2 - original page). I need that structure on my page. When I place the duplicated page on menu-level 4 as well, the following issues occur:

Once you switch to Display Mode and try to select the duplicated page, always the original stacks page is displayed. Even the “Page Marker” left hand side is jumping to the original page which is then marked light grey.
Even worse: The link to the duplicated page is displayed correctly on mouse over in Display Mode, but by clicking it the original page is displayed.

Am I doing something wrong or is this a bug?
EDIT: Trying to work with “styled text page” -> menu-structure with 4 menu levels is all working… seems to be related to a stacks page…


Can you post screenshots similar to the one I have here that shows the settings for both of the pages – the original and the duplicate. I have a hunch I know what problem you’re seeing.

OK, here’s my hunch:

Usually I see this bug when RapidWeaver allows you to set the Folder and Filename for two (or more) pages such that they have the same complete path. So (like my screenshot) if the path is “/my/great/page/index.html” for both pages. When you switch to Preview mode you’ll see this weird behavior. Like you can’t preview one of the two pages – it keeps jumping around.

Here’s a quick way to see the bug in action:
If you set the folder of a page to “/page” and the filename is left ast the default “index.html” and you duplicate this page, then you’ll see the bug. It doesn’t matter what the page type is. It’s all in how the pages are named.

I think there’s a pretty good chance this is at least part of the problem you’re having – but if if isn’t then I’ll let you know how you can contact our support folks and share your project file with them. Then we’ll be able to understand the situation more completely and help you out.


Topic solved.
After having created an entirely new project with the required 4 menu-levels I figured out that having changed the FOLDER in General Settings in my original project caused the issue…

1 Like

Thanks for your help. After I set up a new project and all worked fine I started to investigate what I did different on my original project… sorry for this hickups!

@dan - This quirk has been around since about RW 7.1. I get email about it all the time. It’s easy to set off, just name a styled text page “/styled”, duplicate, and boom, you’ll see it. I have a nice video that demonstrates in both RW 7.5 and RW8.1, let me know if you want me to post it.


@isaiah just tried to reproduce this here, and it works just fine. Maybe I’m not doing it right.

Can you send a video of it happening in 8.1.2 ?


no prob. i made this after the original post, but didn’t want to post if it wasn’t necessary. it’s a quickly made video – just pushed record and go.

let me know if you have any questions

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.