Easy CMS error: "server responded with 0 code"


(David Walsh) #1

I set up an admin page with ECMS back in June. All was well and it worked flawlessly. It has not been touched since then but now when trying to add images and text the images appear to upload but are displayed with a red cross at base which, when hovered over show “server responded with 0 code”.

I have been unable to locate this error in the ECMS online documentation.
If anyone has seen this error and could give an idea how to resolve the issue I’d be grateful.

Have logged a call also with @joeworkman If @zeebe is around - hope you might please help!

Ta.
D


(scott williams) #2

Make sure you are on the correct site… www or no www in the url


(David Walsh) #3

Thanks Scott. Have checked and we are on the correct URL.


(scott williams) #4

next thing to do is put the debug stack on the page and then preview - see what it says


(David Walsh) #5

Thanks - will try that.

As we already have content which was added at set up via the admin page - will this content be overwritten if I upload a debug-enabled page to the server?


(scott williams) #6

no, but you don’t have to re publish anyway. just put the debug stack on the page and then preview in RW


(David Walsh) #7

Okeydoke - thanks. After adding debug and previewing I have some status lines showing up: Anything obviously wrong with this?

PHP version: 5.6.31

HTTP_HOST: www.mydomain.co.uk

SERVER_NAME: www.mydomain.co.uk

DOCUMENT_ROOT: /home/users/myuserID/html/mydomain.co.uk

DOCUMENT_ROOT (realpath): /home/users/myuserID/html/mydomain.co.uk

SITE ROOT: /home/users/myuserID/html/mydomain.co.uk

PHPRC (Strato?): /opt/alt/php56/etc

POST_MAX_SIZE: 128M

UPLOAD_MAX_FILESIZE: 128M

MEMORY LIMIT: 256M

CMS VERSION: Easy CMS v1.3.1 (5225)


(scott williams) #8

That looks like defaults, - like you never went through the registration process
(I assume your server isn’t really www.mydomain.co.uk)

when you are on the admin page;
select the admin core stack
click the register (thumbs up button)
preview
you should see a box with your domain and serial number

is that correct?

Maybe @zeebe should have a look


(David Walsh) #9

Admin core stack screencap:

  • not seeing the button you mention > elsewhere?

Thanks for your very kind help Scott.


(David Walsh) #10

… and yes - ‘mydomain’ subbed to protect the innocent :wink:


(scott williams) #11

its in the UI on the right where the normal stacks settings are


(Jason Bostick) #12

You won’t need to register with Easy CMS, I believe.

So long as you’re sure you’re not mismatching www and non-www (i.e. have www in your project but visiting the admin page with a non-www address), I’m not sure what it’d be.

I’d leave it in Zeebe’s capable hands.


(scott williams) #13

Du… Jason is right, EasyCms doesn’t have that registration my old brain was thinking TotalCms. Sorry for the confusion.

What I said in my first post and what Jason said, holds true though. you need to be sure that you are going to the same page that is set up in RW. www or non-www.


(David Walsh) #14

Thanks gents both and yes, we are matching the correct URL - indeed ECMS flags up an error if the incorrect one is used.

Hoping to hear from @zeebe or @joeworkman before too long.

D.


(scott williams) #15

one other thought, if there has been an update of ECMS you may need to republish all files (from the file menu)


(David Walsh) #16

My thanks to @zeebe for his timely help with this.

It transpires that I had not re-published the problematic pages since the site was moved across to https a few weeks ago. Robb pinpointed that there was an issue with http v https. Re-publishing with ‘https://www.mydomain.co.uk/’ as the web address in ‘General settings’ has gotten everything working again.

thought I would post this update so that anyone else who might encounter something similar might find this of use.

Thanks to all for your very kind help today.
D.