JW ECMS Help Needed

Hi all…have been tearing out what little hair I have left over this. I grasp the basics - especially the significance of correct path structure, but for some reason my admin page will not talk to my content page. In desperation, I have uploaded Joe’s demo pages to my server, and the problem persists. I don’t see any error messages when I enter text or a picture on the admin page…only the little red crosses. Has anyone had this problem? Is it my stupidity, or do I need to talk to my hosting company (who seem up to date with the php)? FWIW, the two pages display properly, so I think the RW file is configured correctly.
For those whose curiosity is piqued, the site sits at:
Thanks in hope!

Start by republishing all files from the file menu. I think some files are missing.
then if it still doesn’t work, add the debug stack to the page and preview in RW.

Thank you for looking.

I’m certainly going to add the debug stock before republishing.

no need, debug is meant for RW preview.

Now I’m just showing how naive I am…anyway, the server seemed most unhappy with the last version of the project…so I have re-reuploaded all the files, and the result is just the same (attached screenshot)

You say some files are missing…I publish to a local folder and then ftp to the destination…could that be the problem? (btw debug didn’t show me anything, but I’m not sure how it could via that method.(

Can you double check that the URL’s in your RW project match exactly (including the www) with the URL you’re using in your browser

Hi Jason Thanks for looking! Joe was most particular abut that very point…I sure I did get the URLs all correct (at one point, a capital letter caused it to break) but it is definitely worth a double-triple check, and that is what I shall do.

RW website address (General setting) is

When I hit
the homepage displays correctly, but the browser address line doesn’t include the " /index.php/".

If I then add /index.php/ to the address, the site breaks.

A file (like HTMP or PHP) should never have a “/” at the end. The “/” signifies a directory.

The RW website address should be the main url of your website.

Thanks for looking Don…I now understand how I broke the site in the first place. Weird thing is, the site longer displays properly, even after restarting Firefox. Nevertheless, I’m sure the RW General setting website address and the full path matched exactly. The site displayed both pages properly (before I broke it…I will now reupload it)but the CMS component didn’t seem to be working

It’s tough to say without seeing how your project is set up. I would try setting the URL in the rapidweaver settings to be: http://www.thewordsmithy.co.uk/client-area/FECMS33/ and then republish all files.

When you drag the Debug stack onto the Admin page and preview it, what do you get?

Thank you again Jason
Debug on the Admin page throws up several things:

I see the text content macros from the content page but only a question mark for the image content

		          forceHeight: false
		  if(!(/Android|iPhone|iPad|iPod|BlackBerry|Windows Phone/i).test(navigator.userAgent || navigator.vendor || window.opera)){
		$elixir(window).load(function() {

It doesn’t make any sense to me.

I’d rather not waste the time all you good people are spending on this, when the site appears to be broken for now (it was displaying correctly, but no longer). So I will reset RW as you suggest and republish. But if I’m no farther forward, I will take it down and star again with the original demo file.

My thanks and admiration to all for all your patience with someone who feels like an idiot right now. (Me, that is.)

Stop, stop…Debugger has now thrown up the following:

CMS Debug Info

PHP version: 7.2.25

HTTP_HOST: www.thewordsmithy.co.uk

SERVER_NAME: www.thewordsmithy.co.uk

DOCUMENT_ROOT: /home/cluster-sites/4/t/thewordsmithy.co.uk/public_html

DOCUMENT_ROOT (realpath): /home/cluster-sites/4/t/thewordsmithy.co.uk/public_html

SITE ROOT: /home/cluster-sites/4/t/thewordsmithy.co.uk/public_html/client-area/FECMS33

CONTEXT_DOCUMENT_ROOT: /home/cluster-sites/4/t/thewordsmithy.co.uk/public_html

SCRIPT_NAME: /client-area/FECMS33/rw_common/plugins/stacks/total-cms/totaldebug.php







CMS VERSION: Easy CMS v1.6.0 (9251)

Yeah that’s gibberish to me too, unfortunately. If you put in a support ticket with Joe I’m sure he can get you sorted (I’m mostly just ‘throwing stuff at the wall’ at this point).

We’ve all been there. You’ll love Easy CMS once you get it working so stick with it

I will stick at it…especially since I reset the website address in RW as you suggested…i.e. removing the “/index.php/”…uploaded it and the online site worked perfectly…once.
That’s right…the CMS took text from the admin page and rendered it in the content. It took an image I added and rendered it.

But it now stubbornly refuses to update the text. I’m convinced that this means I am going forward, even if I’m not there yet.

Thank you - and thank you to all who chipped in!

Sorry, I got tied up and couldn’t get back to you.
Why are you publishing to: http://www.thewordsmithy.co.uk/client-area/FECMS33?

FYI: If you are setting up a “test area/sandbox” then you should be using a subdomain like this: https://www.sandbox.thewordsmithy.co.uk not a folder under your domain. or you will run into all kinds of issues when you go to move it to a “live” site.

Some things that will help:
Where is the actual admin page for easycms?
Show a shot of your Project Settings.
Make sure the cmsid’s in the admin Exactly match the cmsid’s on the public side
Make sure you have cmscore on the public page and admin core on the admin page

Thank you again for your thoughts.
Things have moved on a little, but I still have an outstanding problem - though much smaller than my original one. Although I am reasonably computer-literate, I have come to realise that I am rather lacking weaving experience. I will answer your questions as best I can.

Put simply, that’s the way I’ve always done it…I’ve never had to deal with CMS before, and my post relates to a project for brand new client, for whom I now need some CMS functionality. The URL/pathway issue has never really cropped up when testing live sites for clients before, so I haven’t needed your (admittedly more sophisticated) sandbox approach. I need to learn more about this.
Admin page and Content page are on the same site (this is after all still a test bed)
Project Settings (attached)

have now moved on from those associated with the original problem I slavishly followed the advice for the URL to be exactly right…and so mistakenly added a “/index.php” to the web address window. Removing that has nearly resolved the problem altogether.
Corresponding CSM ids (Admin and Content) match correctly.
Correct CSM core stacks in place.
The two pages (Admin and Content) now appear to display correctly, and the (hopefully much lesser) problem now is that the CSM processes a text upload correctly, but only does so once, while an image upload appears to be processed correctly.

Help from @jabostick means I’m nearly there, but you have demonstrated that I still have a way to go.

You should really set up sandbox(s) subdomains for client projects i.e. https://sandbox.yoursite.com

Especially if you are using a CMS If you don’t, you will have issues setting it up & when you go to move the site because the pathing will be wrong.
The CMS code lives in the rw_common folder and that is expected to be in the root of your site, yours is in /FECMS33/rw_common.
The cms data lives in the root/cms-data folder & that is where easycms expects to find it.
Links you may add to the site will also be wrong when you move it because they will be a level deeper than expected.
If you ever graduate to TotalCms and have a blog or blogs, then it will really get harder to move everything.

My advice to you would be to set up a subdomain, set the project and publishing accordingly & your life will get much, much easier. Especially when you go to move it.

I can see the data in your cms-data/text folder so it’s there.
Show the screenshot public page in edit mode with the UI for a easycms test stack.

Thank you again Scott. I think your analysis confirms that CMS is a whole new ballgame for me, that pathing is clearly the root (no pun intended) of my problem and that ‘graduation’ to TCMS, as you put it, is some way off.
I will be setting up sandbox.thewordsmithy.co.uk when my hosting company’s support function opens up tomorrow (it’s 8:15pm here). If that’s too problematic, I’ve looked up cloudflare and that seems to be a way forward. In the meantime, thank you very much for taking a look at my first faltering CMS steps.
With my best wishes

PS I’ve just seen your more recent post…Attached screenshot of the public page in RW edit mode