Ecwid and Rapidweaver 8.2

I’ve just set up my Ecwid e-commerce shop and have linked it to my new website but I just get “403 Forbidden You don’t have permission to access /bookshop/ on this server.”
I have checked in with Ecwid ( and I have followed their info on their site) but they say its a Rapidweaver issue. I just redid my website. Maybe that is the problem?

Hello @MTP,

Can you tell me how you setup your store in RW?
Are you using the Ecwid Plugin? or are you embedding Ecwid widgets or using my Axyn Ecwid Stacks? If you’d like to PM me your project I would be happy to help you figure it out.

Also, what’s the URL of your site?

Cheers,

Ricardo

Hi
I just checked and it doesn’t look like I got the updated EcwidOnlineStore stacks 1.1.6. So I will do that and see what happens. Thanks
-m

PS. If I get your new EcwidOnlineStore stacks, do I have to rebuild my whole store? I have Rapidweaver 8.2. It says 8.3 recommended. I am using Artful to set up new site.

Hello Mona,

If you were to get the Axyn Ecwid Stacks you do not have to rebuild your store. All you have to do is to obtain your store ID from the Ecwid Dashboard and plug that number into the stacks that require it and off you go.

In fact, one of the samples included with the Axyn Ecwid Stacks uses the Artful Theme. The Axyn Ecwid Stacks should work with any theme or stacks Framework for RW.

Although the stacks are easy to use, If you would like to send me private message here or via the contact form on my website (Axyn.com) with the store ID of your Ecwid shop, or a copy of your project, I can place them into your project and send it back to you. The store ID, can be found in the Ecwid Dashboard, at the very bottom towards the left.

If you use the Axyn Ecwid Stack, you should remove the Ecwid plug-in, it will no longer be necessary.

Your version of RW should be fine as long as it is version 8 or above. It most likely works well with RapidWeaver v7 but I haven’t thoroughly tested it with it.

Let me know if you have more questions or concerns.

Cheers,

Ricardo

I think I fixed it. But do i still need new Ecwid plugin? I am having trouble with logo. But will figure that out i expect. https://www.mothertonguepublishing.com/bookshop/

I checked your website, and see that your shop is showing correctly. When you start RW does it ask you if you’d like to update the plug-in? What issue are you having with the logo?

Hello Mona,

I created a quick page look a like of your website, showing your bookstore (it is your real Ecwid Store, so if someone buys a book, you have a sale), with some quick styling (very quick, it can do a lot more) to show you the kind of things the Axyn Ecwid Stacks can do.

I just used the same theme as you (Artful), and added a couple of the standard stacks that come with Stacks.

Here is the link to that site: https://mtp.axyn.com

The search box now has some style, and the nav bar is left of it. You can also not add the navbar, or place it somewhere completely different. With the stacks I limited the number of featured products to 6, and at the bottom added some individual product stacks with some different styling.

Let me know your thoughts, I can take it down as soon as you tell me to.

Cheers,

Ricardo

Hi Ricardo
Thanks. My store looks better! I will get the Ecwid Stack next week. The logo on my browser ( Chrome) shows just as tiny image square and has the text 'Mother Tongue Publishing Limited ’ across it in large blue font which covers part of the navigation titles at top. I was sure I deleted any text on Logo Alt etc that seemed to come up originally. So not sure where this is coming from unless its from my browser Chrome. On my bookshop ( Ecwid) page the filename has htm at end. I was trying to change it to ‘bookshop.html’ but now it has the .htm and I can’t change it back. My website service provider fixed it at their end but I am wondering why i can’t fix it at my end. That is part of what caused the original problem I think. Thanks for your help.

Is the problem with the logo also showing on the demo page that I created?

no problem with logo on your demo page

The logo on your site is an eps image. Try converting it to a small png image, let’s say 300px in width.

it works on all pages except the ECWID bookstore. i’ll have time to check things next week

Hi @MTP,

I just replied to your e-mail from yesterday. I included a project sample, so that you can compare and see why the logo is not displaying on your current project.

Cheers,

Ricardo