Ecwid store, all I get is a Blank window- SOLVED


(Michael Walker) #1

I reviewed the video, and when I add it to rapid weaver it just gets stuck on a window, "Connect Existing Store, the window is blank, and according to the video i am suppose to press accept…

Any ideas what is wrong or what i did wrong?, I have an existing Ecwid store with products in it…


(Jason Bostick) #2

Do you have any pop-up blockers or anything installed? Hard to guess what is going on.

However, if it just isn’t working, it’s pretty easy to bring in an Ecwid store without the Ecwid plugin. You just grab the ‘integration’ codes from your Ecwid dashboard, then copy that into an HTML stack (and ignore/clear any formatting after pasting it)


(Michael Walker) #3

No I am using the Ecwid plug-in for rapid weaver


(Jason Bostick) #4

But you don’t need to, is what I mean. If the plugin isn’t working (I don’t really know what to suggest to help get it going), you can grab the code from your Ecwid dashboard and just paste it into your Rapidweaver page.


(David) #5

Maybe @makfruit Matt from Ecwid can help?


(Michael Walker) #6

I understand that but I wanted to use the plug as stated, maybe it’s something they do t know about, just would like to know why it is doing that still


(Matt Kuritsyn) #7

Hi Michael,

This is Matt from Ecwid.

Can you try opening this URL in your browser? https://my.ecwid.com/api/oauth/authorize?client_id=rapidweaver&response_type=code&scope=read_store_profile . Does it also open a blank window or the Ecwid login page?

Thanks,


(Michael Walker) #8

It opens the ECWID login Page just fine…


(Michael Walker) #9

I accepted it in that browser window you gave me was that ok? did not fix anything in my rapid weaver however. But that did show up fine the link you gave me…still a blank window in my rapid weaver and I followed the video to a T


(Michael Walker) #10

Yes it worked just fine trying to get my store to connect and still a blank window I guess sorry, store is up now if that helps at seasonalnovelties.com just samples in it yet I deleted them in my Ecwid store


(NeilUK) #11

There are a few errors that are probably the cause of your issues. I’m not sure if Ecwid needs an SSL certificate to function, and I’m not 100% sure what the other errors are.


(Michael Walker) #12

Looks

Like you had a few problems other than an ssl before that…

I’m on godaddy


(Michael Walker) #13

I have an ssl certificate guess I need 20 or More characters to answer lol


(Matt Kuritsyn) #14

Michael,

The store page at seasonalnovelties.com shows a demo store. This means that your store is still not connected to the plugin. Sorry for that.

We tried it several times on our RapidWeaver installations and couldn’t replicate the issue. I will need more time to understand what’s going on.

A quick workaround here would be, as suggested above, disabling the plugin and pasting your store integration code into your page — that should work fine.


(Michael Walker) #15

But in Rapid Weaver it should still connect the store at least so I can see it inside of rapid weaver correct? that don’t need an ssl to just see it inside of rapidwever.

here is that Blank window i get when I try to connect to existing store

I am using Rapidwever 7.5.5 and TelsaPro theme

Where do i find that store integration code on ecwid?


(rob jones) #16

this is exactly what I get - tried it on a laptop and it tries and freezes and does the same.


(Michael Walker) #17

Well at least I am not the only one, my window just is blank, opens a window and nothing in it when trying to connect to existing store… I do not think it is with our machines at all… must be the plugin or ecwid problem…


(Doug Bennett) #18

Might check out these links:


(Matt Kuritsyn) #19

@Flashoser , @Luckybob28, thanks for the details. What MacOS versions do you use? Not sure if the issue is somehow related to the OS version though, but who knows.


(NeilUK) #20

I’ve just done a test to see if the Ecwid window opens for me. It does when I click “connect existing store”.