Ecwid store, all I get is a Blank window- SOLVED


(Michael Walker) #21

I am using the latest 10.13.4 I bet that is the issue…


(Michael Walker) #22

You forgot to tell him what version you are using mine is 10.13.4 and it does not work for me at all…


(Michael Walker) #23

Still getting a blank window under 10.13.4 MacOS


(NeilUK) #24

I’m also using 10.13.4. The latest RW version, latest Stacks version.

The strange thing is that I couldn’t get it to work the second time. I just got the blank window.

So I retraced my steps when it worked. I wasn’t sure, but I think I was connected to my VPN when I tried it successfully earlier.

Turned my VPN back on, hey presto, it worked again.

It works with my VPN on; doesn’t work without it.


(Michael Walker) #25

you mean on your router?


(NeilUK) #26

I use a paid VPN through an app on my Mac.


(Michael Walker) #27

Ah! thats why i can’t get it to work then, what is the app called?


(Michael Walker) #28

sounds like you guys have a problem for some of us now still might be an OS issue I’m sure but it would be nice if the plug in worked…I need to make a few stores…and it was easy for my new guys working with me…


(scott williams) #29

Might be helpful to know if it works on a page just using the code snippets from Ecwid. If it does, then that would point to a plug-in issue, if not then it may be some other issue, dns maybe or something else on the page conflicting JavaScript or similar.


(Matt Kuritsyn) #30

That’s interesting. Might be related to geo location somehow.
What country do you reside in? What country the VPN server you’re connecting to is in?


(Matt Kuritsyn) #31

Totally agree, Michael. The connect dialog window should work fine regardless of OS and network connection type, so that’s definitely an issue on our plugin side. We do want to fix it to make sure you and other users can connect with no problem. We’re struggling with identifying the cause of the issue though, but hopefully this thread will help us.

Inserting store using the code is a good workaround meanwhile.


(scott williams) #32

Something is not right with your SSL if I go to your site using https://seasonalnovelties.com

I get a security error. This may be a contributing issue.


(Michael Walker) #33

Yes i have that working as far as using the code for now on my end…Thanks!


(Michael Walker) #34

We are checking into that now, we know our certificate was due to expire, but not yet, also we were switching to a new server that supports let’s encrypt, but to be honest i don’t think thats an issue if it works with the code just being installed… maybe they can work around it in the plugin…it seemed to have a problem with a guy using a VPN and without the VPN it would not work for him either…


(NeilUK) #35

I’m not saying that you need a VPN to get Ecwid working; just that it works for me when connected to my VPN, it doesn’t work when not connected.

Also, I did offer to help the OP by using his project to try to get the store connected. My offer wasn’t accepted.

I hope the OP manages to sort it.


(Michael Walker) #36

Yes I did accept I asked how can I send you my prodject you did not answer that


(Michael Walker) #37

Neil I did accept I asked how can I send you my project file?


(Michael Walker) #38

Yes I used the code snippet and the store worked fine then


(NeilUK) #39

I sent you a DM earlier with my email.


(Michael Walker) #40

Ah did I answer that? Maybe did not get it?