Error on home page. Any ideas folks?


(Victor Resto) #1

Warning: Invalid argument supplied for foreach() in /home/content/57/5937457/html/index.php on line 173


(Victor Resto) #2

Within Rapidweaver latest update my website previews fine. Viewing online the error is there.


(Nik Fletcher) #3

This normally means there’s an error within your PHP code.


(Robert Ziebol πŸ––πŸΌ) #4

If it is viewable online, do you have a link to the page??


(Victor Resto) #5

This is the web page. I even tried using an older Rapidweaver template of the same site and still get the error.

http://www.showroompartners.com/


(Victor Resto) #6

Warning: Invalid argument supplied for foreach() in /home/content/57/5937457/html/index.php on line 173

It says in the error line 173- Viewing the source of the page this is what’s on line 73.


(Robert Ziebol πŸ––πŸΌ) #7

Do you know what version of PHP your server has on it? Vimeo Wall needs PHP 5.2 or higher, we suggest 5.5 or higher as anything lower has been End of Life for a long time.


(Victor Resto) #8

Funny. I was toying around with Vimeo wall when the issue happened. I deleted it, just used code to display one video from vimeo. I have used GoDaddy as the host for years.

Is there any way to just delete this? I removed the vimeo wall stack on the page already


(Robert Ziebol πŸ––πŸΌ) #9

The Vimeo Wall code is still on your site. If you can not find the PHP version in GoDaddy, use Joe’s free Server Info stack. Put it on a page and publish (not this page) and it will give you and me the server info of your host.


(Victor Resto) #10

Is there anyway to just remove any remnants of the code from Vimeo wall. I figured simply deleting it from the page edit would do so?


(Victor Resto) #11

Ok. I downloaded and added it to a different page on my site and published.


(Victor Resto) #12

After adding the server info stack it appears the server is using PHP 5.5


(Robert Ziebol πŸ––πŸΌ) #13

Hmm, very strange then. Can you PM me a link to that Server Info page??


(Robert Ziebol πŸ––πŸΌ) #14

To remove it, just remove the stack and republish all files.


(Victor Resto) #15

Ok. I will do that. Do you know of any webpages that are using the Vimeo stack you could share with me?


(Robert Ziebol πŸ––πŸΌ) #16

Sure, you can see it on the HipsterWeaver Page and on Joe’s tutorial page.


(Victor Resto) #17

Wow! I removed the stack republished everything and the error is still shown on my home page. I even closed Rapidweaver, restarted my Imac too. Are you sure this is Vimeo Wall? I was also using Carousel Complete but it was having issues with my text in my sidebar navigation.

Any ideas?


(Robert Ziebol πŸ––πŸΌ) #18

Since you removed the Vimeo Wall stack, you have two index files, as RapidWeaver does not remove it. See here
http://www.showroompartners.com/index.html
you need to use an FTP app to remove it


(Victor Resto) #19

I use Fetch. I would imagine that will work. Let me try it. Strange. I really appreciate the assistance!!!

Vic Resto