Failing to upload using RW 5.3.2


(Sally) #1

I’ve been using RW for years on my iMac 2008. I’m using 5.3.2 and can’t upgrade as iMac too old.
Not had any problems til now. Cannot upload any updates. FTP settings are unchanged and correct. Files start uploading then stop after zero or we might get up to 5.
Any ideas?


(David Walsh) #2

I’m having the exact same problem with what sounds like an almost identical setup to mine. Started happening late last week. Sent email to Realmac Software over three days ago - no response. Anyone who could please advise on how we could solve this one - would be very grateful. Thanks.


(Sally) #3

Hmm interesting I’m not the only one.


(David Walsh) #4

I’ve just had a response to my email and have sent full details. Will update here on progress when more to report.


(Sally) #5

:+1: excellent. I look forward to the outcome.


(Sally) #6

Have you heard anything yet?


(David Walsh) #7

Hello Sally. It took several days to get the first response from RW.
Short version:
Unfortunately my problem is not solved to my satisfaction.
The FTP within RW is still stalling during the upload.
It would appear that I am faced now with having to manually export my site after each edit and then perform a manual update using Cute FTP.
Or pay out several hundred pounds to buy new hardware and an upgrade to the latest version of RW.

Long version:
In relative terms I invested a fair bit of time and money two years ago to set up to use RW. It has been fine until now, doing most of what I needed.
This is the first time I’ve needed support and in honesty it has been lacking. Underpinning the whole contact cycle was the notion that my version of RW - despite being purchased only two years ago, ‘is no longer supported’. That said, some support has been provided - but not a great deal and not in any way timely - waiting days for a response to a simple question is not good. I have followed all of the ‘suggested things to try’ with no success. There is also the repeated mention that I should upgrade but little appreciation of the irony that in failing to solve my present difficulties I’m not exactly inspired to upgrade. I’m familiar with the realities of software development and have, over the years, dealt with truly excellent through to abysmal support functions. The average to abysmal half of the scale doesn’t generally make for a sound business model.

Sadly, at the moment - I’m not a satisfied customer; making do with workarounds was not what I thought I was buying in to with RW. Perhaps some other kind soul who encounters and solves this problem might be gracious enough to publish the solution here. Best wishes. D.


(Sally) #8

Oh dear, that’s not good news. I’ve no idea how to do it manually so I will be losing 4 or 5 websites. Thank you for the update.
Sally


(Jason Bostick) #9

There are lots of folks who use a manual upload process as their regular workflow, and there are free FTP tools available.

I am not one of those users as Rapidweavers publishing works fine for me but if you start a new thread and ask for a detailed walkthrough, I’m sure someone could help you out.


(Sally) #10

Thank you. I will try that.


(Sally) #11

Well I’m having no luck either. I downloaded classic ftp but have no idea how to use it. Initial tries have not worked. It would have been nice if the RW guys had explained why suddenly out of the blue our software doesn’t work. There are those of us who can’t afford to upgrade our hardware/software at the drop of a hat.
I will be letting all my friends sites go and use a site builder instead. NOT HAPPY!!!


(scott williams) #12

I’m pretty darn sure that RM did not go back and make a change to RW 5.3.2 a full 2 versions back. Especially since they are neck deep into RW 7 development. And is they did, that means You would have had to update RW on your computer.

So that means something else obviously changed if it worked before and now it doesn’t.

My guesses would be:

  1. Something changed at your host (they updated something or changed a configuration) - happens all the time
  2. You updated something on your MAC that is causing it
  3. You updated an RW add on that is causing it

Dedicated FTP apps are not that difficult to use.
You set up the host address and log in info, and (in some) the folder you want to upload to.
You export your site (or changes) to a folder on your local drive
In the FTP app you log onto your host and navigate to the folder you want to upload to
You drag the files from your local folder to the remote folder
Sit back and wait until the upload completes.

What exactly does “initial tries have not worked” mean?
Can you not connect to your host?
You can connect and navigate to the proper folder but can’t upload?

with a little info you can probably get some help.


(Sally) #13

Thanks for your reply. Nothing has been changed. I contacted my servers and they confirmed they had not changed anything. Very odd that someone using same setup as myself started having identical issues around the same time.


(scott williams) #14

But the question remains, Did you update RW?
If not then how could it be causing the problem?

No Matter…

I will help you try get going with ftp if you can tell me what the problem is.


Walk through using ftp client for updates
(David Walsh) #15

In my case none of your ‘guesses’ is correct. One day the FTP upload worked, the next day it didn’t.
The only change was within the site itself. I have subsequently reverted to an earlier version of the site but this has made no difference to the FTP stalling.

The point remains: why should we should have to use ‘workarounds’ on something which was advertised with inbuilt functionality. You wouldn’t put up with buying a new car and then being told, when it fails two years later, “You’ll have to use the bus from now on. Or buy our latest model. Or you can complain about it on our web forum until another customer takes pity on you and helps you fix your car”.


(David) #16

I suppose you’ve already re-downloaded the same version of RW your using, trashing the old copy and using the new one. Just wondering if it somehow got corrupted since you report no changes were made.


(David Walsh) #17

No, I haven’t done that because I wasn’t sure if I would make the situation worse. I did ask RW if I should do that but they didn’t answer the question. Do you think it would be worth a try? Obviously I will need to back up my site first but I would be glad of advice of the best way to do that please. Thanks for your help.


(David) #18

At this point it seems worth a try. You could zip your current version instead of trashing it i suppose, but it shouldn’t make a difference. But backing up is always good. I would just download a new copy here: https://www.realmacsoftware.com/rapidweaver/releasenotes/
and give it a try. I don’t think it can cause any further problems, but maybe @swilliam Scott or others will chime in to confirm that no problems will be created by replacing your copy with a new one.


(scott williams) #19

Hi David,

If you didn’t change your software in any way but it stoped working then something else changed, make sence?

Something changed upstream that is keeping Rw’s publishing from working.

Using your car anology, if you use your car to go to work and a bridge washes out preventing you from driving there is that the car co’s fault?

I’m not trying to defend RW but how can it be RW if you didn’t change it?

I’m happy to try to help get you going but you have to give us something more to go on besides it quit working.


(David Walsh) #20

Yes, indeed. But I didn’t change anything and RW didn’t either. Aside from a stealth Mac update or some nefarious external infiltration I dunno. All I know is I bought something that no longer works so I asked the supplier for help…

I think the only sensible option is to try reinstalling.