File download zipped - how to defeat this?

Hi friends. Right now, we have no choice but to use RW 5.3.1 with Stacks 2.5.4. Our site has a file downloads page for which we use True Download 1.0.7. Most of our downloads are PDFs, so we zip them before upload because we need them to write to disk rather than open in a browser.

However, we have one encrypted DAT file that need not appear on the Downloads page - but it must be accessible to and downloadable by our software when the “Update Database” command is selected.

If we DO provide a HTML text link on the page, the file downloads with the name “Unknown” rather than “Frequencies.dat.” If we use a True Download stack, it downloads as “” - which our software can’t decompress.

We’ve talked to the service provider tech support, and they say this is caused by the coding of our site - but we can find no control or preference for file compression in RW or True Download.

What we really need is NOT to put the file on the page, but to have it on the server with an URL our software can use to download it uncompressed with its correct name and file format - “Frequencies.dat.”

None of us here are web experts. So your urgent advice would be most appreciated. We have a new version of our software scheduled to be released on 1 January, and we’re in big trouble if we can’t make that deadline.

Any suggestions?

Namaste, and much love and light to you all.


Are you able to use a FTP application? The. You are able to upload the file manually to the server.

If you are not able to do this, you could put the file into the RapidWeaver resources section, and the file will be uploaded by RW to your server.

In all cases, the file can be downloaded via an URL, and it should keep the original file name after download.

Thanks for you response. We use Transmit 4.4.8 to FTP everything up to the server because the Publish command no longer works correctly in RW for us (refuses to accept the password). We don’t have a problem getting the files up. It’s getting this particular one down so that our software can read it that’s the problem.

I’ll try adding an invisible page without Stacks to the site with a plain HTTP link to see if that works.


Is your server using gzip by chance… might be a config in the htaccess file… may be able to change it in your cPanel.

To me, it sounds like the server is configured to automatically zip PDF files for download.

On the other hand, if you are using a files download stack there may be a setting in that stack to configure that a file is downloadable or compressed and downloadable.

As for .dat files, they may be blocked by browser so may not be a good way to do it.

Transmit is currently at version 4.4.11 (MAS), try an update to that software. Did you tell Transmit to send .dat files as ASCII files (Transmit -> Preferences -> Transfers -> ASCII File Extensions)?


Thanks, Brad. Good info. We ended up with a kludge. But it works, and it got us out of a hole. We simply changed the file extension from .dat to .zip, and altered one line in our software.

We met our deadline. And the software works great. Which is the main thing.

Namaste, and much love and light to you.