Formloom 4 on macOS Catalina 10.15 Beta


(Shubhanyu Jain) #1

Hello,

I am running macOS Catalina 10.15 beta (4) on MacBook Air 2017.

Rapidweaver release version and 8.3 latest beta.

There is an issue with Formloom 4, plugin does not load. The issue is amply described in the screenshots, I hope.

The response I received from @yabdab suggested that I should take it up with Realmac. No suggestion of intent to take ownership of their plugin’s operation with the new OS and help Realmac work with them to resolve it. No, the customer bought their plugin, they should do it. So, here I am, seeking help.

@dan Tagging you since the response I received from the developer was suggestive of a Rapidweaver issue.

If any other members are facing something similar, please chime in to help Realmac resolve the issue. The plugin developer has clearly passed the buck.

14%20pm
26%20pm
29%20pm
37%20pm


(Doug Bennett) #2

I do believe that plugins do have make changes with the new Catalina version of macOS.
I know over on @isaiah slack channel he has posted about changes related to new restrictions with “gatekeeper” and “ notarization” with stacks and other plugins.
The issue might be @yabdab and not realmac.


(Yabdab) #3

To the intelligent and well informed user that started this post, “the buck” was not passed.

Plugin developers have no idea on what requirements are necessary on forthcoming BETA releases of the macOS.

That is why I asked you to contact Realmac.

If Realmac needs developers to make changes in the plugins, then it will be done.

As of today,I am unaware of any required changes.


(Shubhanyu Jain) #4

Again, a slightly more responsible thing would be to say, “Prima facie this looks like something in Rapidweaver. While I will certainly look into it and see what can be done at my end, in the meantime you can bring this to the notice of the Realmac team too.”

I have been a longstanding customer of your “loom” plugins. Dateloom, Formloom (from the original). This is the first time I needed support.

:smiley:


(Shubhanyu Jain) #5

I believe so, too, from the looks of it.


(LJ) #6

so you need the developer to write a nice long email instead of getting to the point? I’d say Mike’s response was absolutely fine, and you really shouldn’t accuse him of passing the buck when he’s simply pointing out the issue is almost certainly not a plug in one.


(Shubhanyu Jain) #7

Where I come from, if I develop something and get paid from people, I would at least give a sense that I am involved too, by saying, “I will look into it at my end, meanwhile please do this this this.” It is a basic ownership thing. Too much to ask?

My intent, however, is a solution, either from the developer or Realmac or Apple. I understand that my pointing out the dev’s dismissive behaviour has left it open to discussion, so, thank you for your thoughts.


(Jonathan Spencer) #8

Why on earth are you running the MacOS beta on anything other than a secondary ‘play’ Mac.


(Shubhanyu Jain) #9

You have no concept of beta testing then, if you wonder why would anyone run the beta on anything other than a play device.

Forget macOS for a moment. RapidWeaver has betas too. Why do you think they exist?

To me, they exist to be tested for issues. I found yabdab plugins not working on macOS Catalina beta and contacted the developer to inform him of what’s happening and to know if he was aware.

From his response, clearly he wasn’t aware since he hadn’t tried his plugin on the beta macOS, and guided me to contact Realmac. I posted the issue here on the forum complete with the developer’s dismissive attitude. Nothing hidden. All I want is to know if at all any others are facing any such issue if they are running the beta macOS, and the prime reason for posting here was to get @dan to note this issue and help resolve this if it is with RapidWeaver.

I could have chosen to email him privately about it, but took to the forum to know if anyone else was facing any such issues specific to this plugin and on macOS 10.15 beta. The part where I mention the developer was dismissive by not taking ownership of his own plugin’s functionality and directing the customer to contact another developer is really a secondary facet of the whole thing. In the larger scheme of things it is immaterial as it is just an attitude.


(Kurt Trucksess) #10

I am having the exact same error in Catalina with a different plug in that is maps related. I also can not get Rapidweaver to load my project.


(Angel Ars) #11

How could there be “a solution” when it is still in beta?


(Shubhanyu Jain) #12

You are right.

It may be an unstated thing in the Rapidweaver developer community that they will act only when a final release from Apple happens. I understand that. No issues with that. I have seen larger economies with this exact stance, and I see why. Thing is, those economies communicate their stance. When contacted, they had told me specifically that they will work on it when Apple releases the final product so that there are no more changes to it fundamentally and there isn’t a cat and mouse game they have to indulge in. Perfectly understandable.

So, I apologise if the Rapidweaver community follows that stance as well and I didn’t know of it. The plugin dev did not mention this stance, if it exists in the Rapidweaver community. He didn’t say he will look into it (taking ownership). He asked me to contact Rapidweaver, so I posted the problem in the forum, with only one mistake, I pointed out an issue in the response from the dev. People here grabbed onto that, ignoring everything else about the problem and made my remarking on the response a beating board.

My apologies to @yabdab as well. I expected the dev to communicate with and from a sense of ownership, but it has been amply communicated to me here that there was no issue in their response.

Members who go through this thread (save the first poster here) only respond to my pointing out the issue I noted with the dev’s response, or back-question me nitpicking my words. They have nothing to add to the discussion that would be helpful to Realmac or (God forbid) the dev to work towards a solution. Nothing productive is happening towards a resolution, I have flagged the thread for moderation, requesting any mods out there to kindly close the thread.

I will email Realmac to help me with someone else’s plugin they didn’t get paid for.


(Isaiah Carew) #13

Here’s what I posted on my Slack channel when asked a similar question.

Not all our software can be compiled and notarized yet for Catalina. We expect to be ready long before Catalina finally rolls out – but Catalina still has some serious instability (be careful using iCloud right now) – so we’re taking our time rolling out various plugins.
For now Stacks 3.6 and Stacks 4.0 beta are recompiled and notarized for Catalina. And we expect to start rolling out the others at about one per week after Stacks v4.0.1 ships – which is hopefully not too long from now.

I’ve been working 12 hour days pretty much since WWDC do try to get all our products ready in time for the Catalina release. I do want to support it, of course. And we’ll get there, but it’s a mountain of work. And we’re just a mom&pop style company. It’s just me and my wife. I write the software, Christi answers the support email. So huge changes like this can take a little while to work through.

Catalina imposed quite a few new challenges – and especially for plugins – (the hardened runtime is particularly difficult for plugin debugging since we can’t introspect the app’s memory in some ways – Instruments is pretty much dead now :frowning: ) and notarization changes for non-app bundles (like plugins) weren’t finalized until the week of WWDC.

It’s funny, I notarized Stacks 3 back in April or May when the first documentation rolled out on the Apple dev site for Mojave. But at the time it just didn’t work for plugins. But during the week of WWDC all of sudden… bing… like magic the original notarization started working. LOL Betas and developer releases are a bit scattershot for a while.

The plugins that were easy to get working (like Stacks) are working today. I even notarized a few versions back. I think you can use Stacks 3.4 all the way through about half of the Stacks 4 betas and of course to Stacks 4.0.

The Stacks 4 release drops today (in about 7 hours yeah!). I’ve integrated notarization into our build server – so all our releases going forward should be notarized before the auto-update triggers. After a weekend off we expect to have to roll out at least one Stacks bug-fix update.
But after that I’ve penciled in one plugin per week until they’re all done. It’s a bit optimistic – but I think once we get rolling the problems that need solving are mostly the same problems for each plugin.

I’ll start with PlusKit and SiteMap. Those have had the most recent changes so should be similarly easy to get going.

If you have any questions, don’t hesitate to ask. I am a bit busy with the big release today – I’ll apologize in advance in case I don’t get back to you immediately.

Isaiah


(Shubhanyu Jain) #14

I saw 3.6.8 update today, then went to your website just an hour ago to see if v4 is up. Very happy to know v4 is coming in a few hours. Will upgrade from 3 as soon as I see it live! :smiling_face_with_three_hearts:

Catalina beta 5 that dropped yesterday (my time) changes something regarding notarization definitely. The issue I posted in this thread, regarding Formloom, is currently resolved. Turns out it was neither Rapidweaver (as seemed to the plugin dev) and neither the plugin itself. It was Apple.


(Isaiah Carew) #15

My plan is for 12 noon Central time (that’s about 6 hours).

Betas are betas. Things are in flux. Apple has been fielding quite a few complaints about overzealous “security theater” where they ask novices users to give permissions for things novices have little hope of understanding.

My recommendation is the same as always… keep the beta on a spare device or spare drive. Sometime around mid-september things usually shape up quite a bit.

Oh, and definitely definitely… turn off iCloud on that device!!! The number of data corruption horror stories I’ve heard this year is… not good.

I’m currently running it on a spare drive. I’m used to crashing – but even I have my limits. LOL :stuck_out_tongue_closed_eyes:


(Riaan Grobler) #16

Also running Catalina beta with Formloom , No issues with it since beta 1…
I do understand both sides of the story… it’s all a blame game when things down work. :slight_smile:
Developers should understand that we as users of plugins dont always know why things aren’t working. We just know its not working and I doth believe we should know either… letting the developer know about the problem is first step,… In this case the developer replied. Have you ever received a response from Apple… :slight_smile: , yeah right.
Developer pointed out what he thought would be the problem. Job done.
Glad its not a RW or Formloom issue. but its the beta game.
Cheers


(Isaiah Carew) #17

you’re running a beta. betas are just buggy. that’s why they’re being beta tested.

i know it’s fun to have all those tantalizing new features, but at the end of the day, if the bugginess is to much of pain in the butt – then just stick with the release version.

it’s advice that i’m living by myself. i’m running 10.14.6 for work – but have have an older slow drive that i installed 10.15 catalina on – for playing and testing. i can’t afford to have catalina bugs and incompatibilities slowing me down.


(Riaan Grobler) #18

Perfect! :slight_smile:
I use Beta’s as testing platforms whilst my trusted 10.14.6 is churning without issues. :slight_smile:


(Robin Mair) #19

As of the latest Catalina BETA 6 that was dropped today, this problem still exists for me.

And yes I do have to run on the BETA so I can test my software as I cannot afford a dedicated machine.

RapidBot and RapidMaps also have the same problems, but Formloom 4 is the one I care about as all of my sites use it.


(Yabdab) #20

@handshaper your most recent support ticket stated that our current beta build of Formloom 4 fixed the Catalina issue, is that not the case?

https://www.yabdab.com/beta