RapidWeaver 8.4 released with support for macOS Catalina

It’s been a busy summer for us here at Realmac HQ, we’ve been hard at work making sure your favourite web design tool runs on Apple’s latest system.

After the surprise launch of macOS Catana last week, I’m pleased to announce we have released RapidWeaver 8.4 and it works just great on Apple’s new system.

Update your Plugins

Before you upgrade to macOS Catalina you’ll want to make sure all your third-party plugins are up-to-date.
This is a list of plugins that are known to work great with RapidWeaver 8.4 on macOS Catalina. If a plugin you use or rely on is not on this list please contact the third-party developer directly or check their website for details.

  • Stacks 3
  • Stacks 4
  • Accordion
  • Blocks
  • Collage
  • FAQMaker
  • Flow
  • Lockdown
  • PlusKit
  • SiteMap
  • Formloom 4
  • Emporter

In most cases your themes and stacks should just work on Catalina (as they don’t execute any native code), no update required. Although, it’s always a good idea to make sure you’re running the latest version of all add-ons as they often contain essential bug fixes.

Once your plugins are up-to-date you’ll be all set to upgrade. If you’re running macOS Catalina you should be running RapidWeaver 8.4 otherwise you may run into crital compatibility issues.

What’s New in 8.4?

  • Fixed a crash when right clicking a link in Styled Text (Catalina)
  • Fixed some thread issues in (Catalina)
  • HTML page no longer looses “show in navigation” setting when migrating from RW7 to RW8
  • Fixed an issue with AmazonS3 showing access denied on some files
  • Various other fixes and improvements to keep RapidWeaver running smoothly
  • Where to Download RapidWeaver 8.4

Direct customers can download RapidWeaver 8.4 here, or check in-app for updates. If you’re a Mac App Store customer, please check the App Store for updates.

Happy Weaving!

4 Likes

Just updated to 8.4 (although I’m still on Mojave 10.14.6) and now having issues with the project I’m currently working on. All stacks and addons are fully up-to-date.

The ‘Units’ page will not preview… nada - just blank in the preview area.

The ‘Contact us’ page preview shows the following text:

Fatal error: require_once(): Failed opening required ‘/private/var/folders/jf/2qdd49nj4jj4m00pk6p3rwv00000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/11208/document-0x7f8dfd36c910/RWDocumentPagePreview/contact/…/rw_common/plugins/stacks/formsnap/lib/formsnap.class.php’ (include_path=’.:’) in /private/var/folders/jf/2qdd49nj4jj4m00pk6p3rwv00000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/11208/document-0x7f8dfd36c910/RWDocumentPagePreview/contact/index.php on line 42

If I export the site to a folder on my desktop and put that up to a server, it displays happily. The url for the work-in-progress site is here. Any ideas please?

I have a similar issue in 8.4 with a page not previewing - just a blank preview area.
The published site had the page displaying correctly
I noticed the page was showing a changed marker in the pages column even though it had not been changed - just a resource updated which it uses.
The changed marker did not disappear on publishing which came as a surprise.
On manually changing the page with 'mark as unchanged’ the preview displayed correctly.

Excellent, @julk - thank you - that works for me too! Not how it should be and needs fixing imho, @dan

Hi!

Why does the Inspect Element still work only as a separate window? If you try to make it from the bottom, as in many browsers, then this window disappears altogether, and the stacks begin to twitch.
Mac OS 10.11.6, RW 8.x.

And how hard is it to make digit editing like in browsers using the up and down arrows?

I have submitted a very simple example to @isaiah that demonstrates this issue. I do not know if it is stacks related or not. However closing and opening the project fixes the issue in the short term. It was an issue in earlier version of RW8 as well.

cheers

How hard is it to write a polite forum comment?

Oh, sorry. Didn’t want to be impolite.

2 Likes

And what’s impolite about the message?


Ok, Tell me, please...and question.

By the way, the Inspect Element in RW8 asked about the buggy for a long time, there was no answer.

@Wondrous “How hard is it…?” is pretty curt, isn’t it? Imagine you had spent many, many hours coding an app… would you feel more inclined to respond to / feel better about the question put as you did or you would you rather read something like: ‘I would prefer to be able to use the up and down arrows when editing - is this possible to achieve please?’

1 Like

Sorry, I’m not a writer. Moreover, this is how the online translator translated it. And do not immediately attack like that. And in different languages there can be different meanings of words and expressions.
If I may say so, I asked about this problem before, and more than once.

2 Likes

Aha @Wondrous! A very good explanation and I think you can be excused :slight_smile:

Have a good day!

Since I updated to Catalina, RW 8.4.1 has failed to export. If I close and restart RW, it works until I make any changes and then fails again. A change of one letter generated an attempt to republish of 660 + files but on restarting it only republished 4 files.

Same here, updated to 8.4.1 and one of my projects does not export or publish. I have tried to downgraded to 8.3 but no luck. All other projects work fine. Anyone else with the same problem?

Edit: Solved. The issue was an apostrophe in a keyword for a podcast. However, I only received an alert back with details after downgrading to RW 8.1. As a note for future releases, it’d be nice to have that kind of feedback rather than a simple “Unable to Export”

Since Spanish is my first language i can testify that online translators completely butchered everything I have tried to translate. It is good for comic relief! Translating takes times so I wanted to try Google translate… Not ready for prime time yet… Aloha

I’ve noticed that when filling in the publish info for an ftp location, when choosing the ‘browse’ button to select a folder on the remote server, the window that comes up is only 1 line deep, so not possible to browse to a folder.
Not a biggie as can be set manually but it was easier before.

Cheers

The browse window can be sized as big as you want, just click and drag the edges of the window.

Mine can’t. I used to be able to do just that but now it stays as one small window. I can drag it wider, but not deeper :frowning:

Note that I’m on Mojave. I’m not updating to Catalina until everything I use works on it. So not for a long while yet :slight_smile:

1 Like

Hi!, same thing as rojharris here!

Hello,

Just upgraded from 8.3 to 8.4.1 (but still with High Sierra) :

Now, when in preview, when clicking on a link, it freeze, no other solution than kill RW, and all work is lost…

So please… how to downgrade to 8.3 ?

Best regards,