Formloom giving me strange JSON error message with send button

Hi,
Formloom has been working great for me for a couple years now, but I just updated my site to RWC and made some updates to my form and republished the entire site. And when I tested the form in Safari with all data cleared, it gives me this error message when I hit the “submit” button on the form.

it sill populates my google sheet strangely, but the user would never know that, and it does not send me the email it is supposed to or take the user to the success page.

Any ideas what this message is about? I found a reference to this error on this forum and the solution was to call my hosting company and turn on a bunch of php plugins which I did, they are all on now. And it did not fix the issue. My hosting company has come to the conclusion that it is the fault of the forum and not them, but they always blame me for everything so it could still be something on their end.

Here’s what someone posted previously as a solution to this:

errors in debug show:
You do not have the PHP gd extension enabled
The mb_detect_encoding() function is not installed. Install the php-mbstring package.

Turn this on in your hosting php settings if you can, or have your host do it for you.errors in debug show:
You do not have the PHP gd extension enabled
The mb_detect_encoding() function is not installed. Install the php-mbstring package.

Turn this on in your hosting php settings if you can, or have your host do it for you.

Anyone have any ideas what to do?

Here is the form live

Thank you! Right now no one can order my headphones and I’m gearing up to start production right now so I need this form to be working.

Whitney

If you revert the updates you made to your form does it start working again?

Also looks like you are on PHP 8.0.30. Maybe try changing the versions to see if a different version works.

Finally make sure you are using the most current version of Formloom 4 by redownloading it from @yabdab’s website.

1 Like

I changed very little just removed some options. It couldn’t have broken the form.

Sorry can you explain how to do this? Through my hosting company?

I can’t figure out how to download the latest version without buying it again. Can you provide a link? Or a screenshot?

Thank you!

1 Like

you will have to dig up your serial number though

If your hosting is with green geeks then their support pages have an explanation on how to upgrade your PHP

so I’m talking to both Yabdab and my hosting company and both are blaming each other and I’m at a loss. Yabdab can’t seem to find anything wrong and neither can my hosting company. But this form worked before upgrading to RWC!

Here are all my php settings, sorry for the messy screenshots I ioverlapped each one by one letter.

Any other ideas? I have other websites hosted on this account so I’m weary of just changing the php version around randomly.

But I really need to get this form working asap.

thank you!

while your testing the form turn off the opcache its fine cache scripts in ram and if its set for a long time to store the php scripts from formloom you will struggle to see your changes right away. all my development servers this is off but on production its on. Or learn how to clear it so it can reload. fyi you’re going to have to restart php for this change to take place. it will make the for just a mall bit slower while your sorting this out.

and try php 7.4

So I got this sorted out thanks to Mike @yabdab and my hosting company and putting the pieces together.

it’s a bit of a story, but I owe you all an answer for your help.

So my hosting company, GreenGeeks, migrated all my websites onto a new server a while ago and I either didn’t read the email thinking it was junk or never got it, but all my websites are now on chi200.greengeeks.net not chi100.greengeeks.net

Mike saw this as the problem when he looked into my website deeply, but I had just re published the whole site wit the publishing settings set to chi200. so I didn’t understand why Mike was telling me the problem was STMP file being on chi100. But then I realized it might be a setting in Formloom, and when I investigated, there it was, there’s an STMP setting and it was set to chi100 still. so I set it to chi200 and everything works now as it should.

Screenshot 2024-05-14 at 8.43.43 AM

Should I be sending with secure protocol by the way? I currently don’t have this checked.

========

I am having a new problem though if there are any Formloom experts out there.

I have an auto responder to my domain email address for https://www.rhythmdevilsaudio.com. And I use this same address with Formloom because it’s the same business. But when someone fills out my form to place an order, it triggers the auto responder, and they wind up getting 2 emails. And my autoresponder is meant for questions, not orders, so it winds up being annoying and out of place.

Is there any place in the settings to make it so that the Formloom submission doesn’t trigger my auto responder?

Or do I need to create a second domain email for orders that is separate from general inquiries? I’d really rather not do that, it just confuses things.

Thanks everyone!
I really love Formloom, Mike has done an incredible job creating a really sophisticated form with an incredible amount of options and customizations. it’s only limited by the fact that it’s a plugin, so you can’t add stacks to it. But Formsnap is catching up, still not there yet though.

3 Likes

Formsnap v4 will have everything Formloom does … and MORE! :wink:

2 Likes

Well I got the form working, but since the form was triggering my auto response, I had to create a new email at the same domain just for orders from the form. So that when people place an order then don’t get the confirmation email from the form as well as my auto response for a general contact email.

So I was originally using an info@domain address and I made an orders@domain address. And I added it to Spark and made sure it worked. And then I simply swapped out info@ with orders@ in 3 places in the Formloom settings.

And now the form is broken again! I can’t fathom how or why. Is there another place I need to change the email address that I can’t find?

I know the password is correct, I copy pasted it.

Here are the 3 places I swapped out the info@ for the new orders@. And the new error message, which is a time out error. I’ve spent 2 days troubleshooting this and really need it to work so I can update other things on my website and work on other pressing things.

thank you for any help!

Try checking the box that says “Send with Secure Protocol: SSL” and republishing.

Also does the form settings ask you to enter your new orders@ email address password and hostname? Make sure all those are entered correctly if so.

2 Likes