[Foundation 6] When Updating is not enough

I need help again with Foundation 6… I managed to solved the first issue of multiples versions inside a folder after Rapidweaver updated. Basically I start from scratch, delete all including Rapid Weaver and install all stacks one by one. Problem solved. Now I can launch Rapid Weaver without that annoying pop up at launch. Guess what? This morning after updating stacks (including Foundation 1 end of support) and Foundation 6 stack it start saying my theme need to be updated. I download it, installed it and the problem still there. any ideas?
34%20PM

Restart RapidWeaver.

It should tell you the theme needs to be updated. With F6 the Theme version and the Stacks version must match.

You can check in the addons manager and the stacks:
2020-05-17_10-55-30
2020-05-17_10-56-40

2 Likes

how I upgrade the stacks???

Click the updates button bottom of the stacks library pane

1 Like

it doesn’t work. nothing updates!

Did it tell you there were updates when you clicked he update button in the stacks library? Did you restart RW?

[update]

I restarted the Mac and delete the stack of Foundation 6. Everything is fine now. I need to say that F1 never give me this issues ever. Do I need to get scared with F6? kind of buggy IMHO

[old comment]

no updates. and yes I restarted the app too. nothing

It’s not F6, it’s the updates that is giving you issues.

Your gif didn’t even show you trying to update.

True. Not normal anyway.

As I said. I delete everything (again!) and re-install all again. Problem solved. The thing is I don’t have any client under F6 yet. How would I solve this issue if I have an important client with a F6 website build? If I delete everything I will lose his website too. That’s what’s worrying me. I shouldn’t have this problem just because updating Rapidweaver or Foundation 6. It never happened before why is happening now? Worst thing is trying to imply that the user is the problem when since the user is working with the same tool for years never had to deal with problems related to updates at all. 20 years doing websites. Working with Coda, Espresso, Flux you name it. Rapidweaver has been a great tool for an specific client on a budget and now an update is ruining my daily routine. Not mad, just saying why I’m frustrated.

1 Like

The Foundation 6 stacks do nothing special for updating. It’s the same exact process as all of my other stacks have for years. Are you able to update other stacks? It’s just F6 stacks that don’t show updates? Are you manually installing stacks? Or do you install with the rwaddons installer?

I double click the stack and Rapidweaver does the rest. Do you think is because Mac OS Catalina? Maybe?

I use Catalina and I know many others do

It just F6 stacks. F1 were updated and still runs like a champ.

I know that this does not help you but no one else is having this issue of F6 updates showing up. There is literally nothing different with how F6 updates vs any of my other stacks. when you check the stacks update window, F6 just never appears? Maybe you can join the hangout this Friday and we can look at it together live.

What version of RapidWeaver are you using? I upgraded to 8.6.2 the other day, and it was crashing after trying to startup, so I went back to 8.5.1 and haven’t had any problems–but I’m on OSX 11.6 (El Capitan I think) and not Catalina.

Re: stack updates.

Stacks have not automatically found updates available for me in awhile, maybe a year.

I now manually check to see if updates are available. If updates are available, I’ll update and then Quit RW and then Restart RW to make sure (a) those stacks get updated, and that’s how (b) I make sure I can then use updated stacks.

If you update F6 stacks, but you don’t then immediately quit and restart RW before trying to use F6 stacks, you’re going to have problems.

Sorry Joe. I had the same problem. I have one web site built with F6, and kept having the same issue. It was almost intermittent. I get the warning window, go through the website, remove the F1 stuff, window goes away, then shows up again after another update.

This is true of any stack, not just F6. Just want to make sure that was pointed out. Good advice David.

1 Like

This does not sound like the same problem. It sounds like you are getting the Foundation 1 stacks warning. This shows up if you have any F1 stacks on the page.

1 Like