Foundation FormBase and Spam


(Mike) #1

I have over the weekend been getting loads of Spam emails via the contact form (Foundations FormBase) from my site: Hillside Computers

and I can’t understand why. Basically the form doesn’t elude (as far as I know or can tell) as to what my email address is to the end-user, but the emails I have receive have all been filled in correctly.

Does anyone have any ideas as to why this is happening and how I can stop it from happening?

Thanks in anticipation.

Mike


(Robert Ziebol 🖖🏼) #2

Have you added a human test? That would keep bots from spamming your email.


(Joe Workman) #3

Add Human verification. Basically a text input that has a question… What is 2+12? Then verify that the field validates to 14. If it does not, then the form will not be submitted.


(Mike) #4

Thanks for the swift replies chaps.
What type of field do I add to the form for human verification please?


(Mark Sealey) #5

A text field so that you can put in whatever you want as the ‘answer’, even though - in Joe’s example - ‘12’ looks like a number; it’s treated as a text string.


(Mike) #6

Without sounding too thick, I have added a text input field as Mark suggested, but what settings do I use?

This is what I’ve done so far:

Any suggestions would be great.

Thank you.


(Mark Sealey) #7

Mike,

I don’t use that actual stack.

But the principle is that visitors must enter ‘14’ in the text field in question (because 14 is 12+2); or whatever ‘sum’ you set.

And so the value of the Validate field (on the right) you set to 14 in such a way that if a non-human (spammer) fails to put in ‘14’, or whatever you require, the absence of a valid value in the form will cause its data to be rejected.


(Mike) #8

Hi Mark,
I understand what you say, but I don’t know how to put it into practice.


(Mark Sealey) #9

Mike,

No prob. I’m sure someone familiar with the actual stack, and/or at Joe’s, will describe the exact settings/values. Good luck!


(Martin Waring) #10

Looks like you need to use a Rule = ‘Custom’ setting and then Custom Pattern = ‘14’. Seems to work here: http://www.aromatherapyyork.co.uk/contact.php