Help Needed for Email Setup - Foundation Form Base


(Fred Dalzell) #1

I’m exploring new ground for me. I manage a Ham Radio club website and we are adding a secured area for members only. I’ve got everything working using JW’s Page Safe, but am having a problem with the email setup in Form Base.

Specifically, entering an email address generates the set error message, but I can’t figure out what is wrong. I suspect the domain/email issue discussed elsewhere, but would appreciate help in verifying it and suggestions how best to fix it. All new to me.

Using RW 7.0.4, Foundation 1.7.11, Stacks 3.2.4

URL (hidden): http://w7saa.net/members/login.php

Thanks for any help, Fred

@zeebe

Adding a screenshot of Form Base settings


(scott williams) #2

most hosts nowadays will not allow you to send from a mail account on another server.

Your from address will probably need to be : Yourformemailaccountname@yourwebpageurl

for example: FormSUbmition@mysite.com


(Fred Dalzell) #3

@swilliam - I suspected that was the issue. The club doesn’t use an email address from the ISP (and has never created one). I’ll try getting one setup just for this and see if it works.

Will report back later.

Thanks,

Fred


(Fred Dalzell) #4

Just a quick update. Still not resolved. I was able to create an email account (after several tries due to server issues) and updated my page to reflect it. However, it still doesn’t work, although a different error - Internal Server Error 500.

I’ve opened a ticket with the ISP (maiahost - don’t ask) and hope they can help. If anyone else has any ideas, let me know.

As an aside, I remove the Custom Email Template from the Form Base as I was getting an error that the email body was empty. If the Error 500 gets resolved, I’ll reinstate it and see what happens then.

@zeebe @joeworkman


(Robert Ziebol 🖖🏼) #5

Your site is giving off a 500 Internal Server error when it comes to the PHPMailer, this is out of our control, you will want to contact your host and ask them what might be going on. (click on image to see it bigger)


(Fred Dalzell) #6

Robert - already done as noted.

Reason for my tagging you and Joe was that I got a different error earlier when I tried with the Custom Email Template - body is empty (it wasn’t). Will be looking at that once the Server Error is resolved.

Thanks for looking

Fred