Foundation issues (cosmetic)


(Nick Wilcox-Brown) #1

Odd one here - I’m using Joe’s Top Bar and Orbit Slider, all fully up to date in RW 8.0.3. On the home page, but not the sub pages, I’m seeing a gap between menu bar and slider + strange circles (see images) beside menu items. I have tried everything to tidy this up, but to no avail. The only difference between main page and sub pages are additional Font Pro style stacks in the Single column foundation stack for fonts

You can see the circle, to right, between menu bar and slider, on the ‘Contact’ item, the O of ‘Course Info’ and also the gap here:

56

and here are the circles on the sub-menu items:

27

The Gap is only visible in Safari (latest), not Firefox or Opera, but the ‘circles’ are on all.

No padding or Margin and disabling Bullets on the slider does not help

56

The site is: https://wildphotographer.co.uk

Caches have been cleared, site reloaded from scratch, but no joy!

Thanks for any thoughts!

Nick


(Gary Wann) #2

Orbit is from Elixir not from Joe Workman. I use Top Bar extensively, but I don’t have orbit. I don’t see a gap under any of my top bars, so maybe it’s an Orbit setting. I don’t see the circles in the top bar menu, but I’ll have a look at my settings. It looks like the menu items are bing displayed as a ‘list’ with bullets.


(Neil Egginton) #3

Are you sure?

38


(Adam Shiver) #4

I sell a stack called Orbit that I’ve had for a very long time now, but Foundation also has a slider named Orbit as well. The one in use on the page linked by @NickWB in the original post above if the Foundation stack.


(Gary Wann) #5

Ah, got it. Just Googled for Orbit. I haven’t used the Foundation Orbit slider, I’ll have a play :slight_smile:


(Stuart Marshall) #6

Something is adding this css:

ul, ul li {
    list-style: circle !important
}

and it’s this that is causing all your issues. I don’t have Font Pro - is there a setting in there that controls list / bullet styles?


(Gary Wann) #7

I only see that gap between the menu and orbit in Safari. In Firefox, Chrome and Brave it doesn’t show. Looks like it’s the extra ‘o’ that shows in the RH edge of the ‘gap’ that might be causing the problem?


(Nick Wilcox-Brown) #8

Thanks Stuart, not completely cured, but you are a hero here!

The word ‘Important’ was the clue - a setting in FontPro that should not have been on

55

There is still some list thing going on with the menu (I can’t work out where) and I need to cure it, but the all important gap has gone #HugeRelief


(Nick Wilcox-Brown) #9

Now I remember why ‘Force’ was on - I find Font Pro extremely troublesome. Now all my Typekit fonts have miniaturised themselves again and the site looks like garbage.

:sob:

Later

Serious point here @joeworkman - If I use ! Force in Font Pro, the fonts are the correct size and behave as I would expect, but I am causing issues with ‘Top Bar’ Menus. As soon as I remove ‘Force’ the fonts revert to approx 0.7 em and look ridiculous. I have seen this issue for a while, but had not linked with top bar issues.

Am is missing a trick here somewhere (and should Font Stacks / Styles be in a Single Column stack)?


(Doug Bennett) #10

I would doubt that having the “Force” option would have anything to do with the circles being applied.
What Stuart(@habitualshaker) pointed out is more than likely the issue and shouldn’t have been placed there be any kind of “font” changes.

I would bet what you’re seeing is unordered list styling. See navigation items are almost always stored internally as an unordered (something ordered) list.
Something has added that styling (circle) to the unordered list.


(Nick Wilcox-Brown) #11

Thanks Doug, that makes a great deal of sense.
What I cannot workout is what I can have done in a stack, with no coding or CSS tweaking to add that styling to an unordered list. All was fine this morning until I changed the name on a page and moved the order of the Info page in the page list.


(scott williams) #12

look in fontPro style settings


(Doug Bennett) #13

I’m not at a Mac now(on my iPad), so I can’t help much tracking it down.
If someone else can help you great if not I would suggest process of elimination.


(Nick Wilcox-Brown) #14

@swilliam I have spent half the day in fontPro style settings - currently going through all the JW FontPro videos to recheck the way I’m doing things.

Interestingly, even using Joe’s Custom Style trick will not get my TypeKit fonts to appear the right size unless I use the force option. Odd


(Nick Wilcox-Brown) #15

Doug, Stuart, I owe you a beer or two!

So Style 2 had a list applied to it for inset text (I don’t remember doing it, but never mind). I still cannot find how the menu has Style 2 assigned, but turning off the list in style 2 has solved the issue.

I still need to work out why all the site text is small without ‘Force’ but issue fixed, Thank you very much!!

Sometimes we just need a kick of common sense :wink:


(martin james) #16

Hi Nick, I just spent 5 days trying to publish some sites after a consolidation of my service. My host had given me erroneous paths for my sub-domains. !@#$%^

So for people like me who have already used up our extra free time, do you have a one sentence - “avoid font problems” recipe you would like to share? thx Marty


(Nick Wilcox-Brown) #17

Hi Marty,
There is not one simple fix unfortunately. Using standard web fonts is the easy way, but to make things look better and more unique means using Typekit or G fonts with Joe Workman’s Font Pro.

Joe Workman makes very comprehensive instruction videos for his tools, all of which can be seen here: https://m.youtube.com/weaversspace?uid=nNk0Zm9qZvPIGahKsyqH8A

Good luck!


(martin james) #18

Thanks I guess I will try keep my sites uncomplicated.


(Nick Wilcox-Brown) #19

It is not so hard if I can manage :wink:

g (oogle - I hate swearing) fonts are free and Font Pro is very powerful.


(system) #20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.