Foundation TopBar changed display since El Capitan


(Daniel) #1

Hi,
I have been working with the latest Foundation theme 1.5.4 and latest Foundation Add-on Packs. Topbar 1.5.18 was showing as intended until I upgraded to El Capitan. I had all the latest versions of all the stacks and themes before upgrading. I have RW6 Version 6.3.4 (15071).

TopBar now shows only one level of submenu and rather than showing it under the menu bar, it shows the submenu item next to its parent, on the menu bar. See the snapshots below. The menu item Other Services should show 8 lines under but rather is showing only the first sub item in the menubar. The same goes for any menu item with submenu items.

This is true for the “desktop” menu type only. The mobile menu works perfectly fine and behaves exactly as before the upgrade to El Capitan.
This is true for the preview within Rapidweaver, exported preview in Safari and Firefox, and on the published website (http://www.cfir.ca/ztest/index.html)
Same symptoms for any page previewed and of the website
TopBar is set up in a Partial

  • I made sure I was not using any legacy stacks in the Partial
  • Removed TopBar from within the Partial and placed it directly on the page - same problem
  • I deleted the formatted TopBar stack and replaced it with a new one with minimal formatting on the webpage - same problem
  • I deleted the formatted TopBar stack and replaced it with a new one with minimal formatting back within the Partial - same problem
  • I created a new RW Project file placing TopBar stack right under the Site Styles stack, no Partials involved - same problem

I can send you the RW file if needed. Thanks for your time and help.


(Joe Workman) #2

Got a URL for us to look at?


(Diego) #3

I see the submenus in this site.
http://imgur.com/iZP12Ue


(Daniel) #4

Hi,
Thank you for your response!

Usually responses in this forum are so quick to come but yesterday so many people checked my entry without responding, I decided to revert to the last known good version and republished it (I guess I was a little impatient).

I can send the .rw6 file that is problematic if you want. Now checking the size of the file I’m wondering if there isn’t a problem with it (208MB!). Let me know how to proceed.

Thank you again,


(Daniel) #5

Ok, now no matter what I do, I get the beach ball constantly and it is impossible to work in this file nor in the last known good one. Trying to start a new file from scratch and see if Rapidweaver will keep lagging.

Any suggestions?

Thanks so much.


(Daniel) #6

Hi Joe,
Sorry to bombard you guys.
I tried to create new .rw6 files but as soon as I use the Foundation theme/foundation stacks, the size of the file ramps up to 115MB even with 3 pictures and no videos (about 20 pages max).


(Christopher) #7

Hi,

I had this exact problem a week or so ago. I was still on Yosemite at the time. I tried all of the debugging steps you tried as well and had the same result; problem persisted.

I eventually “solved” it (I say solved, because I’m not sure why it worked) by replacing my gratuitous use of Loghound’s Pluskit’s @import feature with proper Partials. I also shortened my top level names and made the font a tad smaller to fit all top level items across the bar.

I still have a few pages with Pluskit’s @import on them (although only one @import per page) and the top bar is working fine now.

Don’t know if the above helps.

Cheers,

Christopher


(Robert Ziebol 🖖🏼) #8

OK, so you have about 20 pages, each with 3 images on them?? That would easily make a project file be 115MB.


(Daniel) #9

Hi Vaneenoo,

Thanks for your tip. I can confirm it was also the Pluskit and @import that was causing the problem (in or outside of a Partial). Doing backflips now to replace this feature but all is working fine now.

Thank you joeworkman and Trystero for your time!.