Foundry Icons don't publish


(francis) #1

My foundry social media icons show up in my rapidweaver design page but the images don’t get published.
This is in my design page


This is after publishing:

:57%20AM


(Adam Shiver) #2

Hi there @flmcl – if you’d like to send me a ZIP file containing your project file, as well as a link to the live site, I can take a look at it for you.

I will be out this afternoon, as my wife and I are taking part of the day off for our wedding anniversary, but I will take a look as soon as possible.


(francis) #3

Thanks for getting back so quickly:
http://www.drsarahshell.com
sorry i am not sure how to send the zip file.


(Adam Shiver) #4

Create a zip file containing your project file and then use a service like Dropbox or something similar to send a link to me as a direct message here, or via email to adam at elixirgraphics dot com.


(Adam Shiver) #5

Just shot you a reply with some findings and things to try.


(francis) #6

Tried but no luck. Funny thing is if I preview within rapidweaver they show up. But after i publish it it wont show up.


(Adam Shiver) #7

You have several errors on the page, fonts not loading, jQuery not loading, etc. and the icons are loaded via a font (which is also not loading). The odd thing is, when I publish your project if loads perfectly fine (https://elixirgraphics.com/test/frank/).

Deleting what you’ve got on your server and republishing?

Also, are you publishing from RapidWeaver, or are you uploading it manually via your FTP app?


(francis) #8

I have deleted from server and uploaded through rapidweaver.


(Adam Shiver) #9

In your Stacks preferences, are you loading jQuery, FontAwesome, etc from the CDNs or no? The preferences (Prefs button) are found at the bottom of the Stacks settings palette in the Page inspector:

It is a long shot that that might be a problem. I doubt that it is honestly.

There’s something going on with your publish, but I’m not sure what it is. You’re missing a lot of files… I believe you’re even missing your rw_common folder.

You might try doing a local export and then publish via FTP and see if that clears it up.

That said, I do have to step out for the afternoon. Please let me know how it goes.


(francis) #10


(francis) #11

Thanks for all your great help Adam. I just republished all files and it is now working. Previously I just pressed the publish button in RW, this time i did republish all and it worked.
Frank


(Adam Shiver) #12

Not a problem. Glad you got it sorted out.