Freestyle slideshow does not show up

For the life of me, I do not know what’s going on. I used to be able to view the freestyle 2 slideshow in the ExtraContent1 container on this HV-Cefalus theme-based project. I can no longer view it on any browser.

The freestyle 2 slideshow shows up in Rapidweaver, but after publishing, it shows on no browser!

At some point, it stopped showing in Rapidweaver as well. I deleted the PlusKit @import element and added the slideshow itself in the ExtraContent1, and it started to show again, but only in Rapidweaver. After publishing, the slideshow disappears from view on all browsers (Safari, Chrome, Firefox).

I am at my wits’ end. Does anyone have any suggestions?

Check if you have the same page twice on your server - one with the ending .html and one with .php. Then delete both and publish again.

My freestyle page is html only. Ditto for my main index file.

Something very weird is happening. All my stacks have a 5-digit number in parentheses next to the title of the stack. Is this normal?

This is what the project looks like in Rapidweaver:

…and this is what the project looks like in the browser:

my recommendation when the the page looks different in Preview than when it’s published is to republish all files.

this does NOT mean clicking the publish button again.

instead choose Republish All Files from the File menu. this will ignore what RapidWeaver believes has already been published and republish everything again.

no matter the other details, when Preview and Publish are different that’s the first thing to try. it will improve things 99% of the time.

your page is massively complicated however. it has frames and many many many scripts.

the failure rate of any system is directly related to the complexity of the system. IOW complex pages are likely to have problems. if the republishing doesn’t work, i’d look for ways to simplify this page.

just some food for though: in my experience a few clever scripts and a bit of dynamic content is great at engaging users – but the many costs (speed, complexity, bugs, platform compatibility, etc) mean that there is a diminishing return the more you add.

while you might fix the problem by simply republishing or finding the culprit stack or whatever – simplifying your page will reap rewards long term – faster publishing and faster loading your visitors and perhaps even fewer problems.


1 Like

Thank you, Isaiah, but…

“massively complicated”? It’s one of the simplest projects I’ve ever made!

Of course it has iframes. Actually, just one iframe. How else would you incorporate a Google Map onto your site?

I also have two Formloom3 forms, a reservations form and a contact form, and a Weaverpix photo gallery. What’s so unusual about that?

I haven’t incorporated social icons or a sitemap yet.

At any rate, I have done what you suggested several times. Mark all files as changed, republish all files, to no avail.

There are numerous stacks out there pulling the map into the page without iframe.

Yes, I tried some of them, but none of them are good enough. Besides, they also use iframe code. That’s how Google Maps work.

I have been using the embed code from Google Maps on practically all my projects for years without any problems. Anyway, I am sure this is not the culprit. The home page has the freestyle banner not showing problem, and it does not contain a Google Map embed code.

I tried several different options. Apparently, using PlusKit does not work in this case. I had to insert the freestyle stack directly into the ExtraContent Plus stack for the banner to work, instead of using the @import function in a text stack in the ExtraContent Plus stack.

Using divs and Pluskit with the extracontent code in the sidebar for EC1 did not work, either. I had to remove it, and only rely on the ExtraContent Plus stack directly on the page.

Thus far this has only worked on the home page. I have not tried to import the banner on any of the other pages yet.

Thanks to everyone who tried to help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.