RW Publishing - the worst nightmare in RW


(Simon) #1

I cannot understand why after 3 versions of RW you still cannot produce a robust publishing app? A look at the forum alone shows that publishing is your weakest point, and yet it’s the most important for the developer. If I cannot get my site online, what is the point?

I’m sick and tired of opening a project with publishing details all set, doing a 30s edit and then get an error in publishing. I then spend another 45 minutes trying different things and it still doesn’t work so now I have to export the site and FTP it using a proper app.

Either fix it or create a conduit to use proper publishing apps such as Transmit or Yummy FTP.

By the way both Transmit and FTP have no problems whatsoever using the same credentials in RW.

After 3 years of fighting with your flakey publishing feature, I’m annoyed enough to have this rant.

//Rant over.


(Dave Farrants) #2

There has to be something more at work here, I’ve been on RW since v4, now on 7.1.7. I run OS 10.11.6 on a 2009 MacPro Quad and apart from two occasions with updates that were sorted quickly, I’ve NEVER had ongoing publishing issues. I run 8 different sites for 8 different people on 3 different hosting companies, using both SFTP and FTP publishing with a mixture of large and small sites, some with almost daily updates.


(Simon) #3

This has sadly not been my experience. RW consistently fails to connect, but the same settings with Transmit have no issues whatsoever. Im running a 2015 imac on 10.11.6 and RW 7.1.7. I do not appear to be alone judging by the amount of posts about publishing problems on this forum.


(Dave Farrants) #4

I understand your frustration and I know many people do have publishing problems, if RW could find a common link from the complaint posts then perhaps it could be fixed, this is obviously made more difficult by the many, like me who have none.


(Robert Ziebol 🖖🏼) #5

If you use stacks or pluskit (or both) I would suggest you get the latest Stacks update (3.2.5) sounds like many people are finding success with this update.


(Rob D) #6

I am now pretty confident that the common culprit for those of us who don’t find Publishing useful, is the same as for those who have problems with Exporting to a local folder: the combination of RW 7.1.x with Stacks plugin and PlusKit.

I have 3 pages that use PlusKit @import on my main site. Publishing has never worked for me. So, I was exporting instead. This has worked for me like a charm, until RW v.7.1.0. After that, RW was always crashing on Export.

Good news: as soon as I installed Stacks 3.2.5, I am able to Export again. I also tried to Publish (Extended Passive mode and Lightning Fast connection) and it worked, too!


(Simon) #7

I do not have pluskit and I’m on 3.2.5. Export also works fine.

It’s just that publishing is extremely flakey in my opinion. It was on my 2007 macbook pro and on my 2012 macair and now on my 2015 imac. My imac was a clean install so no cruft from migration. During that time Transmit has worked on all three systems with the same setup credentials and hasn’t flinched once.

I’ve noticed that RW doesn’t give you a choice with FTPS. There is no choose between “with TLS/SSL” or “with implicit SSL” and wonder if this is the issue.

Anyhow, my workflow for a long time just exported the site and synchronized using Transmit. I have returned to this as I realise after 3 years that RW just cannot get this right. What would be useful is if they allowed users to chose their FTP client in app and upload through the client.


(Dave Farrants) #8

Don’t like to burst your bubble but one of my sites that I’ve had no problems with in v7 and it’s updates also uses Pluskit @import on 3 pages…good to hear you’ve at least sorted your problem though.


(Rob D) #9

Hi, @DaveFox, I did not have problems in v. 7.0.x. It all started in 7.1.x.


(Doug Bennett) #10

Simon,

Have you tried using a port number on your FTPS?
Some host require a port number.
Check with your hosting company, and if they have the port number then simply add a colin :followed by the port number on your server name in your publishing setup.
ftp.example.com:23261


(Simon) #11

They do require a port number but it is the default 21 for ftps.

I’m not going to try it because my set works vie export and Transmit synchronisation, which is far more robust.


(Larry F.) #12

RapidWeaver publishing has never worked for me. My first version was 7.0, I believe. We’re up to 7.1.7 and it still doesn’t work. CyberDuck, using the exact same credentials, works each and every time. I don’t use PlusKit in any of my projects.


(Andy D) #13

It’s definitely unreliable.


(Charles Vogan) #14

Just for the record, I also have had nothing but trouble with publishing in RW for the last several versions. For as good as the program is on design and ease of use, the really important part has been nothing less than frustrating. There’s no rhyme or reason! “Publish” - fails; save project, “Publish” - this time it works. “Publish” several times in a row, all failures. Quit the program, come back in, “Publish” - sometimes will work, sometimes I have to save and try again. At times I’ve been at it for almost an hour trying to save a “quick edit” and have to give up till the next day.

In fact, I haven’t updated to version 7 yet because a major stacks developer told me that version 7 is worse on publishing than version 6 is.


(Simon) #15

@cvogan

I would seriously encourage you to export and use something like Transmit (https://panic.com/transmit/) to synchronise your files. I’ve had NO troubles with Transmit in over 5 years use and the workflow is quicker than RW. Transmit will synchronise the files in less time than RW. The export from RW is usually fast as it’s got no FTP connection going on.

I have an “Export” folder in my project folder, which once set up after the first export is the default it goes to. My workflow goes as follows:

  1. Command-S
  2. Command-Shift-E
  3. Alt-Tab to Transmit
  4. Select local folder
  5. Connect to FTP
  6. Synchronise

If you have Keyboard Maestro or now automator, it only takes one keyboard shortcut.


(Greg Schneck) #16

I also highly recommend Yummy FTP. Yummy also has a droplet app and folder Watcher app. Some time ago I compared Yummy with Transmit and Yummy was faster (with same basic setups between the two apps.) But your experience may be different. That was my particular case only.


(Simon) #17

I’ve got Yummy FTP Pro, but the watcher was always temperamental. Yummy FTP Pro is good though.

I’ve got a Keyboard Maestro workflow that essentially saves the RW project, exports, opens transmit and synchronises my two folders. If you try this you do need to remember to set up the two folders as favourites in your local and remote favourites section.


(Greg Schneck) #18

I’m using Maestro right now to convert/transfer 800 blog pages to stacks pages. great product!


(Don Sinclair) #19

I make 20 changesto my site a day and the latest version repeats 600 files. Totally crap. Publishing is not flakey it is awful.


(Bryan Dunleavy) #20

Regardless of the defenders, the Publish feature has always been “iffy”, and I have been using RW since v 3. Many times over the years I have had to use an ftp program to rescue the situation. I don’t know why this should be. FTP is a fairly ancient and robust technology. But there we are.
I will add this. I have recently had to rebuild one site from the ground up in RW7, (After upgrading to Mac OS12 I could not retrieve the files from my network drive.) and I have found that the “Publish” command works quickly and seamlessly.