Having HUGE issues with Stacks - HELP!


(Marylou Badeaux) #1

I have sent an urgent email to Yourhead.com … no answers yet. Realmac Software can’t help. All of a sudden, whenever I go to export my site, I get a message cancelling the export. I’ve attached just 2 examples. Can ANYONE help??? Urgently trying to get changes up on my site.

I’d uninstall everything and reinstall but cannot find anything other than the RW6 programme …


(Marten Claridge ) #2

Hi Marylou,

Yourhead are five or six hours behind us but I’m sure they’ll respond as soon as they can.

In the meantime, do you remember what you added before the errors appeared? Have you tried undoing your changes or removing any additions you made? Removing stacks on a page one-by-one and then previewing is often a good way to start troubleshooting as it helps to zero in on what might be the problem.

How extensive are your changes? Have you duplicating your project file and seeing if the copy also throws an error? Have you tried restarting your Mac?

Marten
RapidWeaver Central


(Peter Danckwerts) #3

I’d recommend duplicating the whole project before removing stacks one at a time.


(Marylou Badeaux) #4

thanks very much! The errors actually appeared AFTER migrating ALL my files to a new computer (Mac Pro 4core). I’ll try your suggestions.

Also, it might be worthwhile for me to grab an older version from Time Machine and see what happens…


(Isaiah Carew) #5

The error indicates that some internal bits of the stacks plugin can’t be found. So I’m guessing however your transferred the files to your new machine didn’t go so well.

Probably best just to download a fresh copy of Stacks (http://yourhead.com/stacks), install, and see if that improves things.

Isaiah


(Marylou Badeaux) #6

I tend to agree and have re-installed Stacks. Same result. Am in touch with yourhead.com to see if they can help. I may have to ring Applecare as well as it was a migration from a Time Machine. Incredibly frustrating as I also tried a new project with the same result. Any other suggestions, even removing completely and re-installing ALL plug-ins (a real pain)? Thanks very much


(Butternut Squash) #7

Hi Marylou,

It is not clear from your original post whether you did in fact reinstall RW, but in any case, wondering what happens if you sign on as a different user.


(kris ) #8

This post was flagged by the community and is temporarily hidden.


(Isaiah Carew) #9

In your screenshot here you posted an error. But in the screenshot you sent to support your error was slightly different. I suspect the reinstall actually did change things – but that that there are still other things yet broken.

Since this all happened after a Time Machine restore I think it’s very reasonable to assume that something went wrong during that process.

I would strongly urge you to create a new backup of your data (not just this file or Stacks or RapidWeaver but all of your data). When things go wrong with a backup/restore then it can be catastrophic and it’s always better to be safe than sorry. :smile:

OK – that that out of the way, I think what I’d recommend as a way forward would be to start with the basics and verify each bit works in turn. Don’t proceed to the next step until you know the previous one works. In this way we can build up from working system until we find each broken bit.

  • Download and Reinstall the latest RapidWeaver. And run it with no add ons at all installed. Make sure that you can new/save/open/preview/export a new file – don’t attempt to open your previous files just yet – we’re just verifying the basics first.

So, if you’re here – the we know RapidWeaver is working and you can move on to your add ons.

  • Download and Reinstall the latest Stacks. Make sure that you can create a new file, add a stack, preview, save, open.

So, if you’re here – then we know RapidWeaver and Stacks is working and we can move on to other things.

  • Install other add ons and test in turn. For now, you should try to limit this to just those needed to open your file.

So, if you’re here – we know that RapidWeaver and all your add ons are working.

  • Now open your file and see if things improve.

If things are working, great – we fixed it by reinstalling things – if not then we can be certain the problem is that the data in the file is somehow corrupted by the TimeMachine backup/restore process. If that’s the case, then it might be wise to take your machine/disk to expert (Apple Store) to see if there’s anything that can be done to restore the data without errors.

Isaiah


(Marylou Badeaux) #10

Thanks so much for taking the time with detailed help. I have learned to have multiple back-ups :-)) I am now going to devote the next hours to following your instructions to see how I go … fingers crossed. Will let you know. Thanks again!


(Marylou Badeaux) #11

didn’t get far :-(( Home page and I just did some text. Tried to export and this is what I got …

make sense to you???


(kris ) #12

This post was flagged by the community and is temporarily hidden.


(Marylou Badeaux) #13

Thanks Kris… tomoro I will put down detailed info … it is very complex because of a switch in computers and the new computer was NOT what I ordered (whole other story) and I’m limping by using an external drive … all details tomoro. Meanwhile, I went in with the urgent website and reinstalled Rapidweaver on my old machine (iMac) and was able to do the basics of what I needed to do to get changes published.

Gives me just a bit of breathing room on this issue. End of day here in Australia and I’ve had enough of this for another day :-)) Glass of wine time.


(Marylou Badeaux) #14

Here’s the info:

OSX 10.10.5 on BOTH old (iMac 27" 4 years old) and new (Mac Pro 4-core)

Here’s where it gets problematic. I purchased a 512k 4-core with 32gb ram. The dealer (said he was authorized, was not) sold me 256k with 12gb RAM. I am mounting action against him. When I received it from him, he told me the internal flash drive (leading me to believe it was the correct 512) was faulty and Apple told him to return. He gave me an external 4gb drive to work with until flash drive was repaired/returned. That external failed after a few days. Went to Apple store – tested and found it was no good. They then discovered no flash drive inside computer and said they NEVER have ANYONE return JUST the internal drive. Eventually, they installed a 256k. Went home to do migration from Time Machine (ran disk utility on it). Of course, loads did not fit. I twigged to what had happened and now in the middle of a huge “situation” trying to get rectified. In the meanwhile, delegated an external drive – LaCie 6tb – as the new system disk with all my info. Now, tons of permission issues, etc. Have been on with AppleCare every other day. Waiting to resolve issue and will have to get new computer with correct internal.

I can copy files/directories between disk drives on same computer. Yesterday, I put website info on an external and took it over to my old computer to make the fixes I needed to do. I re-installed RW6 with the necessary stacks/add-ons to do the work and I got it done.

I have not used any other backup/restore tools.

I uninstalled RW6 and ALL plug-ins, add-ons to start fresh on new machine. Opened a new project and used a text page to try and test. I just put a bit of text on what would be the home page … that’s when I got “unable to export index.html” Haven’t even tried to add a stacks page …

Sorry for all the info but it’s sort of necessary to understand how wacky this all is.

THANKS


(Peter Danckwerts) #15

It sounds completely bizarre. Wouldn’t it have been cheaper and better to buy a new lower spec Mac from a reputable source (such as Apple Store)? The iMac I’ve had for more than 8 years, which only has 4GB RAM and a 500GB HD, runs RW perfectly, Not that I wouldn’t like a new one.


(Marylou Badeaux) #16

the part I didn’t put in … this is someone who WAS an authorized reseller (and didn’t bother to tell me he is no longer authorized) AND I’ve been buying Apple products from him for over 10 years with great service, etc.!!!


(kris ) #17

This post was flagged by the community and is temporarily hidden.


(Marylou Badeaux) #18

as an update (and MANY thanks for all your help) … I have re-installed RW6 on my old iMac so I could get my work done. Removed RW6 and ALL plug-ins from new computer. Have re-installed RW and Stacks … no other add-ons at this point. Testing with those two works. My guess is that the issue is somewhere in the other add-ons, plug-ins I’ve had. I’ll add them back in, one by one, as you suggested. Also, as happens, there were several plug-ins I don’t use anymore so won’t put those back.

Thanks again … lots of pressure off now that I’ve got the old computer doing the website work.