RW& and Stacks Trashed!


(Kim Michael Loader) #1

HELP! Because of illness I have been unable to work on my website and had not accessed RW7 for two years. When I attempted to run RW7 for the first time again last week nothing worked - themes, add-ons and plug ins were all over the place or missing completely. It was as though a burglar had been in and trashed everything. My first thought was that I had missed several updates and re-downloaded a clean version of RW7 and managed to recover a lot of missing software from the original developer’s licenses but to no avail. RW7 refuses to operate at all and even if I try to use the basic Text stack I get a message asking me to buy more stacks now! Stacks which I have already purchased. YourHead support have been trying to help but nothing seems to work and I’ve no response from an email I sent to RealMac. I would be grateful for any help at all anyone can offer as I can no longer edit my site.


(Doug Bennett) #2

I’m not sure what you’re saying here. You said “RW7 refuses to operate at all”, but it’s asking you to “buy more stacks”? Can you be more specific? What happens when you launch RapidWeaver? What exact message are you getting or does RW freeze up or what? Screenshots and details would help you get help.

RapidWeaver should look for all addons (themes, plugins, stacks, etc) from a single location. Starting with RW7 you could choose to change this location. The default location is in a hidden library folder. You said “all over the place”, where exactly did you find what? That might give a clue as to where you had your addons folder placed.

If you had it set to the default location when you did a clean install of RapidWeaver it should have found them.

You can also have a look at these knowledge base articles about addons:
https://help.realmacsoftware.com/en/?q=Addon+

You could also do a finder and or spotlight search for the missing addons. You could search for something like the file extension .stacks (All stacks use that extension).

Hopefully you can find them, if they got deleted and you have no backups (TimeMachine) then you’re probably going to have to address them one vendor at a time to get your purchases restored.

RealMac can only help you with the actual RapidWeaver install and license. All the addons are from independent developers. Many of these developers have support areas to recover lost software.

You probably don’t remember everything you had, but if you want help identifying what you used on your current site then post a URL and someone here can probably help you out.


(Kim Michael Loader) #3

Sorry, ‘all over the place’ was used in a general sense. All my add-ons (or nearly all ) are separately recoverable from the original licence keys which I have kept. When I run RW7, it will open and shows all the add ons and plug ins, etc, but immediately I try to use RW7 it throws up a message and won’t function at all. I have included some screen shots this time.


(Joe Martin) #4

Looks like you may have installed Stacks 4…edited the .RW file and saved…and now that requires you to buy Stacks 4…if you didn’t save a version with Stacks 3 you are out of luck. Time Machine might help.
Just like if saved a version with RW 8 and tried to open with RW 7…not going to happen.


(Doug Bennett) #5

What Joe said is true. You’ll need to use the stacks license key to register the old version. You can get that version key at the bottom of every page at YourHead’s site.

If you saved the project with stacks 4, you’ll need to grab an older copy from TimeMachine or upgrade to stacks 4. If you register your stacks 3 copy I think you’ll get an upgrade price?


(Kim Michael Loader) #6

Thanks to all, I managed to find the old Stacks 3 serial number and did as you suggest - got a discounted upgrade and everything now seems to be recovered. Might as well upgrade to 8 now! A little disconcerting thought omrealise you can’t really leave things unattended for any length of time. I am very relieved though; I have used Rapid Weaver since its very early days, and having had two work with Wordpress lately I much prefer RW.