Unable to see new changes

I am using RW 8.1.7. Its up to date.
I am able to save the changes.
Am able to see the new changes in preview
But after publishing the new changes dont appear on the website!
I have tried everything based on the answers suggested here on the forum.
Any help will be appreciated.
Thank you

Check if you have both a html and php file in the page folder with the same name.

If so, delete the html file.

1 Like

What @instacks syas. This is nearly always what causes such problems. You probably had an html page and then added a stack which needed php.

1 Like

Thank you so much for your response.
I dont see both html and php files.
In the advanced settings its set to html.
Within the stacks all the filenames (of the pages which dont show the saved changes) also show html.
I can see the changes in preview mode and when I simulate and even when I open it as preview in browser. I hit publish and it goes through the whole process, says publishing is done, visit the site.
But the site doesnt show the recent changes…
RW and stacks up to date.

You need to provide a URL so we can have a look.

Some stacks will automatically change the filename to .php if they require it (forms stacks, for example) and it won’t reflect that in your project settings. You can manually check it by going to your website and manually putting in the html and php versions into your browser to see if they exist. (i.e.: mywebsite.com/index.html and mywebsite.com/index.php)

1 Like

Thank you @jabostick will try this
@swilliam Both my partner and I hv RW websites. I am helping him correct this problem in his website. I will ask him to join the forum and send the URL. Will he be sending the URL of the website or the page which is not showing the recent changes?
Thank you so much, we have been struggling with this for the last six days!

A link to the page that is not showing the recent changes.

A description of what’s different/not showing will also be helpful.

Thanks, Jason. I’m with Ash here. My URL is https://forrestgander.com I’ve followed your advice and checked for a php version. There doesn’t seem to be one. The html version shows up-- but it’s not the one i see in my rapidweaver. It has stopped uploading changes that appear to have been saved and published on rapidweaver. Weirdly, I just won a Pulitzer Prize and so I’ve got more traffic than I’ve ever had . . . AND a frozen website. I’m mystified. Thanks for any suggestions you might have.

There is no .php page so maybe it’s just your browser cache? Try loading it with an incognito window.
What changed? I can share a screen shot of what I see.

Hey Scott. Incognito window shows same thing that you see. But I’ve made changes to that page and published them but they don’t show. To take a simpler page, this contact page shows an old contact-- Alison@blueflower.com I’ve changed that on rapidweaver to barbara@blueflower.com I published the change and on rapidweaver I see the change. But it never makes it to the website.

Is there something amiss with how you are naming pages? Check the real name for that contact page. It is listed at the site as:

But it would be better named to be:

Okay, then you have a publishing issue.
Try this:
Right click on the page title in RW and select re-publish (see if that works) use incognito window.

Did it change?
You can also go to the file menu and mark all pages as changed and republish all files.

@Mathew makes another good point (although not your issue) you should name your folders and leave the files named index Webservers look for index(.php or .html) by default. it makes for a cleaner url.

Oh, one more thing… Are you using CloudFlare or another CDN by any chance?

Well that’s interesting, Mathew. But here’s where my idiot comes out. How would I change that? The website was working fine for years. I wonder if this is a new problem-- maybe from working on the website from another computer? But in Rapidweaver, I don’t see how to address the page name. My incapacity. Thanks for any advice.

Hey Scott (and Mathew and Jason)-- it’s just uncommonly generous of you to be so responsive to a stranger. I’m really grateful. I right clicked on page title and republished and opened in incognito window-- but the changes haven’t taken. I’ve also tried (3 times) republishing the whole website. Rapidweaver republishes and it all looks good on Rapidweaver, but not of the changes appear online.

Can you post a screenshot of your publishing settings in RW? May be a problem with the path.

My guess is something simple needs to be fixed. But I have no idea what. If someone is willing to look at your project file (I’m off to meetings) then I’d share the file with one person. My guess is they could spot your problem in less than 5 minutes. (Only a guess mind you.)

Someone’s publishing settings are wrong…
If I go to https://forrestgander.com/public_html/Contacts/Contacts.html
I see the new page:

1 Like

These are my publishing settings. When I test them, they pass the test.

Wow! But where IS that?
These are the same settings I’ve used for years: