How can I change my RW File Path - to avoid manual changes on Bluehost from being overwritten on publisihing


(Nicko) #1

I recently reactivated my Bluehost account (sadly after missing a payment). Prior to doing so Bluehost assured me that all files would be as they were - nothing would change. Oouch - Not so…

Long story short, after reactivating my hosting nothing worked as normal. After lots of back and forth, it turns out Bluehost have changed my file path. The root cause of the problem appears to be the home partition changing when my account was reactivated. The file path has been changed from

/home6/thegrfc3

to

/home5/thegrfc3.

Bluehost manually changed the file paths to fix it (not all, but it was a great start), but when I republish from Rapidweaver, Rapidweaver overwrites all the updated file paths (/home5/thegrfc3.) back to (/home6/thegrfc3.)

How do i change the file path in Rapidweaver so it doesn’t overwrite the manual changes?

I have included an image below as it looks like I should enter the new file path in Rapidweavers ‘publishing’ pain under ‘path’. But it seems odd as (see image) the current path area is currently and has always only been ‘public_html’. What will happen if I change the path to the new filepath - /home5/thegrfc3.

Any guidance would be fantastic. I’m a bit scared to mess this up - as this path change has caused a lot of issues and has been time consuming fix - I never let hosting lapse again!.

NOTE: After many phone calls and emails with Bluehost all their pretty awesome support, still did get my website online - they had no ida what the issue was - no idea it was the file path. Adrian from Vibrologix/Sitelok was the one that worked it out and has always been incredibly helpful beyond any support I ever experienced. I’ve dropped this in here in the hope I can avoid asking Adrian for help, which he has already offered.

thanks in advance.


(Don H) #2

What do you see when you use the browse button next to the path field? Can you see where you are supposed to put the files?

Honestly, it seems to me that they still have something wrong in your account. The home folder is above the level of your user folder. When you login with your user ID, I would not expect you to have any rights above it. Which means, you probably can’t go up a level and change from “/home6/thegrfc3” to “/home5/thegrfc3”

You probably need them to fix this.


(Nicko) #3

I have added a screen shot - can i change the file path as required? I looks likes no to me, but I’m not sure.

I have asked if they Bluehost can change the file path back to what it was and they said no. This project has taken me years - i don’t what to do at all? I will go back to Bluehost and ask again. Any advise - is there another way to change the file path?


(Doug Bennett) #4

Try clearing out the path field first, then select the browse button.


(Nicko) #5

Thanks DLH and teefers, I’ve attached an image, but doesn’t look like the option is there? Correct me if i’m wrong though. Anything other ideas? I’m freaking out.


(Don H) #6

You do not need them to change the path back to what it was.

You do need them to change the default path of your user id to point to the new home directory.

If the files are now being served from “/home5/thegrfc3”, then when you login using your user id (thegrfc3), then you should be placed in the directory “/home5/thegrfc3”. If you are not, then they need to fix that.


(Don H) #7

I’d also have them confirm that your domain is now being served from that same directory ("/home5/thegrfc3").


(Nicko) #8

Ok - I’ll shoot that over to them - I appreciate your help. thank you.


(Nicko) #9

I had to read that a few times to understand, but that makes sense, i hope it works - thanks again.


(Nicko) #10

@DLH Below is the response from Bluehost. What are your thoughts? Have Bluehost covered what you recommended? Thanks.

Hello Nick,

Thank you for providing the response. The $HOME variable for your user is set to /home5/thegrfc3, as you can see below -

thegrfc3@cashdupp.com.au [~]# echo $HOME
/home5/thegrfc3

However, it is entirely possible that there is a setting in your software’s configuration that still points to /home6/thegrfc3. Unfortunately we are not trained to support RapidWeaver, so to determine how to alter this configuration we recommend contacting the official support team for this software.

If after contacting support for your software you are unable to determine why your content continues to reference /home6/thegrfc3, please reply to this email with steps that we can take to replicate the issue you are experiencing and we would be happy to investigate.

Please let us know if you have any further questions.

Regards,

Heston


(Don H) #11

You are likely fine. Have you tried making a minor change to a page and then publishing changes to see if the change appears? You may have to clear your browser cache to see it appear.

You could also login with an FTP app or your control panel and see if they page’s html file shows the updated date. You’ll then know your changes are going to the correct location. You could also login with an FTP app and see if the folder tree shows home5 or home6.


(Nicko) #12

Awesome - Thanks for that. I tried publishing the home page, but hadn’t cleared cache. I’ll have run a few tests and let you know how it goes. Thanks again.

Also a thought: Would there be anything you can see in my .htaaccess as below that maybe causing issues?

Use PHP70CGI as default

AddHandler fcgid70-script .php
RewriteEngine on

RewriteOptions inherit

AddHandler application/x-httpd-php5s .php

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://cashdupp.com.au/$1 [R=301,L]


(Nicko) #13

So I tried deleting all the files in file managers public_html expect for sitelok files. And then republished the home page with Rapidweaver. Now all i get an automatic file download when I try to go to my URL.


(scott williams) #14

what is the name of your home page? index.html?, index.php? something else?


(Nicko) #15

@swilliam. Im currently publishing, so can’t double check, but is ‘index.html’ from memory. Why’s that? I’ll double check as soon as publishing is complete.


(Doug Bennett) #16

interesting:

If I give a full URL https://cashdupp.com.au/index.html I get a 404 not found.
If I give a full URL https://cashdupp.com.au/index.php I download the php file.

I would remove the addHandler and for that matter everything in the .htaccess file and test.


(Nicko) #17

ok thanks - ill give that a go. still currently publishing, but will try asap.


(Don H) #18

I really just wanted you to make a small text change (like adding or removing a word) on a page and then just publishing as normal. I wanted to get you to the point where you were publishing to the correct location before doing something like removing all files!

As Doug said, remove that addHandler line from .htaccess and lets see if you home page will load.

edit: make sure you remove both addHandler lines.


(Nicko) #19

thanks - yeah I did notice that. That’s alright - I’ll let you know how I go. thanks


(Don H) #20

Looks likes it’s mostly back up. You do have some insecure content errors that are preventing some fonts from loading.