Http redirected to https

A friend of mine redirected my website from http to https in admin panel.
My sites is “safe” now but i’m not able to change (after uploading new things)
the site after that. (RW will publish /republish all files).
Admin panel has been a bit of no go zone for me, but i’m afraid i have to
enter the battlefield.
Somebody a clue?

Did you change the address in the RW it settings

Not sure what you mean “not able to change”, what exactly is happening when you change something and republish?

Without knowing what was done in the admin panel and what problem you’re seeing it’s difficult to say whether the admin panel changes had anything to do with it.

Thank you for your quick response!
I can change my website in RW but the changes don’t show up after publishing.
I thought that it must be the somewhere in the admin panel because that’s the only thing where something has been changed.

Probably something else is causing stuff not to show up. When you say you changed something what did you change? Did you change something on an existing page or add a new page?

Did you try clearing your browsers cache or try a different browser?

I just put in some more text and added a link on a one page website.
It’s the same in Safari, Chrome , Firefox

The redirect to https seems to work fine. When you publish does it give you any error message?
I’m not at my Mac right now so I can’t really do to much to check file dates.
Since I don’t know exactly what you changed I can’t tell if the changes are ther or not.

If you not getting any error messages when you republish all files I w double check the path in pu settings.

I can see that my changes are in the ci-bin folder, so the changes are where they should be I think. But I know nothing about http and https and redirections.
I added a few lines of text and I added a soundcloud link to the site.

Can you post a screenshot of the folder where you see the most recently changed files? Did you mean “cgi-bin”? Typically, that isn’t the correct folder for your html files.

Also, post a screenshot of your publishing settings.

1 Like

The cgi-bin:

inside that folder:

and publishing settings:

Thanks for your help!

You haven’t mentioned your hosting company, but nothing you do in RapidWeaver usually would go into cgi-bin directory.
The cgi-bin directory should be strictly used for cgi(Common Gateway Interface) components.

My best bet from the path in the screenshot above is that you should be publishing to the parent directory public-html That’s a very common path for many hosting companies.

The screenshots above you cut off the one with the parent directory of cgi-bin, but I would bet if you scrolled down you would find the index.html file that continues to display.


Problem solved!
I had to change the path in ftp settings.
Thank you so much for helping me out!
This forum is such a great help to me.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.