I purchased CodeGuard but it isn't showing up in my Chilidog hosting area

Most importantly the web browser still lists my site as unsecured. I hope to get that resolved very soon. Thought it would show up automatically after purchase.

Update: tech support is now getting back to me so hopefully this will get resolved through their help.

Hi @KipV

As mentioned via support,

  1. You needed to add a .htaccess code to force users to the secure version of your site. We recommend Option #3 of our WeaverTip Force SSL. Just be sure to customize the URL appropriately
  2. I know it can be a little confusing, but CodeGuard is showing up in the billing area. It shows up in two locations
    a. Immediately when you log in to the billing area approximately half way down
    b. As it’s associated with a specific service, on the service details page.
  3. Our primary support is via our billing area. We may not find or see these questions posted here. Please contact us via our billing area and we’ll be happy to help.

Thanks
Greg

4 Likes
  1. The htaccess file should have been setup already.
  2. Yes, I can see it set up in the billing area but I am stuck setting it up. It’s hard to log in right and whenever I succeed I’m still not completely sure what the root directory should be.
  3. Okay, I just figured I could get though this part with not this much work. I guess that is one reason I went to the forums there are just so many things to have to get through and I can’t tell how high of a threat a lot of it is.

The favicons seem to be causing the “mixed display content” errors but I have no idea what to do about that. Surprised a little image in the URL bar could be this big of a deal. Whatever isn’t working about that would fix two out of three errors.

Hi @KipV

Is your RW project set to use a https:// url? Yes, for a site to be secure, all items on a page (including a favicon) have to be loaded over HTTPS.

-Greg

I thought I switched it over to https:// . That is what automatically comes up in the URL bar when I type in the address. Do I remove the favicon and put it back in now that the site appears to be https?

In your RW general settings and publishing settings, make sure both are set o https://

1 Like

Okay I changed it so that both general and publishing say https://

I removed all the favicons and found that Firefox is finally telling me the connection is secure for the first time! Can I now re-enter in my favicon now that everything is set to https? Or how do I go about adding the favicons back in?

Yes, have at it. You should be good to go.

Okay good, I noticed there is one more Firefox message but I’m not sure if it matters that much given that it does not set off a unsecured message:
“Use of Mutation Events is deprecated. Use MutationObserver instead.”

Is that okay to just ignore? I don’t know what any of that message means.

Yes, ignore it

1 Like

Okay than, thanks for the help! It’s good to basically have things up and running.