Installing Foundry and Foundry 2

I’m trying to install Foundry 2 and having the same problem as AdrianB “A little trouble with installing Foundry” By the way I had the same problem when trying to install foundry 1

My install process is exactly the same except I get

“At least one addon is older or the same version as the one already installed. Are you sure you want to continue?”

then when I continue I get “Some addons could not be installed Please click the warning symbol next to each addon for more information.”

When I click on the warning next to the Foundry.stack I get “Foundry.stack” couldn’t be copied because you don’t have permission to access “Stacks”. To view or change permissions, select the item in the Finder and choose File > Get Info.”

And next to foundry.rapidweaver “Foundry.rapidweavertheme” couldn’t be copied because you don’t have permission to access “to Install”. To view or change permissions, select the item in the Finder and choose File > Get Info.

I am a newby to Rapidweaver and really struggling just to load the Foundry 2 addon I have tried reinstalling and every other recommended option. I have stacks and an number of other addons installed with a total purchase price of over $200. I really want to get into the system.

Please help me get Foundry 2 installed. I have written to the developers but have had absolutely no reply.

That’s an unusual error message. It sounds like a permissions issue on your mac. Her’s a couple of things to try.

Start RW and then drag the “Foundry.stack” and “Foundry.rapidweavertheme” files onto the running RW icon in the dock. This will ensure RW is trying to install them in the correct version of RW, in the event you have multiple copies installed on your computer and they do not use the same add-ons folder.

If you are still getting those errors, then in RW, go to the file name and select “Reveal Addons Folder”. It should open the add-ons folder in finder. You should see a folder names “Stacks” in this folder. Copy the “Foundry.stack” file to that folder and copy the “Foundry.rapidweavertheme” into the “Themes” folder.

If you get any errors, Get Info (Finder File menu) and check your permissions, Your user name should have read & write permissions to those folders.

1 Like

I had the same problem.

Open Rapidweaver.

Go to the Rapidweaver menu next to Finder on the Mac top bar.

Open the Rapidweaver menu. You will see REVEAL ADDONS FOLDER.
Click that and open the Stacks folder.
Drag and drop the yellow lego (from the unpacked Foundry dmg.) into the folder. It will overwrite the previous Foundry.

Hope this helps!
It worked for me at least.

Thanks for this it has worked partly. I can see most of the stacks but there are some that simply dont work or the icon is not shown but the name is.
Thanks for the assistance

Probably going to need more information, as I don’t follow what stacks you see or that don’t work.

  1. You can always delete the stack from the Stacks folder in finder, using the “Reveal Add-ons Folder” and place a new copy in there.

  2. Do not do this while RW is running. Open RW, use Reveal Add-ons and then quit RW before adding/removing and stack files from the Stacks folder.

This is what my stacks look like. I am missing stacks right the way through the foundry stacks. Biut at least i am getting some of them loaded.
Thanks for your ongoing help.

PS I tried reloading them and got the same result.

The ones with missing icons are not Foundry stacks.

Click on one of the ones with a missing icon and then click on the Details button at the bottom of the Stacks pane. That may give you a clue as to what they are from. It’s likely they didn’t get installed correctly or there is a permission issue with them too.

Hey there @Gazza!

This thread will clear up the confusion on those “missing” stack icons.

1 Like

That was it! thanks Adam.
Hey this is a great community as a newby I feel more comfortable than ever with all the help I get form you all. THANKS

Now when I try to use the stack its saying

Guys what is missing Im sorry to be a pest I just cant see how to add this.

You need a copy of the Foundry stack on any page where you use Foundry stacks. It has the base settings for lots of things like paragraph and header fonts, colors, etc. The control center stack is the one named “Foundry”.

You should probably start with the Quickstart area of the Foundry documentation.

If you are not familiar with the Partials feature of Stacks, you should also learn about them before you start making mutiple pages. They allow you to have the same stack on multiple pages that all use the same settings. They are good for things like: the main Foundry stack, your navigation, your footer, etc. Basically, things you want to always be the same on your pages should be in a partial.

Info on Partials can be found here. Partials work the same in v4 as in v3:


I should also mention that you also need the Foundry theme selected to use Foundry stacks.

  1. Set theme to Foundry
  2. Place “Foundry” stack on page
  3. Add any other Foundry stacks to the page
1 Like

Yes that’s what I’m doing. Just tried it again and it seems locked in the drop down.
I did follow this instruction an loaded the Themes as I was told previously.

You don’t drag a theme to the page. You just select it in the dropdown. When selected, it’s outlined in blue. It looks like you have it selected, so you should be good.

1 Like

Thanks for your help. All good now got it thank you very much for being patient with me.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.