Installing Snapform2 stack fails to install - am on RW7


(Alvin Ong) #1

I recently upgraded from RW6 to RW7 (I am running it on the OS X El Capitan).
Upgrade went thru without issues.

Then I purchased the Snapform2 stack from Yabdab.
Following the instructions given, after I unzipped the file (under stack3 folder) I double clicked the FormSnapBase.stack file
A dialog window pops up to inform me that the stack is installed.
I go the the directory where my stacks are placed, and I can see the above stack file.

However, when I start using RW7, go to library, the SnapForm2 stacks is no where to be found…

I have never had this problems with stacks in RW6 and before…

Any help is much appreciated - newbie on the forum.
I have gone to the discussion forum, tried some of the suggestions, but no joy.
TQ.

Alvin


(Jason Bostick) #2

You can try this and see if it works: http://kb.realmacsoftware.com/article/53-how-to-manually-install-addons


(Alvin Ong) #3

Hi,
As per the instructions in the link above, I went in to the said directory (for RW7)

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver
Difference is I have a subdirectory called Stacks, and upon going into it… I do find the stack file FormSnapBase.stack in it.
Note1. ALL my previous stacks are there (as expected).
Note 2. FormSnap2 is a new stack which I had purchased after I upgraded from RW6 to RW7 (7.0.2)

However after I restarted RW7, in the library list… the FormSnap2 stacks is still NOT there… very strange…

Alvin


(Mark Sealey) #4

Might this be helpful?


(Isaiah Carew) #5

A couple things probably worth noting:

  1. RapidWeaver 7 allows users to move the location of their addons. So going to a specific folder might not (if you have asked RW to move the addons folder) reveal the actual addons in use.

  2. When you double-click on a stack to install it, RapidWeaver launches and installs the stack. However if you happen to have multiple versions of RapidWeaver around on your system (yes, even in Time Machine backups and other hard drives that are attached) then sometimes the version that launches and installs is not the version you were hoping for. And if RW6 (or 5!!!) gets launched then the stack will be installed in the wrong spot (well, wrong for RapidWeaver 7).

The one true way to find out where your stacks library is, is to ask the library itself. :wink: You can do that with the menu option under the library (see screenshot below)

And… to ensure that you install the stack with the correct version of RapidWeaver – just make sure that RapidWeaver is already running when double click the stack. The finder will always open a file with a running app before trying to find another app to run.

As for your original problem… make sure to use the search field to try to find the stack you’re looking for – perhaps it isn’t Titled quite like you expect – or perhaps it’s sorted in the library a bit differently than you expect.

And if it doesn’t show up – then reinstall it again. This time making sure RapidWeaver 7 is already running when you double click. You should see the stack show up in the Stacks Library almost immediately after RapidWeaver says that it’s been installed. There’s no harm in installing it twice – RapidWeaver will “do the right thing” and inform you that it’s already installed if that’s the case.

Isaiah


(Alvin Ong) #6

Hi Mark…
Had a look at your trail of communications - I can more or less see that we have about the same problem with RW 7 (I am on 7.0.2). The only difference is that all of my stacks from RW 6 ported across OK, but I had since purchase an additional stack from Yabdab (FormSnap2). This new stack although it tells me that the installation of the stack is successful, but when I open any of my project RW files, this new stack is no where to be found. When I go to the default RW7 stack folder, I can see the new stack there (in Finder)… but its not getting picked up in the RW7 stack library that I can use it… I am totally stumped as to why this is happening.

Alvin


(Alvin Ong) #7

Isaiah,
Please refer to my reply to Mark… I tried your suggestion… and I am still having the same issue.
I am not sure if the problem is with RW7, or the stack which I got from Yabdab is not compatible with RW7.

Is there anything in the .RW6 project files which stores this stack information that could be over riding the current RW 7 setting?


(Mark Sealey) #8

Alvin,

I’ve spent much of the last week trying to make sense of this.

As Dan says, the default location is:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver

But I found beyond any reasonable doubt that RW 7(.0.2) does move Addons (which would probably include the Stacks that you’re having to chase); and create other directories to hold them than:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver

I did, I think, though, find two ways to stop this happening; at least the first is logical and predictable:

1 - tell RW where its Addons should be by manually moving them - e.g. into DropBox so that they can be shared between machines

2 - uninstalling older versions of RW6 and 7 completely… they may confuse the active installation

Then thre is a line in this file:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver 7/ RapidWeaver 7.log

indicating where RW where should look for Themes - presumably including, I hope, your Stack… after either/both of the above two steps have set a directory definitively:

2016-06-21 09:56:27.328 RapidWeaver 7[4867:78845] Themes directory path is: ~/Dropbox/Apps/RapidWeaverAddOns

Good luck!


Difficulties to install stacks or themes
(Isaiah Carew) #9

deleting old versions is very good thing.

i can’t do this because i need to test our plugins on old versions too – but i take precautions (like compressing old versions so they can’t be accidentally launched).

Unless you have specific reasons to keep those old versions around I’d highly recommend simplifying your life and removing them.

Isaiah


(Alvin Ong) #10

I did a TOTAL uninstall of RW 7 and some manual deletion of older RW folders from ~/Library/Containers/… Reinstalled RW 7 and individually reinstalled the stacks, now the Formsnap stack finally appears in the library.
TQ all for your kind assist.

Strange that I have moved from version 5 to 6 and now to 7 of RW upwards and have never encountered this issue until now.