Javascript header slide show is not working when published

Greetings,

For some reason the Javascript header slide show is not working when published. I works fine when viewed in RW8 Preview Mode. Any ideas why it is not working on my Bluehost server?
https://www.edophoto.com

ALSO the pop-up

's (about halfway down the page) also stopped working. I can just delete them and embed the Vimeo videos as is, but was wondering if anyone can tell why they aren’t working.
https://www.edophoto.com/movies.html

Using RW 8 Thanks in advance,

Ed

Did you recently change to https? You have errors of insecure content from google and vimeo as they are linked with http urls. Not sure if that is causing the problems, but worth checking.

Thanks for the reply. Its been https for some time, BUT recently I had to get them to redo the lock after having some problems. The straight embedded Vimeo links work for me. Its the pop window players (“fancy zoom” I think its called) isn’t working on my movie page. They seem to work in Rapid Weaver Preview mode on my HD.

If this helps This is the HTML code under the Javascript category.
on the index page http://www.edophoto.com

$qube(document).ready(function() {
$qube(’.lowerHeader’).crossSlide({
sleep: 3,
fade: 1
}, [
{ src: ‘%resource(Edward_Levinson_head_1.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_2.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_3.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_4.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_5.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_6.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_7.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_8.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_9.jpg)%’ },
{ src: ‘%resource(Edward_Levinson_head_10.jpg)%’ }
]);
});

Yu have mixed content on the jquery library being loaded. It’s also a very old version of jquery (1.7).

My guess is this i very old verion of an old theme (Qube).

Might check with @nimblehost and see if there is an update, if not change themes.

I doubt this version would have worked a https since browsers started blocking mixed content.

1 Like

Doug, thanks for the reply, I suspect you might be right. The Qube theme is quite old. Though what I had did work up until very recently. Bluehost had to redo/edit my .htaccess file some problem mistake my end. The problem appeared after that.

Curious if the problem would still exist using Rapid Weaver Classic instead of RW8?

My bet would be that the site hasn’t worked as an https since browsers began blocking active mixed content (Chrome January 2020).

If you still access the site using http , it would work. So again my guess would be the changes that the host made to your .htaccess File Forced any none secured (http) requests to be redirected to secure (https) requests.

That being said, you might be better off picking a modern, supported theme.

You could also modify the existing theme to use https instead of http . It’s not a difficult change.

3 Likes

Thanks Doug. see below

***1. I downloaded the .htaccess but not sure what I am looking for :wink:

****2. How/Where about would one modify the existing theme to use https instead of http ?

Thanks in advance, Ed

  1. In the .htaccess file you would be looking for a rewrite rule from http to https. There’s several ways to write the rule, so can’t say for certain what you’re looking for without seeing it directly.

  2. It would involve navigating to the theme in Finder, expanding package contents, then going through the theme’s files to update http links to https via a text editor. Not really a great way to do it. I would agree with teeters assessment that you would probably be better off picking a modern, supported theme and migrating your data over to it.

Rapid weaver Guy, thanks. I can see the rewrite rules in the file (not sure if its a good idea to attach or paste here) and will look into the other suggestions (self update theme or just migrate to something else). Either way will take some time.

I wouldn’t suggest that you “go back” to http, as the security warnings are probably going to keep visitors away. Down the road, I wouldn’t be surprised to see the warnings becoming more aggressive or even blocking access altogether.

The easiest and most long-term solution would be is to pick a modern supported theme. The version of qube that you are using is loading jQuery 1.7 (November 2011). The current stable jQuery version is 3.6 (March 2021).

if you are comfortable with coding then you could modify the existing template inside the theme package to simply change the HTTP links to their equivalents in HTTPS.

I’d have a look over at Themeflood (@willwood). Qube is now sold and supported by Will.

There are also a ton of other themes there, free or reasonably priced and all offer a free trial version so you can see what it looks like with your content.

Thanks Teffers, sorry for the slow reply. Just now before seeing this found the new Qube page and plan to give it a try.

UPDATE: The very kind Will Woodgate at Themeflood has helped me update my older Qube theme without having to loose all my customization I had done to it a long (with kind help from Jonathan at NimbleHost. ) I am still working on correcting a few pages but the Top page slide show was fixed, quite simply in my opinion. Highly recommend Will’s service if you need help with themes from his Themeflood page. Thanks everyone for you input. BTW Will said he wasn’t able to use the “new” RW forum for some reason.