Jpeg won't place in "Image" Stack - RW 7.5.7

Can’t by any of three means successfully place a jpeg within an Image Stack in Stacks. Can’t drag it onto the stack from the Finder. Can’t drag it onto the stack from Resources (bounces back). Can’t link to it using the stack-specific Inspector page - but if I do this Inspector page route, the image DOES APPEAR in the image stack in EDIT MODE, but DOES NOT show up in DESIGN MODE. One more thing about Inspector-linked image, it is somehow NOT REALLY THERE - ie, in edit mode, the “DROP AND IMAGE HERE” MESSAGE STILL APPEARS OVER THE IMAGE, as if the stack still thinks nothing has been placed.

One more thing: weirdly, I DID succeed at this a few days ago in a kind of first test of Stacks (bought 7/3/20). In this case, I believe it was a drag and drop from the finder. But I looked back at this instance - and even though the pic shows in design mode as well as edit mode, if I look at the Stack-specific Inspector panel, the field that would show the pic is blank (gray).

Hi Keith,

I have only just got the software but I have a similar issue with JPGs files going into the drag-and-drop panel on Collage2. A very small fraction of my JPEGS (very small) do import just fine but the majority do not. I am currently trying to work out the differences and whether there are parameters somewhere that limit file size/dimensions that can be altered, in either base FW or Collage2.

Like I said, new to this platform but will post my findings even if it means binary interrogation of the files themselves :grinning:


Hi, Andy -

Glad to know I’m not alone in this. Tearing my hair out here.
Here’s something bizarre:
RW 7 image drag and drop DID NOT work two days ago.
Yesterday it WORKED.
Today it DOES NOT work again.
I have tried quit and restart multiple times, and restart computer twice. No change in the outcome.
I’m not a coder, so no way for me to investigate - I’m at the mercy of the app.

Not sure what might be going on for either of you.
Keith(@KeithJ), you said you are using a Stacks page with RW 7.5.7. What version of Stacks are you running? You also mention " EDIT MODE" and “DESIGN MODE”, I’m assuming you are talking about “Preview Mode” vs “edit Mode”? I just tested with RW7.5.7 and Stacks v4.04 and I can drag all kinds of jPeg from the Finder into a stacks page without any problem.

Might help if you could give us a screenshot of what’s going on, also some information on the jpg file like the size and file name.

Andy(@CodeMonkey), You said you are using the Collage2 plugin. That’s probably different from the problem that Keith is experienced as they are completely different plugins (Stacks vs Collage2).

All of my failed photos are from a Canon Powershot S40 over a period of ten years. Rather a convincing pattern. I’ll pursue in a different thread rather than hijack the OP. Thanks Doug.


Hi, Doug. Thanks for the reply.
Sorry, I did in fact mean EDIT mode and PREVIEW mode.
I’m using RW 7.5.7 - purchased July 1 of this year. (Bought this instead of v.8 because I am still running El Capitan, Mac OS 10.11.6)
Stacks v. 4.0.4 - purchased 2 days later, 7/3/20. (They said this was fine w/ RW 7.)
Files I’ve tried to drop experimentally have been anywhere from 564KB to 1KB (ie, my favicon). All are 72 dpi, rgb or grayscale jpegs). Should be fine as files - I’ve been creating similar files for decades and successfully using them in websites.
I was able to drag and drop all my resource images when I started using RW7, then also into image stacks when I bought Stacks.
After a few days, I longer could, using the same files - either in a standard RW page or a Stacks page using an image stack. Here is a screen shot of a page from the site I am working with. Note the picture at right, dropped successfully a few days ago. Also note the image stack above that, into which I can no longer drop either that same image, or an other.
Thanks for any further suggestions.

My first suggestion would be NOT to use the internal resources folder in RW7. RapidWeaver had a lot of issues with the internal resource folder back in RW7. In RW8 they totally reworked it and it works much better.

With Stacks pages and RW7 using resources really didn’t buy you anything, as when you drag an image from resources the stacks plugin will make a copy of it anyway so if you change it in resources you’d have to go any change it any place you used it.

Stacks 4 and RW8 added an additional stack called site image. It won’t show up with RW7 though as it uses the new RW8 resources. That is the new “default” image stack. If you drag an image onto the page (from finder) it will be a site image. If you drag the same image onto a another RW8/S4 page it will use the same image.

With RW7 I’d suggest you just drag the image from finder directly onto the stacks page from finder. If you have a lot of images then you could also look into something called “warehousing” the images. That’s were you manage the images remotely with a stand alone FTP app on the server. Then you would use one of many “warehouse” stacks to link to the image.

If you want to use resources in RW7 then I’d suggest you use one of the “Warehouse” stacks and link to the URL.
Some free stacks for images:
A simple free WH Stack

A very Good donationware image Stack

For most average websites “warehousing” is overkill. But more info can be found here:

Doug - Thanks very much for the suggestion of drag from the desktop. Works fine. I was unaware of the RW 7 problem with the internal resources folder. Before I bought the app, I tried to find some reviews, but found virtually nothing.
As I said, can’t upgrade to 8 at this point (Mac OS issue), but some day…
Strange, I thought I had tried direct drag from desktop as well, but apparently not. In any case knew in principle it was an option.
I’ll look into the warehousing suggestion and warehouse image stacks - but for now I’m good. The site I’m currently working on is not image-heavy.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.