Just updated to RW7 - 2 problems - one in publishing; other in missing share buttons


(AZ Billy De) #1

Just updated to RW7.0.2. I made a single character change, and when I pressed Publish, RW7 published the entire site; RW 6 only published the change, very fast. Did I miss something? Is there a setting to make sure RW only publishes the change?

And second, I have some share buttons on the site through addthis.com. They disappeared in RW 7. How do I get them back?

Help and ideas would be appreciated.

Using EC 10.11.5 on a 2 year old iMac.

Thanks


(Greg Schneck) #2

If that was first time you made a change smart publishing probably needs to publish entire site so it knows everything was published. I’m just guessing. I always right clik on a page or folder to publish/export.

btw… RW7 has smart publishing only and you can’t turn if off.


(AZ Billy De) #3

Thank you 1611 Mac. I went back to RW 6 and republished the entire site because my share icons from addthis.com went away under RW7. I just put up a new blog that is getting a lot of reads and shares, 4 times what we normally get, so I need the share buttons in place.

So does anyone know why the share buttons would have disappeared?

So if anyone has a solution for me, I will be eternally grateful.

Thank you

Bill


(Greg Schneck) #4

can you provide url of site? I’d like to see the buttons (I use addthis too and mine works fine though I implement the code as part of php header includes.)


(AZ Billy De) #5

1611 Mac,

Here it is and the shares are on w=each blog posting

http://rachellneumann.com

Thanks


(Greg Schneck) #6

I see your javascript is in the HEAD section of your html. I suspect conversion to RW7 wiped it out somehow. You need to check your RW7 project and see if the addthis script is in the header. (addthis recommends it’s placement just before the close body tag) -

Did you do the setup in RW6? If so, you just need to ensure the code is somewhere for RW to inject it into the page.


(Greg Schneck) #7

the correct way to do this in RW7 is to put the Script code itself in “Settings” “Code” “Javascript” - Note that you do not put the tags in as the note says at top of page.

Of course, you still need the calling code where the buttons are to appear. They are probably still there from the conversion.

When you are ready just dup one of your blog pages, rename it “test” and publish that one page only. Then on your site manually type in the url to get the test page to see if it is working.

I always do a test page first before uploading a blog to the site when new scripts are added.


(AZ Billy De) #8

Thanks – I will look into this later and let you know!


(Greg Schneck) #9

Note… my bad… You can’t publish one page only of the blog. What I meant was :slight_smile: … Output to a local folder and then upload (ftp) just the one page.

Or better yet, setup a single non-blog test page and publish. Good Luck


(AZ Billy De) #10

1611 Mac

Thanks for your help. I am up and running!

And using RW 7!


(AZ Billy De) #11

1611 Mac

Bummer I made a small change to my blog site using RW7, republished and lost the shared icons again. I checked my iMac and my MacBook Pro and the icons were gone. SO I went back to RW6 and it has always handled the shared icons perfectly.

I will sleep on this before trying again.

Ryan Smith got back to me and suggested that I make sure that Smart Quotes was unchecked which it was. He uses Addthis shared icons and it works for him so back to square one.

Thanks again


(Greg Schneck) #12

as info… that was a good tip about smartquotes… I always use BBEdit (or TextWrangler) when I hand code or grab code. There is a “straighten quotes” features which will “fix” all quotes to be code (web) friendly. BBEdit and Textwrangler (free version) are text editors specifically for web coding.


(AZ Billy De) #13

1611 Mac

Back at this with fresh eyes.

To get the share icons back with addthis.com,

  1. where do I place the code from addthis.com?

  2. you said to remove the script tags, but i am not sure how much of that to remove. Could you provide an example of what the resulting code would look like.

  3. and that code gets placed in the javascript area in the left sidebar of RW. Does it matter if it is in the number one position?

I think that I have been messing the above up and putting things in the wrong place which has cause my problem

Thank you


(AZ Billy De) #14

1611 Mac.

These fresh eyes, re-read the RW 7 manual, and there was a comment that Smart quotes could interfere with HTML code so uncheck it BUT the note further said that Smart Quotes needed to be unchecked in OS X settings. In my case it was CHECKED! When I unchecked it and published my blog using RW7, the Share icons worked!

Problem solved

Thanks for your help!


(Kevin Atkins) #15

Having the same issue since RW7, but still can’t get it to work using the above method.

I’ve tried various combos of location for each bit of code, but no joy. I’ve been communicating with the AddThis team for a few days now, and they’ve finally come back with ‘contact your framework support team.’ That would be me.

They’ve given me some alternative code to try, but none of that has worked either.

I have one more combo to try, but I’m not holding out much hope. Is there a decent Stack that will do the job?


(Kevin Atkins) #16

A quick update.

I’ve tried the methods above, but still no joy. After coms with AddThis, who have had a similar issue with Shopify. It appears that a ‘version’ reference is being put into the code that calls the AddThis widget, and it’s this that’s preventing the boxes from appearing … you can see where, below, just after the ‘addthis_widget.js?’ bit (I’ve removed the tags) …

src="//s7.addthis.com/js/300/addthis_widget.js?v=489509137"

The code is some custom code they supplied me with for testing, and it doesn’t contain the v in the app: RW is inserting this on publishingfor some reason.


(Kevin Atkins) #17

Another update: with the help of the AddThis team, I’ve managed to get everything working.

It didn’t help that they were seeing a cached version of the pages under investigation.


(AZ Billy De) #18

Hi,

I started this thread. Today after updating to RW 704, it happened again that the share icons are not appearing. I went through everything that I did above to make the icons appear but to no avail.

If Kevin is out there, what code did addthis give you? I have also contacted addthis support but have not heard back.

Thanks


(Kevin Atkins) #19

Yes… I’m certainly ‘out there!’

I was given two sections of code to replace all and any existing AddThis code on the site. Here’s what I had:

<script type="text/javascript"> var addthis_config = addthis_config || {}; addthis_config.pubid = 'PUTYOURPUBIDHERE'; </script>

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js"></script>

and

Both bits of code went into the Settings/Code/Body area in RW7, and I replaced PUTYOURPUBIDHERE with my pub id. You can get this from your embed codes in the AddThis dashboard, after setting up a widget.

I did have to remove all existing AddThis code, though, as some old stuff was clashing with the new stuff, so make sure that this is the ONLY AddThis on the page. And make double-sure that you’re not looking at a cached page when checking!

Hope that helps. This ‘fix’ is actually for an issue with Shopify sites, but this works for me … let me know if it does for you.

Oh, and forgot: the ‘v’ wasn’t the issue after all, apparently, so I’m not sure why they mentioned it!


(AZ Billy De) #20

Kevin,

I applied your code with my id and it worked! The addthis icons are back.

Thank you!

Bill