RW 7 Publishing is Ruining My Site - SOLVED


(Bill Hall) #1

Hello- Ok, very frustrating transition from 6 to 7. Not sure why this needs to be so difficult.

Just upgraded from 6 to 7… opened the project in 7, change 1 letter in the body text, and publish… The site is not publishing correctly (no header images and other formatting problems). The only way to fix it is to go back to RW6 and re-publish all files. In reality, I don’t notice any difference in speed (I have 7 set at level 5), but that’s a different story.

Are others finding general formatting problems and removing the header(s)/Banner images? I’m running 7.0.4, MichaelDavidDesign theme with latest stacks and 10.11.6

Thx.


Added Code after upload
(Greg Schneck) #2

When you published from 7 did you publish all files?


(Greg Schneck) #3

Also… 7.1 is close to being released. I would wait for an official 7.1 release. I would stay on 6 until then.


(Bill Hall) #4

Thx for the info. I’ve tried both publish all and just changing a page.

So what exactly is/are the advantage(s) of RW7?

Thx!


(Salim) #5

Ive updated to 7.0.4

It seems that upon update the Rapidweaver is adding some code to all links in the page source code - on all places with href= … or src=… there is something like this added ?rwcache=492275561
This breaks the script code.
Please advise on solutions.


(Bill Hall) #6

Ok… after a TON of trouble shooting (and good help from RMS support), it was a problem with Google Code being duplicated when RW converted the file from 6 to 7. Now that we found that, it is publishing ok.

On another note, I’ve now spent quite a bit of time with RW7 and really like it. I LOVE the settings section that is awesome and worth the upgrade itself. I just RW7 easier to work in and it flows better.


(scott williams) #7

You should edit thread title and add SOLVED


(Clint Hansen) #8

This thread is marked solved, but I am looking for the solution?? I too have “?rwcache=492275561” plastered all over my coding and it has messed up a site that has worked for years. I read its Google coding duplicated, but how was the problem fixed, where do I find the duplicated script and how do I keep this from happening again?
Please respond with the solution, its greatly needed right now.


(Bill Hall) #9

In RW 7, the only way to ‘fix’ this was to completely remove the google remarking code. I’ve read other places since this post that this seems to be a problem with the google code on some platforms/templates.


(Michael Forte) #10

What is the “google remarking code” and where do I find it? Can you show an example of what you are talking about? I have several snippets of google code (adsense, analytics, etc); is it one of those?


(Doug Bennett) #11

Take a look at this thread:


If your problem is rwchache= being added this should solve it.