Map 2 Lost Again

I had an issue with Map 2 in October which was resolved and my maps displayed correctly. Today I went to do some updates on the site and once again am getting an error message. I haven’t changed anything. I’ve emailed Gary at Doobox, however I’m posting here

in case I’ve missed an update of some sort. It’s for a home builder site which relies heavily on maps and directions:

Looks like you got it fixed?

I wish! No that’s the site now. Last edits from October. Working on update now in RW which I opened this morning and the maps are gone again so can’t publish my updates until I get them up and running again.

Without publishing the page, it’s going to be hard for anyone here to help you out.

Have you looked at the console?


Hi Doug - I can’t publish the update with no maps. My clients site is for real estate developments and the maps and directions are critical. If I sync the update the maps will disappear. Still waiting to hear from Gary at Doobox.

Did you have a look at the console in the browser? It might give you a clue.

You could publish a test page without affecting the production page.

Assume you have an API key from Google?

I just tried Maps 2, If you don’t put in the api key you don’t get the Oops screen. I have a really old key and got the error.

I don’t use Google maps any longer so I don’t know if my key is good.

Hi Mark,
you are not alone ;o)
Same problem here … from time to time.
Without making any changes - sometimes the maps are there - sometimes not.
… have no idea why, either…

Did you check the console?

Seems like Google is always changing things on its map api.

Might give Open Street Maps a look. It’s open-source no key needed and no customer privacy concerns.

1 Like

Yes. Same problem here too.

Map 2 had an update today.

If you want to preview maps you have to make some changes to Google.
Check out the release notes:

I haven’t tried, just relaying the info.

For it! Excellent - many thanks to Gary :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.