Missing resources?

In the middle of working on a complicated web site (and I had been saving frequently), I got the following error message–it seems as though many o my resources have vanished:

I don’t know how to get these back, and I don’t understand why it says that the files are accessible. HELP!!

I’ve never gotten this before, but others have.

Have you tried the Relink… option?

That wouldn’t work, because Rapidweaver apparently has renamed all of the resources to completely unrecognizable names, so I’d have no idea what I was linking. This is a really, really terrible bug–it apparently happened when I was attempting to view the site. I reverted the file back to last night, which means I lost a couple of hours of work this morning–better that than weeks of work. I’d like to know why this happened, and whether it’s possible to avoid it in the future.

@crashdown Heather: Yes, this is a scary bug. I’ve only had it happen once. Seemingly out of nowhere. I think it happened as I started up. No upgrade recently, etc. etc. Fortunately I only had one image to relink so the change in name was not a big deal. But for most folks it would be a nightmare.

I have no idea why this happens but it’s been reported before. I have no idea whether a solution is being worked on. Hopefully @tpbradley or @dan can let us know more.

The only sure fire way I know to avoid this is to NOT use resources. In the main that’s exactly what I do. This means first uploading your “stuff” (images, PDFs, etc.) to your hosting server via FTP software. (You could also do this via the Repository stack by @instacks ). Then you copy a link from each file (image, PDF, etc.) and use in your stack. Most stacks that work with images and other things have an option to use a link to a remote/warehoused file. Many/most photo gallery stacks allow you to point to a folder instead of one file so that makes creating galleries using this approach very easy.

If you have never done FTPing of your work to the server there’s a little bit to learn: but quite doable. And you’d have to find some decent FTP software like Transmit (paid) or Filezilla (free).

… however, before going down this road you want to make sure the stacks you use allow for remote linking. Many, but not all, stacks have this capability.

1 Like

Did you use any maintenance software like cleanmymac or others? Perhaps even running on a schedule so you might have not noticed? Or a virus scan? Sometimes this leads to a corrupted rw file…

Nope, nothing like that. It happened when I went to preview the file. When I checked Dropbox (which allowed me to revert to the file before this happened), it showed me a point where I apparently deleted all of my resources. I SO DID NOT!!

It sounds like you’re saving you project directly to a Dropbox folder. A number of people have reported corruption caused by DB syncing. This likely could have caused your issue. Some users have switched to saving to iCloud and reported it worked better. Others are copying the project file to their desktop (out of DB), working on it and then copying back to DB.

3 Likes

I’ve been using resources quite a lot since Rapid Weaver 8 was released and have never had a problem.

As Don @DLH said, there have been lots of people who are or have been using Dropbox that have been reporting corrupted project files.

That’s essentially what the missing resources message is, a type of corrupt project file. Your RW project file is actually a special kind of folder called a package that consists of a bunch of other files that make up the “project”. Any Irregularities in this folder can make the project unusable.

This Dropbox corruption has happened to people weather they use resources or not.

More can be found on the forum, most people are switching away from Dropbox to iCloud or other services.

1 Like

If it is at all possible for you, depending on the size of these resources, you might consider switching on ‘Copy into the document’ of the ‘Site Resources’. This setting can be found under ‘Settings’, ‘Advanced’ in the left sidebar. You’ll never lose them again.

That’s an interesting idea–I had never heard of that. How big is too big?

I don’t know. My resources are only images and my RW8 files are 700MB and 500MB. Which of course also include images in styled-text pages, and on other places where resources cannot be chosen.

For the exact answer, you may contact someone at Realmac.

I hate to spoil the party on this one, but the one time I did have this “resource links missing” issue was when my one and only resource had been copied into the project file. So, for whatever reason, this is NOT a failsafe technique. I definitely suggest doing it for many reasons, but don’t expect it to be perfect going forward in terms of this one bug/issue that’s going on.

The safest approach will be to use remote image links and place on your server directly.

Moving off of Dropbox will probably help and is a sensible move to make.

I disagree,

The safest approach would be to Remove the project from Dropbox. Lots of people have reported Dropbox no longer working for RW project files on this forum and others.

@teefers You can disagree all you want but the evidence was: Project corrupted and project was in iCloud. Not Dropbox.

My plugins/stacks were in Dropbox: that’s true. But in that case I should have some more consistent problems across projects.

I also agreed that moving plugins/stacks away from Dropbox might help. There’s nothing bad with doing this and it might result in better outcomes.

… but it does seem there is a stray bug out there caused by what? We don’t know. I’m not sure it is a Dropbox “thing”. It may be but we don’t have evidence that it really is: just guessing right now.

Good advice thought it may be, I’m not removing my projects from Dropbox. My reasons are as follows: (1) In doing research on this board, I see that the corrupted resource problem is not limited to Dropbox users; (2) I’ve used Dropbox for Rapidweaver for at least ten years, and I’ve never had a problem with any file corruption before this one; and (3) if it weren’t for Dropbox’s easy ability to roll back file versions, I’d have been in a LOT more trouble than I was–I only lost a couple of hours of work, not days of work. So right or wrong, I’m sticking with it.